Author Topic: Raspberry Pi F.A.Q.  (Read 17865 times)


  • Hero Member
  • *****
  • Posts: 656
    • View Profile
Re: Raspberry Pi F.A.Q.
« Reply #15 on: December 31, 2017, 11:36:20 AM »
Yes i tried with different adaptators (2.4a, 3a, short cable with good copper quality...), the next time i'll try with the j4 flag.
The command is "make -j4" (with a space between)?
I've had some problems with my personal ES themes and some updates since the last retropie 4.3.8, however eveything was ok with the 4.3.6. Maybe it come from here...
Thanks for your reply.


SFML install
Code: [Select]
sudo make -j4 install
FFMPEG install
Code: [Select]
make -j4
AM install
Code: [Select]
make -j4 USE_GLES=1
These aren't going to change anything except the amount of time it take to compile. It will allow you to try a fresh build more quickly.

It's important to note that the SFML compile commands have changed recently to support the latest Pi firmware. If you're using the older firmware you need to adjust the SFML command accordingly.
Code: [Select]
cmake .. -DSFML_RPI=1 -DEGL_INCLUDE_DIR=/opt/vc/include -DEGL_LIBRARY=/opt/vc/lib/ -DGLES_INCLUDE_DIR=/opt/vc/include -DGLES_LIBRARY=/opt/vc/lib/


  • Newbie
  • *
  • Posts: 4
    • View Profile
Re: Raspberry Pi F.A.Q.
« Reply #16 on: January 05, 2018, 03:46:58 PM »
Hi, effectively the j4 flag is a lot faster! So i tried with the new and the old SFML cmake commands, it's working when i go to attract just after the install but after a reboot, i've some errors like "no file or directory" about and files.
But the files are in the /usr/local/lib directory. However there were no errors during the install. My firmware is :
Linux retropie 4.4.13-v7+ #894 SMP Mon Jun 13 13:13:27 BST 2016 armv7l GNU/Linux