Author Topic: executable "cmd" on linux?  (Read 262 times)

qqplayer

  • Sr. Member
  • ****
  • Posts: 140
    • View Profile
executable "cmd" on linux?
« on: August 07, 2017, 04:07:26 AM »
How can I set executable as a command line on a linux system?
On windows I set "cmd" and then pass the comand line with arguments.

progets

  • Sr. Member
  • ****
  • Posts: 476
    • View Profile
Re: executable "cmd" on linux?
« Reply #1 on: August 07, 2017, 07:26:56 PM »
"/bin/bash"

qqplayer

  • Sr. Member
  • ****
  • Posts: 140
    • View Profile
Re: executable "cmd" on linux?
« Reply #2 on: August 14, 2017, 02:12:09 PM »
Thanks , is working now.
I have another problem.

I have assigned escape key to exit emulator but when I press this key it exits from the game to the retroarch gui.
On my windows build I've used autohotkey or "cmd" "taskill" to kill retroarch and return to AM.

Any command or idea to kill the emulator process with a key on a rpi?

Thanks.
« Last Edit: August 14, 2017, 02:13:49 PM by qqplayer »

progets

  • Sr. Member
  • ****
  • Posts: 476
    • View Profile
Re: executable "cmd" on linux?
« Reply #3 on: August 14, 2017, 09:22:56 PM »
You should setup your emulators with the proper exit key(s)/button(s) and not use the AM setting to exit. RetroArch's default key to exit is "Esc" but you're sending it to AM instead of RetroArch by having this set.

Are you using RetroPie as your base build? If so, run EmulationStation and setup your keyboard and controls there. It will create the proper exit keys for the emulators when you run them in Attract-Mode. Once you have that setup there is no need for any cmd, taskkill, etc. There is also no need to use the AM setting to exit emulators.

qqplayer

  • Sr. Member
  • ****
  • Posts: 140
    • View Profile
Re: executable "cmd" on linux?
« Reply #4 on: August 15, 2017, 03:04:01 PM »
I know but for some reason when I launch the mame core It doesnt close the emulator propertly.
I set esc key on emulationstation and on AM but only exits from the game to the retroarch gui.

progets

  • Sr. Member
  • ****
  • Posts: 476
    • View Profile
Re: executable "cmd" on linux?
« Reply #5 on: August 15, 2017, 05:20:21 PM »
I know but for some reason when I launch the mame core It doesnt close the emulator propertly.
I set esc key on emulationstation and on AM but only exits from the game to the retroarch gui.

If you used EmulationStation to set it up, the key you choose for "Select" is the hotkey and the key you choose for "Start" is used to exit (with the hotkey). So "Select+Start" is how you would exit.

qqplayer

  • Sr. Member
  • ****
  • Posts: 140
    • View Profile
Re: executable "cmd" on linux?
« Reply #6 on: August 20, 2017, 02:20:01 AM »
Finally solved , I have disabled this line at retroarch.cfg

Code: [Select]
#input_enable_hotkey = "space"
Clean the "es_input.cfg" and reasign all the keys.

Then reasign "ESC" to exit emulator on AM and now all works ok  ;D