Author Topic: Version 2.3 Released  (Read 1551 times)

keilmillerjr

  • Sr. Member
  • ****
  • Posts: 364
    • View Profile
Re: Version 2.3 Released
« Reply #30 on: December 05, 2017, 07:05:45 PM »
ShLt. I didn’t actually try running the bundle. We have a problem.

Code: [Select]
Keils-iMac:~ keiljr$ cd /Applications/Attract.app/Contents/MacOS
Keils-iMac:MacOS keiljr$ /Applications/Attract.app/Contents/MacOS/attract
objc[57392]: Class SFApplication is implemented in both /usr/local/lib/libsfml-window.2.4.dylib and /Applications/Attract.app/Contents/libs/libsfml-window.2.4.2.dylib. One of the two will be used. Which one is undefined.
objc[57392]: Class SFApplicationDelegate is implemented in both /usr/local/lib/libsfml-window.2.4.dylib and /Applications/Attract.app/Contents/libs/libsfml-window.2.4.2.dylib. One of the two will be used. Which one is undefined.
objc[57392]: Class SFOpenGLView is implemented in both /usr/local/lib/libsfml-window.2.4.dylib and /Applications/Attract.app/Contents/libs/libsfml-window.2.4.2.dylib. One of the two will be used. Which one is undefined.
objc[57392]: Class SFSilentResponder is implemented in both /usr/local/lib/libsfml-window.2.4.dylib and /Applications/Attract.app/Contents/libs/libsfml-window.2.4.2.dylib. One of the two will be used. Which one is undefined.
objc[57392]: Class SFWindow is implemented in both /usr/local/lib/libsfml-window.2.4.dylib and /Applications/Attract.app/Contents/libs/libsfml-window.2.4.2.dylib. One of the two will be used. Which one is undefined.
objc[57392]: Class SFBlackView is implemented in both /usr/local/lib/libsfml-window.2.4.dylib and /Applications/Attract.app/Contents/libs/libsfml-window.2.4.2.dylib. One of the two will be used. Which one is undefined.
objc[57392]: Class SFWindowController is implemented in both /usr/local/lib/libsfml-window.2.4.dylib and /Applications/Attract.app/Contents/libs/libsfml-window.2.4.2.dylib. One of the two will be used. Which one is undefined.
objc[57392]: Class SFViewController is implemented in both /usr/local/lib/libsfml-window.2.4.dylib and /Applications/Attract.app/Contents/libs/libsfml-window.2.4.2.dylib. One of the two will be used. Which one is undefined.
Attract-Mode v2.3.0-12 (OSX, SFML 2.4)
avcodec 57.107.100 / avformat 57.83.100 / swscale 4.8.100 / swresample 2.9.100

Config: /Users/keiljr/.attract/attract.cfg

*** Initializing display: 'NeoGeo'
 - Loaded master romlist 'mame' in 176 ms (147 entries kept, 10 discarded)
 - Constructed 10 filters in 0 ms (1470 comparisons)
Segmentation fault: 11


estefan3112

  • Jr. Member
  • **
  • Posts: 17
    • View Profile
    • Retrogaming on my Mac
Re: Version 2.3 Released
« Reply #31 on: December 06, 2017, 03:13:02 AM »
Same segfault here. What worked for me wasanually copying the new binary into the 2.2.0 App container and replacing the confit data in .attract with the newly compiled data. Far from perfect, however running  :D.

keilmillerjr

  • Sr. Member
  • ****
  • Posts: 364
    • View Profile
Re: Version 2.3 Released
« Reply #32 on: December 06, 2017, 05:00:14 AM »
Same segfault here. What worked for me wasanually copying the new binary into the 2.2.0 App container and replacing the confit data in .attract with the newly compiled data. Far from perfect, however running  :D.

Used a hex editor to compare bin and bin inside bundle, and they are not the same. create-pkg.sh line 73 is not copying the bin correctly. Not sure why. Manually copying it within the finder works, but it has to be something stupid. I’ll look into it some more tonight.

estefan3112

  • Jr. Member
  • **
  • Posts: 17
    • View Profile
    • Retrogaming on my Mac
Re: Version 2.3 Released
« Reply #33 on: December 06, 2017, 01:15:00 PM »
I can confirm this and manually modified the dmg by adding the running binary to it.
The compressed image is ready for download and install.
Here it is  ;D.

https://drive.google.com/file/d/1Gjt-YKvH97lt78biQuBdtxTU9W8B6Bba/view?usp=sharing

If this successfully installs with Mac users, it would be great to know!
Not the most elegant way, but we are getting somewhere!
Cheers!

keilmillerjr

  • Sr. Member
  • ****
  • Posts: 364
    • View Profile
Re: Version 2.3 Released
« Reply #34 on: December 06, 2017, 02:15:48 PM »
I am still wondering what is going on though.

I changed line 73 of create-pig.sh to move the file (mv) instead of copying it, and the resulting binary inside the bundle inside the dmg is still altered. Maybe something to do with making the dmg?

kent79

  • Sr. Member
  • ****
  • Posts: 426
    • View Profile
Re: Version 2.3 Released
« Reply #35 on: December 08, 2017, 06:24:09 PM »
Dear raygun

I find some issue on version 2.3. The image width is something wrong. All images width can't cover the screen

You may try to download my theme to look at this issue.
http://forum.attractmode.org/index.php?topic=1824.0

Below is example:

local flw = fe.layout.width;

Version 2.2 or before
local topBar = fe.add_image("white.png",0, 0, flw, 25 )
--------------------------------------

Version 2.3
local topBar = fe.add_image("white.png",0, 0, flw + 1, 25 )
« Last Edit: December 08, 2017, 06:42:39 PM by kent79 »

cosmo

  • Full Member
  • ***
  • Posts: 53
    • View Profile
Re: Version 2.3 Released
« Reply #36 on: Yesterday at 02:37:38 AM »
i'm having a segmentation fault trying to compile AM on the Raspberry Pi. Am i doing something wrong?
Code: [Select]
cd ~
mkdir develop

sudo apt-get install cmake libflac-dev libogg-dev libvorbis-dev libopenal-dev libjpeg62-turbo-dev libfreetype6-dev  libudev-dev libfontconfig1-dev

cd ~/develop
git clone --depth 1 https://github.com/mickelson/sfml-pi sfml-pi
mkdir sfml-pi/build;cd sfml-pi/build
cmake .. -DSFML_RPI=1 -DEGL_INCLUDE_DIR=/opt/vc/include -DEGL_LIBRARY=/opt/vc/lib/libEGL.so -DGLES_INCLUDE_DIR=/opt/vc/include -DGLES_LIBRARY=/opt/vc/lib/libGLESv1_CM.so
sudo make install
sudo ldconfig

cd ~/develop
git clone --depth 1 git://source.ffmpeg.org/ffmpeg.git
cd ffmpeg
./configure --enable-mmal --disable-debug --enable-shared
make
sudo make install
sudo ldconfig

cd ~/develop
git clone --depth 1 https://github.com/mickelson/attract attract
cd attract
make USE_GLES=1
sudo make install

Everything compiles fine, but AM gives a segmentation fault and dont work.  :-\

If i install it from the experimental packages on retropie, it works, but it doesn't have mmal hardware acceleration. Any help?  :P