Author Topic: Games not starting with Retroarch, config files wrong?  (Read 53 times)

Trag0z

  • Newbie
  • *
  • Posts: 2
    • View Profile
Games not starting with Retroarch, config files wrong?
« on: September 05, 2017, 05:50:09 AM »
Hey there!

I set up a system on an old PC using Arch Linux, Retroarch and Attract Mode. Retroarch runs fine but when I try to start a game in Attract, nothing happens. I played around a lot with the emulator config files, but I can't get it to work.

This is my mame.cfg file:
Code: [Select]
# Generated by Attract-Mode v2.2.1-52
#
executable           retroarch
args                 -L ~/.config/retroarch/cores/mame_libretro.so "[romfilename]"
rompath              $HOME/roms/mame
romext               .zip
system               Arcade
info_source          thegamesdb.net
artwork    flyer           $HOME/emulators/mame/flyers
artwork    marquee         $HOME/emulators/mame/marquees
artwork    snap            $HOME/emulators/mame/videos
artwork    wheel           $HOME/emulators/mame/wheels

If I try to run a game in Attract, the output in the terminal just says:
Code: [Select]
*** Running: retroarch -L ~/.config/retroarch/cores/mame_libretro.so "/home/trag0z/roms/mame/pacman.zip"So, no errors? (There are error messegas before that, but they're just about images missing in my layout)

If I type the same command into the terminal, the game works fine:
Code: [Select]
retroarch -L ~/.config/retroarch/cores/mame_libretro.so "/home/trag0z/roms/mame/pacman.zip"
So, I'm kinda lost here. Tell me if you need more information or something, any help would be greatly appreciated! :)

Cheers,
Trag0z

mc2programmer

  • Jr. Member
  • **
  • Posts: 11
    • View Profile
Re: Games not starting with Retroarch, config files wrong?
« Reply #1 on: September 06, 2017, 06:57:17 PM »
Hi Trag0z! I do not use the Arch Linux flavor, but can you verify the path of the cores?

this is a config for Mint... notice the path to the cores they are in  /usr/lib/libretro/nestopia_libretro.so

executable           retroarch
args                 --libretro /usr/lib/libretro/nestopia_libretro.so "/media/emulation/Attract-Mode/roms/Nintendo Entertainment System/[name][romext]"
rompath              /media/emulation/Attract-Mode/roms/Nintendo Entertainment System/

for whatever reason the ppa doesn't install cores in the retroarch install folder and this could be true for the compile install. Best way to verify this is to just launch retroarch and go to settings and check the directory that retroarch uses for cores if it is set to the /user/lib... path you could just change it there. Let me know what you get.

Trag0z

  • Newbie
  • *
  • Posts: 2
    • View Profile
Re: Games not starting with Retroarch, config files wrong?
« Reply #2 on: September 07, 2017, 06:18:15 AM »
Hi mc2programmer!

Thx for your input! I downloaded the cores through the retroarch menu and the default path was ~/.config/retroarch/cores, so that was correct.

I got it to work though. Changed these lines in my config and added the last one:
Code: [Select]
args                 -L home/trag0z/.config/retroarch/cores/mame_libretro.so "[romfilename]"
rompath              home/trag0z/roms/mame
workdir              /

So I guess the problem was that $HOME and ~/ did not work in the config file. I also had to specify the working directory because otherwise I would have to cd to / in the shell before running attract.

Now I have to fix some stuff in my layout and my arcade cabinet will be good to go! ;)