Author Topic: Another Retroarch issue in Attract Mode  (Read 89 times)

flaviobello

  • Jr. Member
  • **
  • Posts: 10
    • View Profile
Another Retroarch issue in Attract Mode
« on: September 10, 2017, 07:52:46 AM »
Hi all,

i'm trying to setup my system based on Retroarch, and facing this weird issue that i can't fix:

here's my snes config, it Works fine with no problem:
Code: [Select]
executable           C:\RetroArch\retroarch.exe
args                 "[romfilename]" -L cores\bsnes_mercury_balanced_libretro.dll -fullscreen
workdir              C:\Retroarch\
rompath              C:\ROMS\snes
romext               .zip;.sfc
system               SNES
info_source          thegamesdb.net
exit_hotkey          Joy0 Button9
artwork    flyer           
artwork    marquee         C:\ROMS\snes\images\marquee
artwork    snap            C:\ROMS\snes\images\snap
artwork    wheel 

and now my Neogeo FBA system, but this don't work:
Code: [Select]
executable           C:\RetroArch\retroarch.exe
args                 "[romfilename]" -L cores\fbalpha_libretro.dll -c configs\fb_alpha_libretro.cfg -fullscreen
workdir              C:\Retroarch\
rompath              C:\ROMS\neogeo
romext               .zip;
system               Arcade
info_source          thegamesdb.net
exit_hotkey          Joy0 Button9
artwork    flyer           
artwork    marquee         C:\ROMS\neogeo\images\marquee
artwork    snap            C:\ROMS\neogeo\images\snap
artwork    wheel           

So, if the configs are basically the same, why neogeo, or FBA games won't launch?

nitrogen_widget

  • Sr. Member
  • ****
  • Posts: 296
    • View Profile
Re: Another Retroarch issue in Attract Mode
« Reply #1 on: September 11, 2017, 09:29:23 AM »
When I run into issues with emulators launching I open a command prompt and run the command to launch a rom manually to see the error message.


mc2programmer

  • Jr. Member
  • **
  • Posts: 11
    • View Profile
Re: Another Retroarch issue in Attract Mode
« Reply #2 on: September 11, 2017, 12:38:47 PM »
I had something similar with Sega CD today was doing a new setup on a Linux box, and I did not have the bios files in the systems folder in retroarch... does neogeo fba have a bios?... neogeo.zip? I think not sure never ran it. If it does make sure you have it in the directory that retroarch is looking for... default I think is system or systems... can not remember off the top of my head. If you are not sure what I mean look in retroarches menu under config and directories and see where your bios/system directory is pointing and stick the neogeo bios in there.

This would explain the config thing... if the configs are the same... SNES doesn't have or need a bios associated with it...

let me know if this helps.
« Last Edit: September 11, 2017, 12:46:13 PM by mc2programmer »

flaviobello

  • Jr. Member
  • **
  • Posts: 10
    • View Profile
Re: Another Retroarch issue in Attract Mode
« Reply #3 on: September 12, 2017, 04:22:26 PM »
nice, great tips,
i haven't think about it, thanks a lot!