Author Topic: Game Station Theme v2.6.3 (Support 4:3 & Wide Screen now)  (Read 22967 times)

kent79

  • Sr. Member
  • ****
  • Posts: 355
    • View Profile
Game Station Theme v2.6.3 (Support 4:3 & Wide Screen now)
« on: December 24, 2015, 09:35:51 PM »
Game Station supported for 4:3 & Wide Screen now. Please download correct layout theme. It supports multi emulator purpose.

I would like to say thank you first to AM development team, liquid8d, version, omegaman, xbs, Bgoulette. They help me a lot for the new layout.

Preview Here: https://youtu.be/d8VyyXFjrpA


Change Log in new version:

1. Add layout mode option (default is simple)
Simple mode - for new user, display wheel logo and single back group color only, but color can be customized in option   
Expert mode - for advanced user, system, logo, wheel logo and back group color (each catalog each color) setup by layout.nut file manually

2. Add game list display option (listbox only, listbox + spin, spin only) (default is listbox + spin)
If you are using old machine, recommend using listbox only

3.Display logo by (wheel only, wheel + system, system only) (default is system only) 

4. Add CRT effect option for video screen (default is No)

5. Add Preserve aspect ratio of Flyer option (default is No)

6. Display spin by (snap,wheel) (default is snap)

7. Add animation effect

8. Add scrolling effect for display title   ->  It is not support this moment until liquid8d update a new scrolling module.

9. Layout improvement

Current download version  v2.6.3
« Last Edit: March 02, 2016, 08:11:22 PM by kent79 »

kent79

  • Sr. Member
  • ****
  • Posts: 355
    • View Profile
Re: New Theme - Game Station Theme
« Reply #1 on: December 25, 2015, 05:12:04 PM »
This is final version  :)
« Last Edit: December 26, 2015, 05:18:44 PM by kent79 »

Namachieli

  • Full Member
  • ***
  • Posts: 29
    • View Profile
Re: New Theme - Game Station Theme
« Reply #2 on: December 26, 2015, 06:48:41 PM »
This looks really cool. I will be checking it out. Thanks!
kubuntu 14.04 x64. i5 4690k, 16 GB RAM, EVGA GTX 750ti, DS3 SIXAXIS via BT/USB, RetroArch/libretro.

kent79

  • Sr. Member
  • ****
  • Posts: 355
    • View Profile
Re: New Theme - Game Station Theme [Phase 2 WIP]
« Reply #3 on: December 27, 2015, 11:30:26 PM »
This theme is going to Phase 2, it will be more improvement in next version.  :)
« Last Edit: December 27, 2015, 11:48:22 PM by kent79 »

kent79

  • Sr. Member
  • ****
  • Posts: 355
    • View Profile
Re: New Theme - Game Station Theme [Phase 2 WIP]
« Reply #4 on: December 28, 2015, 06:31:22 AM »
You may see it in next version  :)

https://youtu.be/mdbmNmg1chE
« Last Edit: December 28, 2015, 08:13:42 AM by kent79 »

kent79

  • Sr. Member
  • ****
  • Posts: 355
    • View Profile
Re: New Theme - Game Station Theme [Phase 2 WIP]
« Reply #5 on: December 29, 2015, 05:50:20 AM »
I am happy to say Phase 2 is being completed. Just left one more, I am asking scrolling effect question in scripting page. Please help me if you know how to do. Many Thanks. 

Change Log
- add shrink animation effect for display logo
- remove display marquee image
- add CRT option for video screen, default is disable
- add scrolling effect for display title   
- add game list
- layout improvement
- bugs fix

 :)




 

liquid8d

  • Global Moderator
  • Sr. Member
  • *****
  • Posts: 404
    • View Profile
Re: New Theme - Game Station Theme [Phase 2 WIP]
« Reply #6 on: December 29, 2015, 02:23:49 PM »
This looks really great :) Feels a little busy for my taste, but maybe you can add options for whether to display the video list and alternate/choose which artwork is displayed.

Namachieli

  • Full Member
  • ***
  • Posts: 29
    • View Profile
Re: New Theme - Game Station Theme [Phase 2 WIP]
« Reply #7 on: December 29, 2015, 07:26:38 PM »
Love the V2 footage. Can't wait!
kubuntu 14.04 x64. i5 4690k, 16 GB RAM, EVGA GTX 750ti, DS3 SIXAXIS via BT/USB, RetroArch/libretro.

Namachieli

  • Full Member
  • ***
  • Posts: 29
    • View Profile
Re: New Theme - Game Station Theme [Phase 2 WIP]
« Reply #8 on: December 29, 2015, 08:08:42 PM »
So i tried out the v1 and it looks good, but the text that would appear in the lower part of the screen is just blank.

I have the included font installed (Ubuntu 14.04) and I even tried changing the font to a know good (working on other layouts.)

Ideas?

kubuntu 14.04 x64. i5 4690k, 16 GB RAM, EVGA GTX 750ti, DS3 SIXAXIS via BT/USB, RetroArch/libretro.

obby

  • Newbie
  • *
  • Posts: 7
    • View Profile
Re: New Theme - Game Station Theme [Phase 2 WIP]
« Reply #9 on: December 30, 2015, 02:21:20 AM »
So i tried out the v1 and it looks good, but the text that would appear in the lower part of the screen is just blank.

I have the included font installed (Ubuntu 14.04) and I even tried changing the font to a know good (working on other layouts.)

Ideas?
Same, also on Ubuntu 14.04

kent79

  • Sr. Member
  • ****
  • Posts: 355
    • View Profile
Re: New Theme - Game Station Theme [Phase 2 WIP]
« Reply #10 on: December 30, 2015, 04:38:35 AM »
Dear All,

For Phase 2, I would like to simplify the theme. The layout is only provided single background color, but you can customize color from option. I wish it can help new user to setup (don't need coding)

Task:

- add customize background color option-> WIP
- add shrink animation effect for display logo
- remove display marquee image
- add CRT option for video screen, default is disable
- add scrolling effect for display title   ->wait for liquid8d update script
- add game list
- add option to select display type of game list
- layout improvement
- bugs fix -> WIP

Below is the latest layout screen shot
« Last Edit: December 30, 2015, 06:09:43 AM by kent79 »

kent79

  • Sr. Member
  • ****
  • Posts: 355
    • View Profile
Re: New Theme - Game Station Theme [Phase 2 WIP]
« Reply #11 on: December 30, 2015, 06:58:12 AM »
So i tried out the v1 and it looks good, but the text that would appear in the lower part of the screen is just blank.

I have the included font installed (Ubuntu 14.04) and I even tried changing the font to a know good (working on other layouts.)

Ideas?

Since I am using windows, could you help to try as below? Thanks.

1. Can you try to edit attract.cfg file as correct font path?
font_path            %SYSTEMROOT%/Fonts/
2. Can you take a screenshot for me to see the problem?
3. How about of using other font for the layout?
4. How about of using the "roboto" font for other layout? 
5. Please press Tab button to AM configure page like as below, can you see apply the  "roboto" font. If success to apply it, it means the issue is coming from layout. If doesn't, it should be related of AM. I think you should ask for AM developer

« Last Edit: December 30, 2015, 12:46:48 PM by kent79 »

Namachieli

  • Full Member
  • ***
  • Posts: 29
    • View Profile
Re: New Theme - Game Station Theme [Phase 2 WIP]
« Reply #12 on: December 30, 2015, 12:36:26 PM »
So it looks like the font is fine here (see the text "C 34/249" for roboto and coolvetica) as it clearly changes for the 'not working' images.

What I did notice is when running attract from command line for more debugging, i got this:

http://pastebin.com/QU8qXXdi

Specifically

Code: [Select]
ls: cannot access /home/emulator/.attract/modules/animate: No such file or directory
Hmmmmm...

After investigating I found the animate module (and others) and saw that these weren't included in the 1.6.0 deb (not sure they should be, just saying).

so hats off to you Kent79, you did just fine and this layout is great! :)

For the next person with this issue, take these steps;

Install git (if you haven't)
Code: [Select]
apt-get install git

Make sure the modules directory exists and create it if it doesnt.
Code: [Select]
ls -l ~/.attract
mkdir ~/.attract/modules

Clone liquid8d's repo to .attract dicussed in this thread - http://forum.attractmode.org/index.php?topic=194.msg1515#msg1515
Code: [Select]
cd ~/.attract
git clone https://github.com/liquid8d/attract-extra.git
Code: [Select]
Cloning into 'attract-extra'...
remote: Counting objects: 1044, done.
remote: Total 1044 (delta 0), reused 0 (delta 0), pack-reused 1044
Receiving objects: 100% (1044/1044), 27.24 MiB | 6.29 MiB/s, done.
Resolving deltas: 100% (458/458), done.
Checking connectivity... done.

Copy the contents of ~/.attract/attract-extra/modules/ to ~/.attract/modules/
Code: [Select]
cp -R ~/.attract/attract-extra/modules/* ~/.attract/modules/

you can clean up the clone of attract-extra if you want, but it doesn't hurt to leave it there for reference.

Code: [Select]
rm -R ~/.attract/attract-extra

If you look at the roboto Working picture, you can see that things are now working. My rom lists are missing metadata, so thats why it looks incomplete.

Pictures
roboto not working http://imgur.com/0rJlHCI
roboto_menu http://imgur.com/b4BWP3N
coolvetica not working http://imgur.com/VKkfyU6
coolvetica_menu http://imgur.com/2CBXWHL
roboto on another layout menu (works fine) http://imgur.com/Y0yVm35
roboto WORKING http://imgur.com/QfLJuLt
kubuntu 14.04 x64. i5 4690k, 16 GB RAM, EVGA GTX 750ti, DS3 SIXAXIS via BT/USB, RetroArch/libretro.

Namachieli

  • Full Member
  • ***
  • Posts: 29
    • View Profile
Re: New Theme - Game Station Theme [Phase 2 WIP]
« Reply #13 on: December 30, 2015, 01:04:42 PM »
Heh, looks like I got my post in before the ninja Edit :)
kubuntu 14.04 x64. i5 4690k, 16 GB RAM, EVGA GTX 750ti, DS3 SIXAXIS via BT/USB, RetroArch/libretro.

kent79

  • Sr. Member
  • ****
  • Posts: 355
    • View Profile
Re: New Theme - Game Station Theme [Phase 2 WIP]
« Reply #14 on: December 30, 2015, 02:46:56 PM »
Heh, looks like I got my post in before the ninja Edit :)

It is something wrong on your final screen. "Roboto" font should be all upper case, but you are not. I confirmed you are not using "roboto" font in layout.   :-\

« Last Edit: December 30, 2015, 02:50:09 PM by kent79 »