Author Topic: Version 2.3 Released  (Read 13186 times)

keilmillerjr

  • Sr. Member
  • ****
  • Posts: 486
    • View Profile
Re: Version 2.3 Released
« Reply #30 on: December 05, 2017, 07:05:45 PM »
Code: [Select]
Keils-iMac:~ keiljr$ cd /Applications/Attract.app/Contents/MacOS
Keils-iMac:MacOS keiljr$ /Applications/Attract.app/Contents/MacOS/attract
objc[57392]: Class SFApplication is implemented in both /usr/local/lib/libsfml-window.2.4.dylib and /Applications/Attract.app/Contents/libs/libsfml-window.2.4.2.dylib. One of the two will be used. Which one is undefined.
objc[57392]: Class SFApplicationDelegate is implemented in both /usr/local/lib/libsfml-window.2.4.dylib and /Applications/Attract.app/Contents/libs/libsfml-window.2.4.2.dylib. One of the two will be used. Which one is undefined.
objc[57392]: Class SFOpenGLView is implemented in both /usr/local/lib/libsfml-window.2.4.dylib and /Applications/Attract.app/Contents/libs/libsfml-window.2.4.2.dylib. One of the two will be used. Which one is undefined.
objc[57392]: Class SFSilentResponder is implemented in both /usr/local/lib/libsfml-window.2.4.dylib and /Applications/Attract.app/Contents/libs/libsfml-window.2.4.2.dylib. One of the two will be used. Which one is undefined.
objc[57392]: Class SFWindow is implemented in both /usr/local/lib/libsfml-window.2.4.dylib and /Applications/Attract.app/Contents/libs/libsfml-window.2.4.2.dylib. One of the two will be used. Which one is undefined.
objc[57392]: Class SFBlackView is implemented in both /usr/local/lib/libsfml-window.2.4.dylib and /Applications/Attract.app/Contents/libs/libsfml-window.2.4.2.dylib. One of the two will be used. Which one is undefined.
objc[57392]: Class SFWindowController is implemented in both /usr/local/lib/libsfml-window.2.4.dylib and /Applications/Attract.app/Contents/libs/libsfml-window.2.4.2.dylib. One of the two will be used. Which one is undefined.
objc[57392]: Class SFViewController is implemented in both /usr/local/lib/libsfml-window.2.4.dylib and /Applications/Attract.app/Contents/libs/libsfml-window.2.4.2.dylib. One of the two will be used. Which one is undefined.
Attract-Mode v2.3.0-12 (OSX, SFML 2.4)
avcodec 57.107.100 / avformat 57.83.100 / swscale 4.8.100 / swresample 2.9.100

Config: /Users/keiljr/.attract/attract.cfg

*** Initializing display: 'NeoGeo'
 - Loaded master romlist 'mame' in 176 ms (147 entries kept, 10 discarded)
 - Constructed 10 filters in 0 ms (1470 comparisons)
Segmentation fault: 11


estefan3112

  • Jr. Member
  • **
  • Posts: 21
    • View Profile
    • Retrogaming on my Mac
Re: Version 2.3 Released
« Reply #31 on: December 06, 2017, 03:13:02 AM »
Same segfault here. What worked for me wasanually copying the new binary into the 2.2.0 App container and replacing the confit data in .attract with the newly compiled data. Far from perfect, however running  :D.

keilmillerjr

  • Sr. Member
  • ****
  • Posts: 486
    • View Profile
Re: Version 2.3 Released
« Reply #32 on: December 06, 2017, 05:00:14 AM »
Same segfault here. What worked for me wasanually copying the new binary into the 2.2.0 App container and replacing the confit data in .attract with the newly compiled data. Far from perfect, however running  :D.

estefan3112

  • Jr. Member
  • **
  • Posts: 21
    • View Profile
    • Retrogaming on my Mac
Re: Version 2.3 Released
« Reply #33 on: December 06, 2017, 01:15:00 PM »
I can confirm this and manually modified the dmg by adding the running binary to it.
The compressed image is ready for download and install.
Here it is  ;D.

https://drive.google.com/file/d/1Gjt-YKvH97lt78biQuBdtxTU9W8B6Bba/view?usp=sharing

If this successfully installs with Mac users, it would be great to know!
Not the most elegant way, but we are getting somewhere!
Cheers!

keilmillerjr

  • Sr. Member
  • ****
  • Posts: 486
    • View Profile
Re: Version 2.3 Released
« Reply #34 on: December 06, 2017, 02:15:48 PM »
I am still wondering what is going on though.

I changed line 73 of create-pig.sh to move the file (mv) instead of copying it, and the resulting binary inside the bundle inside the dmg is still altered. Maybe something to do with making the dmg?

kent79

  • Hero Member
  • *****
  • Posts: 500
    • View Profile
Re: Version 2.3 Released
« Reply #35 on: December 08, 2017, 06:24:09 PM »
Dear raygun

I find some issue on version 2.3. The image width is something wrong. All images width can't cover the screen

You may try to download my theme to look at this issue.
http://forum.attractmode.org/index.php?topic=1824.0

Below is example:

local flw = fe.layout.width;

Version 2.2 or before
local topBar = fe.add_image("white.png",0, 0, flw, 25 )
--------------------------------------

Version 2.3
local topBar = fe.add_image("white.png",0, 0, flw + 1, 25 )
« Last Edit: December 08, 2017, 06:42:39 PM by kent79 »

cosmo

  • Full Member
  • ***
  • Posts: 54
    • View Profile
Re: Version 2.3 Released
« Reply #36 on: December 10, 2017, 02:37:38 AM »
i'm having a segmentation fault trying to compile AM on the Raspberry Pi. Am i doing something wrong?
Code: [Select]
cd ~
mkdir develop

sudo apt-get install cmake libflac-dev libogg-dev libvorbis-dev libopenal-dev libjpeg62-turbo-dev libfreetype6-dev  libudev-dev libfontconfig1-dev

cd ~/develop
git clone --depth 1 https://github.com/mickelson/sfml-pi sfml-pi
mkdir sfml-pi/build;cd sfml-pi/build
cmake .. -DSFML_RPI=1 -DEGL_INCLUDE_DIR=/opt/vc/include -DEGL_LIBRARY=/opt/vc/lib/libEGL.so -DGLES_INCLUDE_DIR=/opt/vc/include -DGLES_LIBRARY=/opt/vc/lib/libGLESv1_CM.so
sudo make install
sudo ldconfig

cd ~/develop
git clone --depth 1 git://source.ffmpeg.org/ffmpeg.git
cd ffmpeg
./configure --enable-mmal --disable-debug --enable-shared
make
sudo make install
sudo ldconfig

cd ~/develop
git clone --depth 1 https://github.com/mickelson/attract attract
cd attract
make USE_GLES=1
sudo make install

Everything compiles fine, but AM gives a segmentation fault and dont work.  :-\

If i install it from the experimental packages on retropie, it works, but it doesn't have mmal hardware acceleration. Any help?  :P

Omamez

  • Sr. Member
  • ****
  • Posts: 222
    • View Profile
Re: Version 2.3 Released
« Reply #37 on: December 11, 2017, 06:41:27 PM »
I get same issue as Cosmo when compiling AM on Raspberrry pi it doesnt work

Enverex

  • Jr. Member
  • **
  • Posts: 24
    • View Profile
    • xNode - Internet Toolkit
Re: Version 2.3 Released
« Reply #38 on: December 18, 2017, 03:26:04 AM »
Regarding 2.3, has anyone successfully used VAAPI acceleration for videos? It's displaying blank or garbage for me.

raygun

  • Administrator
  • Sr. Member
  • *****
  • Posts: 361
    • View Profile
Re: Version 2.3 Released
« Reply #39 on: December 18, 2017, 07:36:13 PM »
i'm having a segmentation fault trying to compile AM on the Raspberry Pi. Am i doing something wrong?
Code: [Select]
cd ~
mkdir develop

sudo apt-get install cmake libflac-dev libogg-dev libvorbis-dev libopenal-dev libjpeg62-turbo-dev libfreetype6-dev  libudev-dev libfontconfig1-dev

cd ~/develop
git clone --depth 1 https://github.com/mickelson/sfml-pi sfml-pi
mkdir sfml-pi/build;cd sfml-pi/build
cmake .. -DSFML_RPI=1 -DEGL_INCLUDE_DIR=/opt/vc/include -DEGL_LIBRARY=/opt/vc/lib/libEGL.so -DGLES_INCLUDE_DIR=/opt/vc/include -DGLES_LIBRARY=/opt/vc/lib/libGLESv1_CM.so
sudo make install
sudo ldconfig

cd ~/develop
git clone --depth 1 git://source.ffmpeg.org/ffmpeg.git
cd ffmpeg
./configure --enable-mmal --disable-debug --enable-shared
make
sudo make install
sudo ldconfig

cd ~/develop
git clone --depth 1 https://github.com/mickelson/attract attract
cd attract
make USE_GLES=1
sudo make install

Everything compiles fine, but AM gives a segmentation fault and dont work.  :-\

If i install it from the experimental packages on retropie, it works, but it doesn't have mmal hardware acceleration. Any help?  :P

For the very last step, try this instead:

Code: [Select]
sudo make install USE_GLES=1

BadFurDay

  • Full Member
  • ***
  • Posts: 69
    • View Profile
Re: Version 2.3 Released
« Reply #40 on: December 19, 2017, 02:43:35 PM »
i'm having a segmentation fault trying to compile AM on the Raspberry Pi. Am i doing something wrong?
Code: [Select]
cd ~
mkdir develop

sudo apt-get install cmake libflac-dev libogg-dev libvorbis-dev libopenal-dev libjpeg62-turbo-dev libfreetype6-dev  libudev-dev libfontconfig1-dev

cd ~/develop
git clone --depth 1 https://github.com/mickelson/sfml-pi sfml-pi
mkdir sfml-pi/build;cd sfml-pi/build
cmake .. -DSFML_RPI=1 -DEGL_INCLUDE_DIR=/opt/vc/include -DEGL_LIBRARY=/opt/vc/lib/libEGL.so -DGLES_INCLUDE_DIR=/opt/vc/include -DGLES_LIBRARY=/opt/vc/lib/libGLESv1_CM.so
sudo make install
sudo ldconfig

cd ~/develop
git clone --depth 1 git://source.ffmpeg.org/ffmpeg.git
cd ffmpeg
./configure --enable-mmal --disable-debug --enable-shared
make
sudo make install
sudo ldconfig

cd ~/develop
git clone --depth 1 https://github.com/mickelson/attract attract
cd attract
make USE_GLES=1
sudo make install

Everything compiles fine, but AM gives a segmentation fault and dont work.  :-\

If i install it from the experimental packages on retropie, it works, but it doesn't have mmal hardware acceleration. Any help?  :P

For the very last step, try this instead:

Code: [Select]
sudo make install USE_GLES=1

This worked for me, thanks!

cosmo

  • Full Member
  • ***
  • Posts: 54
    • View Profile
Re: Version 2.3 Released
« Reply #41 on: December 23, 2017, 03:54:28 AM »
Works perfectly! Thank you very much!

Thorvald

  • Jr. Member
  • **
  • Posts: 13
    • View Profile
Re: Version 2.3 Released
« Reply #42 on: December 25, 2017, 12:48:56 PM »
Hot damn!   Multi Monitor now works!   It finally displays the Marquee's in the second monitor when moving through the menu.

Awesome!

keilmillerjr

  • Sr. Member
  • ****
  • Posts: 486
    • View Profile
Re: Version 2.3 Released
« Reply #43 on: January 25, 2018, 06:29:08 PM »
Mac os x compile. v2.3.0-32 with SWF support, 100% error free, and a dmg file that works. Yay! The only thing I didn’t do was create an Application folder alias in the dmg. I couldn’t get the icon to line up perfectly, so my OCD said to forget it. Github source is still no bueno with the create-pkg.sh script. But at least we finally have a perfectly working mac os x compile!

attract-v2.3.0-32-fixed.dmg
« Last Edit: January 29, 2018, 11:16:11 AM by keilmillerjr »

RetroMacGamer

  • Jr. Member
  • **
  • Posts: 14
    • View Profile
Re: Version 2.3 Released
« Reply #44 on: January 29, 2018, 08:25:24 PM »
Thanks for the link keilmillerjr.

This is the error I'm getting, anything I can do to fix it?

Last login: Tue Jan 30 14:47:10 on ttys001
Alexs-MacBook:~ alexmacbook$ /Applications/Attract.app/Contents/MacOS/attract
dyld: Library not loaded: /usr/local/opt/sfml/lib/libsfml-graphics.2.4.dylib
  Referenced from: /Applications/Attract.app/Contents/MacOS/attract
  Reason: image not found
Abort trap: 6
Alexs-MacBook:~ alexmacbook$

Cheers