Author Topic: 5200  (Read 2646 times)

Tobas

  • Jr. Member
  • **
  • Posts: 18
    • View Profile
5200
« on: May 30, 2021, 07:21:23 AM »
it's incredibly frustrating to play 5200 perfectly on my old 3rd party david marti image, and now, on my fresh buster install, 5200 is completely broken. has anyone found this to be the case? is there a solution?

akafox

  • Moderator
  • Hero Member
  • *****
  • Posts: 985
    • View Profile
Re: 5200
« Reply #1 on: May 30, 2021, 07:52:57 PM »
I am going to assume you are talking about a raspberry pi and a pre-made image. Problem with a pre-made image is it can be changed or altered so we have no idea how to fix it..

but check to make sure you have your bios for the 5200 in the correct place and you have the emulator (atari800 I think it is) set to load 5200 games instead of the computer. If it is retropie..then also make sure the emulator is set correctly in the emulator menu (normally accessed by pressing a button after a launch of a game from the emulator and check the default emulator.

That's all I can suggest to you with so little information.
People want life easy..then complain about it

dmmarti

  • Sr. Member
  • ****
  • Posts: 106
    • View Profile
Re: 5200
« Reply #2 on: May 31, 2021, 06:20:43 AM »
Its not broken, you just have to understand how a base Retropie build works and what extra manual steps you can do to set it up the same as your old Pi 3 image.  These are manual tweaks to setup the Atari 5200 system to auto-boot as an Atari 5200 instead of an Atari 800.

As mentioned above, make sure you have the BIOS files in the proper place.

Then update/create these 3 files in /opt/retropie/configs/atari5200 and you should be good to go.

=====

/opt/retropie/configs/atari5200

emulators.cfg
retroarch.cfg
retroarch-core-options.cfg

pi@retropie:/opt/retropie/configs/atari5200 $ pwd
/opt/retropie/configs/atari5200

pi@retropie:/opt/retropie/configs/atari5200 $ ls -l
total 12
-rw-r--r-- 1 pi pi 278 May 11  2020 emulators.cfg
-rw------- 1 pi pi 375 May 11  2020 retroarch.cfg
-rw-r--r-- 1 pi pi 296 May 11  2020 retroarch-core-options.cfg

==========
==========

pi@retropie:/opt/retropie/configs/atari5200 $ cat emulators.cfg
lr-atari800 = "/opt/retropie/emulators/retroarch/bin/retroarch -L /opt/retropie/libretrocores/lr-atari800/atari800_libretro.so --config /opt/retropie/configs/atari5200/retroarch.cfg %ROM%"
default = "lr-atari800"
atari800 = "/opt/retropie/emulators/atari800/bin/atari800 %ROM%"


==========
==========

pi@retropie:/opt/retropie/configs/atari5200 $ cat retroarch.cfg
# Settings made here will only override settings in the global retroarch.cfg if placed above the #include line

input_libretro_device_p1 = "513"
input_libretro_device_p2 = "513"

input_remapping_directory = "/opt/retropie/configs/atari5200/"

core_options_path = "/opt/retropie/configs/atari5200/retroarch-core-options.cfg"
#include "/opt/retropie/configs/all/retroarch.cfg"


==========
==========

pi@retropie:/opt/retropie/configs/atari5200 $ cat retroarch-core-options.cfg
atari800_system = "5200"
atari800_ntscpal = "NTSC"
atari800_internalbasic = "disabled"
atari800_sioaccel = "disabled"
atari800_cassboot = "disabled"
atari800_artifacting = "disabled"
atari800_opt1 = "disabled"
atari800_opt2 = "disabled"
atari800_resolution = "336x240"
atari800_keyboard = "poll"