Author Topic: attractmode exits too early on launching an emulator (retropi)  (Read 231 times)

nullpacket

  • Newbie
  • *
  • Posts: 1
    • View Profile
attractmode exits too early on launching an emulator (retropi)
« on: September 30, 2022, 03:49:18 AM »
Hello all, first post so be gentle :)

I am  running on a pi (2b right now but will move to a 4 when you I actually get hold of the damn things). Latest retropie and am from binary pacjage (2022-06-25)

I've spent a couple of days building a setup with specific requirements. The machine needs to run only a single rom and when not in use needs to display a custom frontend. After some playing around I am almost where I want to be but I have a couple of outstanding issues that I am unsure how to solve.

Firstly, when the game is launched, attract mode exits (or changes focus to the console) and the runcommand output is then visible on the screen for many seconds before retroarch has finished launching mame. Is there any way to have attractmode still visible for say 5-10 seconds after runcommand is executed? In an ideal world, I'd prefer to launch the emulator and have it's output displayed in my layout as per a snap video for example, then when the user launches, the artwork "tile" would expand to full screen and there would be no waiting for the emulator to load but as far as I can see this isn't an option.

Secondly, and likely a more complex issue is that I'd very much like to return to attractmode if mame has had no joystick input for a period of time. Just wondered if anyone here has attempted something similar (I did see reference to a plugin and script but that appeared to be windows focused not linux).

Thanks in advance