Recent Posts

Pages: 1 ... 8 9 [10]
91
Scripting / Re: Text styling questions
« Last post by jdye82 on October 13, 2017, 10:35:04 AM »
Please update filtername fucntion as below  :)

function filtername(){
     local text = fe.filters[1];
     return text.name.toupper();
}

OK. So, the ROM name/title is now showing - and working in uppercase!!

BUT, The filer/list name is not showing now. So it looks like there's something wrong with fe.filters[1] ?
92
Scripting / Re: Text styling questions
« Last post by kent79 on October 13, 2017, 05:58:01 AM »
Please update filtername fucntion as below  :)

function filtername(){
     local text = fe.filters[1];
     return text.name.toupper();
}
93
Scripting / Re: Text styling questions
« Last post by jdye82 on October 13, 2017, 03:30:41 AM »
Sure. Attached
94
Scripting / Re: Text styling questions
« Last post by kent79 on October 13, 2017, 01:51:44 AM »
OK, I have no idea where I'm going wrong, but I still can't get this to work.

Here's the code.

Code: [Select]
function title(){
  local text = fe.game_info(Info.Title);
  return text.toupper();
}

local title = fe.add_text("[!title]  PLAYS: [PlayedCount]", flx*0.235, fly*0.02, flw*0.600, flh*0.500 );

Using this, the text doesn't display at all, so something's off. As soon as I remove the function and stop trying to make the text uppercase, it's fine. So it's definitely the function causing the issues  :(

Any final thoughts? If not, I'll learn to live with it, or will find a suitable replacement uppercase font.

Could you mind provide nut file to us for checking?
95
Scripting / Re: Text styling questions
« Last post by jdye82 on October 13, 2017, 12:54:42 AM »
OK, I have no idea where I'm going wrong, but I still can't get this to work.

Here's the code.

Code: [Select]
function title(){
  local text = fe.game_info(Info.Title);
  return text.toupper();
}

local title = fe.add_text("[!title]  PLAYS: [PlayedCount]", flx*0.235, fly*0.02, flw*0.600, flh*0.500 );

Using this, the text doesn't display at all, so something's off. As soon as I remove the function and stop trying to make the text uppercase, it's fine. So it's definitely the function causing the issues  :(

Any final thoughts? If not, I'll learn to live with it, or will find a suitable replacement uppercase font.
96
General / Re: Request: quiet (no prints) mode
« Last post by flexfulton on October 12, 2017, 08:02:50 AM »
Is there a dummy's guide to getting this accomplished on a retropie?  I'm not quite sure I follow on what to do.
Thanks!

You need to replace what is in the autostart.sh script found in /opt/retropie/configs/all with

setterm -cursor off
stty -echo
clear
attract 2>&1 | grep -o $'\033\[2J'

You can just make sure that a # is in front of all the existing lines in you would rather save it in case you need to revert back.

Thank you need to make two text files one called runcommand-onstart and one called runcommand-onend.  They both need to contain printf "\033[H\033[2J"
Once you created them, rename them to add the .sh to the end and then upload them into the /opt/retropie/configs/all folder.

This can all be done via WinSCP but you can also do it via command line if you want.  Th

Please note that if you use the Retropie Setup Script at any time that will flash up before the game loads.  This can be cleaned up by rebooting the system.

Also note that all terminal text that you wish to input to the system via USB keyboard will no longer show up either.  It will accept the text you just won't be able to see it.  You can however SSH into the system to do all your work if required.

Good luck!
97
General / Re: Request: quiet (no prints) mode
« Last post by flexfulton on October 12, 2017, 07:55:29 AM »
This is great to remove the visually unappealing flash of the glGetError.  The only issue with this is that if you use the Retropie Setup Script that will flash on the screen now before and after the launching.png.

A simple reboot with get rid of it though.  So for now it's the best best for a completely clean system.
98
General / Re: Raspberry Pi Image for Pi 2 and Pi 3
« Last post by flexfulton on October 12, 2017, 07:40:35 AM »
I know it's a long shot but does anyone know how to get rid of the glGetError 0x500 that flashes up on the screen before every game is launched?  I know it has no effect on the functionality of attract mode but the error getting displayed is the only thing preventing me from having a completely clean set up with no text or anything pi related.

I have done this

12. How can I get rid of the terminal/console text I see when I launch a game or exit a game? Check out this post http://forum.attractmode.org/index.php?topic=1642.0.

However if I use the Retropie Script at all that screen will always flash up when launching a game until I do a reboot.

Any help, insight, tips or ways to get this cleaned up would be greatly appreciated.

I'm running the latest version, installed from scratch from the Retropie Experimental options.

Thank you!
99
Scripting / Re: Continuous sliding image like as SNES Mini background
« Last post by kent79 on October 12, 2017, 06:53:30 AM »
Thank you qqplayer reply, but not working. Anyway, I will release a new version of Grid Pro Theme soon. You may try to update. Thanks.  :)
100
Scripting / Re: Text styling questions
« Last post by jdye82 on October 12, 2017, 01:21:27 AM »
Brilliant.

Thank you keilmillerjr and jedione for your help and time on this. Will give it a go this evening (UK).
Pages: 1 ... 8 9 [10]