Author Topic: AM intermittently does not return focus on exit  (Read 122 times)

feltz916

  • Jr. Member
  • **
  • Posts: 12
    • View Profile
AM intermittently does not return focus on exit
« on: June 11, 2017, 11:55:48 PM »
Hoping someone has more insight as to what is going on when this occurs.

Issue: About 1 out of 10 attempts to exit a game and return to AM causes AM to not have focus.
Setup: Windows 8.1 with AM setup as shell replacement

When this occurs, there is another process running that i see in my alt-tab list by the name of "NVOpenGLFbo"
When in the alt-tab list, if I select Attract Mode , the process of NVOpenGLFbo ends.

Thinking this might be Mame, i setup Mame to run on D3D, and the problem still occurs. So I think the problem is with AM.

bobbanico

  • Newbie
  • *
  • Posts: 3
    • View Profile
Re: AM intermittently does not return focus on exit
« Reply #1 on: June 12, 2017, 02:02:16 PM »
hello,

Here i solved many problems with focus losing when launching or leaving, hiding the console in attract.cfg, setting hide_console  to yes,
then also leaving Fill screen as window mode, and also running attract mode as administrator and also setting it with compatibility mode for windows 7.
Also something pretty important i noticed is to map your attract mode exit hotkey in emulator, the same as the one you use with the emulator.
Seems it gives back the focus to AM.

Hope this helps

feltz916

  • Jr. Member
  • **
  • Posts: 12
    • View Profile
Re: AM intermittently does not return focus on exit
« Reply #2 on: June 14, 2017, 08:13:34 PM »
This is really breaking the experience of being in a cabinet. I re-installed on a separate OS using Windows 7 and the same problem is occurring. :(