Author Topic: A problem with "Hide_Console"  (Read 263 times)

Xazuki

  • Newbie
  • *
  • Posts: 2
    • View Profile
A problem with "Hide_Console"
« on: June 17, 2017, 12:43:40 PM »
I'm on Windows and I've been looking in to completely hiding the console window that appears when you launch Attract Mode. By changing "hide_console" to yes in attract.cfg it does disappear... if Attract Mode is launched directly or as a Windows shortcut. However if launched through Steam or Steam Big-Picture the console window still appears which is a bit of a pain when running things through Steam Link. There are no parameters passed through either the Windows shortcut or the Steam shortcut.

Has anyone encountered this or can maybe suggest a course of action? Thanks a bunch.

feltz916

  • Jr. Member
  • **
  • Posts: 12
    • View Profile
Re: A problem with "Hide_Console"
« Reply #1 on: June 22, 2017, 11:22:10 PM »
same problem occurs if you setup AM to launch via windows shell replacement.
wish there was a solution, but it seems the windows support is pretty lacking.

progets

  • Sr. Member
  • ****
  • Posts: 475
    • View Profile
Re: A problem with "Hide_Console"
« Reply #2 on: June 23, 2017, 01:05:09 AM »
Try adding your Attract-Mode folder to you Windows "path". Then when you launch Attract-Mode use the "-c" switch to provide the path of your configuration.

Xazuki

  • Newbie
  • *
  • Posts: 2
    • View Profile
Re: A problem with "Hide_Console"
« Reply #3 on: June 23, 2017, 12:38:58 PM »
It doesn't have a problem finding attract.cfg as all the other settings and data is present and correct, it just seems to ignore the hide_console setting when launched through Steam. Unless I am misunderstanding what you were saying, in which case could you please go in to more detail about what you suggested?