Author Topic: Q: on missing art for FadeArt module  (Read 52 times)

jedione

  • Sr. Member
  • ****
  • Posts: 364
  • punktoe
    • View Profile
Q: on missing art for FadeArt module
« on: December 04, 2017, 01:56:28 PM »
so lets say your using this to add a snap....
local snap = fe.add_artwork(  "snap", flx*0.050, fly*0.200, flw*0.200, flh*0.250 );

and you dont have a "snap" for it ,,if you put a pic or a vid in the layout called "snap.png" it
will use that in place of the missing..

ok.. now if your using ..module fadeart
local snap = FadeArt (  "snap", flx*0.050, fly*0.200, flw*0.200, flh*0.250 );
it dont work.

Q: anyone know how to add a filler for this..thanks


« Last Edit: December 04, 2017, 02:02:53 PM by jedione »
help a friend....

keilmillerjr

  • Sr. Member
  • ****
  • Posts: 364
    • View Profile
Re: Q: on missing art for FadeArt module
« Reply #1 on: December 04, 2017, 04:16:48 PM »
I use fadeart for mvscomplete mini marquees. I have neogeo.png in my artwork folder and it’s automatically selected when artwork is missing, I assume that’s because the name of my display is neogeo?

jedione

  • Sr. Member
  • ****
  • Posts: 364
  • punktoe
    • View Profile
Re: Q: on missing art for FadeArt module
« Reply #2 on: December 04, 2017, 06:29:48 PM »
well that would be to easy!   8)

trying when i get home..  thanks bro..
help a friend....

IceLancer

  • Full Member
  • ***
  • Posts: 26
    • View Profile
Re: Q: on missing art for FadeArt module
« Reply #3 on: December 05, 2017, 05:35:18 PM »
if it doesnt work u can always make it snappy like , instant show boxart and with delay add video snap, if no snap it will just stay with picture.But yes it should always put [emulator name] as default pic, its doing the same for my theme in case of missing background fanart

define surface then just add fadeart

local surface = fe.add_surface( 500, 500 );
local point = FadeArt("cartart", 0, 0, 500, 500, surface );
point.trigger = Transition.EndNavigation;
point.preserve_aspect_ratio = true;
surface.set_pos( flx*0.050, fly*0.200, flw*0.200, flh*0.250  );

jedione

  • Sr. Member
  • ****
  • Posts: 364
  • punktoe
    • View Profile
Re: Q: on missing art for FadeArt module
« Reply #4 on: December 06, 2017, 06:55:34 PM »
so adding a .png works,,  but nothing els does..

so i looked at the , Fade.nut in modules   and their it is..

line #83    "test = fe.script_dir + _label +".png ;"

so i changed it to .mp4 and now that works ...

but now .png dont work.. so i tryed several diff ways to see if i could add two or three files

like  .png, mp4, jpg , ext...  know luck     

any help from a scripter  so the fade.nut can be updated would be nice  thanks.

help a friend....