Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - keilmillerjr

Pages: [1] 2 3 ... 45
1
Scripting / Re: Issue with surface?
« on: Today at 03:32:49 AM »
It’s been an ongoing issue. Right now I’m running 2.5.1 including that commit. I’m going to do a partial rewrite anyways, but it’s a head scratcher and I’m trying to clean up little bugs here and there.

Something happened in my last upgrade (I changed config too) where when navigating, it’s only 1 game per press when before I could hold a key for rapid next games.? Frame rate went up a lot. Navigating 450 games would be painful.

Lack of free disk space and adobe flash likely to blame for poor performance. My kids watch YouTube and occasionally I have to reboot after.

2
Themes / Re: Theme to demonstrate CRT shaders
« on: Today at 03:21:28 AM »
My iMac that I had to take a loan out for is now officially obsolete due to Mac OS X changing video requirements. I wish Apple would stop all these GUI enhancements and kept it simple like OS9. I don’t need 10 ways to open an app. I would much prefer clicking shutdown and having an instant black screen like on my 333mhz and 433mhz macs with os9.

3
General / Re: Mac OSX Problems. I need some help
« on: Yesterday at 05:59:56 PM »
Hi, this is probably the same as with MAME:
The value 1 in 'Non-blocking Wait Mode' just brought everything back to normal - for me in MAME.
Documented here:
http://forum.attractmode.org/index.php?topic=2589.0
Good luck, and please post if successful.

I updated attract on my mac. Running mame 0.200 on it. First time in a while I actually tried launching a game. Same thing happened with the black screen and have to force quit attract. Adding the value 1 to non blocking wait mode worked as you suggested. Thank you. I have no idea why its even necessary.?

Also, is the newly added pause feature not available on the mac? I cant seem to find it.

attract 2.5.1
https://github.com/mickelson/attract/commit/18d8c10869e56de7a2adc390d15a0125d0554c50

4
General / Re: POLL: What system are you running Attract Mode on?
« on: Yesterday at 06:03:54 AM »
Not neccesarily. We have a database of 4529 forum users and I don't believe all of them have registered here to seek guidance in developing themes. Even though I'm not a fan of sending spam emails from administrators maybe in this case it would be beneficial to do so. That would give us a pretty good statistical sample.

Theres about 50 people with 50 posts or more, but over 4500 users. I recognize almost all the top 50 people and most have contributed in some way. An estimated 3100 users have zero posts. Either spam, or came to download a theme. Which is a good thing! But like I said, I guarantee this poll would end up either windows or "wtf is unix"?

http://forum.attractmode.org/index.php?action=mlist;sort=posts;desc;start=30

Regardless, I love that this front end is multiplatform. I can program on my mac, and use windows in the arcade because of crt emu drivers and lack of support for groovy arcade. I honestly cant tell you when the last time I used my arcade machine was. I enjoy the tinkering. rPi has been an interesting project. Not a fan of how bloated existing images are. I created my own setup just for mame. It would be an easy and cheap solution for some one making a home made cabinet with a crt tv and jpac!

5
Themes / Re: Theme to demonstrate CRT shaders
« on: Yesterday at 05:46:34 AM »
Tested on:
10.13.6 (17G3025)
iMac (27-inch, Mid 2011)
2.7 GHz Intel Core i5
12 GB 1333 MHz DDR3
AMD Radeon HD 6770M 512 MB

CRT-CGWG: pass
CRT-Halation: pass with errors
  Failed to compile fragment shader:
  ERROR: 0:1: '' :  version '130' is not supported
  Failed to compile vertex shader:
  ERROR: 0:1: '' :  version '130' is not supported
CRT-Lottes: pass
CRT-Lottes-Multipass: fail
  Failed to compile vertex shader:
  ERROR: 0:1: '' :  version '130' is not supported
  Failed to compile vertex shader:
  ERROR: 0:1: '' :  version '130' is not supported

6
General / Re: POLL: What system are you running Attract Mode on?
« on: Yesterday at 01:42:29 AM »
Interesting to see that Unix based systems are on par with Windows based systems, but still only 15 people voted for the poll so it's probably a very skewed statistic...

Your on a forum where there is a good amount of people interested in some form of developing. I would expect a somewhat even split with windows and unix based systems. Ask this poll on any arcade related facebook group, and I bet you will get either windows or „raspberry pi“ because most people do not know even know what operating system they have running on their raspberry pi.

7
Scripting / Re: Problem plugin - Random
« on: Yesterday at 01:17:11 AM »
Pushed small update. Plugin should wait for intro to finish before activating plugin. Please test and report back if it doesn’t work. I didn’t actually test it.

As is, screensaver will never become active unless screensaver time is less than sequencers delay time (which would be pointless). One option is to not use a screensaver. Harsh, I know. Second option, differentiate between signals from the plugin and actual user plugins. I could then keep track of time the user was away and activate the screensaver manually a signal that you preset in the config to activate the screensaver. Plugin would have to disable when the screensaver is active, and enable when returning. Thoughts?

Thanks for the update, the sequencer plugin now waits correctly for the intro-video as long as the delay time set in the sequencer settings is not shorter than the intro-video length itself (for example if you set sequencer delay time to 5sec and the intro-video length is 10sec then it will still interrupt the intro-video at 5sec and jump into AM). This is really a non-issue since most of us use ~30sec as sequencer delay time (the normal video length of EmuMovies) and usually don't use long intro-videos (but I know some people love those super long intro videos in their arcade cabinets). Mine is just around 10 sec.

I just wish that AM would have a function that would ignore keyboard/joystick key inputs during the intro-video as an optional option. I use AHK script for that as a workaround until I learn how to do it via the intro.nut file correctly.

PS. This great plug-in has completely removed the need for a screensaver for me, and it works much better as a "Attract-Mode" attention grabber in an Arcade cabinet than the built in AM screensavers.

Keep up the good work and best regards.

/Edit, forgot to quote the post I was replying to

Thank you for trying it out and your detailed review! Resolved the issue with the intro. Sorry about that. Fully tested now. Pushed update to GitHub.

I can disable signals when the intro is active, but this would best be handled by the intro script because the plugin would not know the length of the video object and it would be stuck on a never ending loop. You would have to add a signal handler and return true unless video is done playing.

8
Scripting / Issue with surface?
« on: December 08, 2018, 11:58:20 PM »
I have two layouts that use the same general format - mvscomplete and playchoicecomplete. I have an issue where if you start attractmode on a display using one of the layouts, my „container" surface is not shown unless I reload the layout. Remember, layouts get reloaded between displays. If I start with a different layout such as arcadeflow, and then switch displays, the issue will not be present. Using the intro, issue is not present. Using microsoft windows, issue is not present. Only on my mac. Which is very odd. Any ideas? Can some one take a look? I’m about to scrap the surface idea to resolve the issue.

https://www.youtube.com/watch?v=_Gp5-aH2yLI&feature=youtu.be

https://github.com/keilmillerjr/mvscomplete/blob/master/layout.nut
https://github.com/keilmillerjr/playchoicecomplete-layout/layout.nut

9
Themes / Re: Arcadeflow theme v 2.9 [Release] Updated 2 December 2018
« on: December 08, 2018, 10:32:45 PM »
Hi Zpaolo11x! I am happy to say that I have arcade flow up and running on my mac without any issues! It even works nicely with the sequencer plugin. Cant wait to put it on the arcade machine. The only error I get is the following:

Code: [Select]
Uniform "maincolor" not found in shader

10
General / Re: Disable Automatic Launch
« on: December 08, 2018, 09:59:21 PM »
The issue has something to do with the screensaver function.  When I disable the screensaver, the system stops launching the game automatically.

Jim
https://github.com/mickelson/attract/blob/1c1ab2ddfe812354a12665920c7c3b236db5300d/config/screensaver/screensaver.nut#L735

https://github.com/mickelson/attract/blob/1c1ab2ddfe812354a12665920c7c3b236db5300d/config/screensaver/screensaver.nut#L207

It doesn’t happen automatically. I believe your pressing the select button. Which makes sense if your in basic movie or rgb mode. I see a game I like in the screensaver? Select and away I play. Want to return to the layout? Hit any other key.

11
General / Re: Disable Automatic Launch
« on: December 08, 2018, 12:16:20 PM »
I haven’t noticed this. What layout and plugins are you using?

12
General / Re: POLL: What system are you running Attract Mode on?
« on: December 07, 2018, 06:02:00 AM »
I am using a total of three systems now. My target platforms are different than my development platform. Can we check off more than one?

Dev: Mac 10.13.6
Mach: Win 10 1607 enterprise
Proj: Raspbian lite 10/09/2018

13
Themes / Re: "Blue Ring AM" Theme
« on: December 06, 2018, 01:10:12 PM »
The psd will have the author of the original theme.

Now i'm very involved with a bootable image for pi with atract-mode and only with raspbian and attract-mode, without retropie, lakka, recalbox, nor batocera, nor emulationstation...

And i find it quite complicated to perform...

but when i have a free time, i will try a vertical version of this layout, although i can not guarantee anything... :D

Same thing I did. Setup works perfect. Can release image when I can manage to save $40 for the sdclone app. I should probably release the guide I assembled.

14
General / Re: Romlist?
« on: December 05, 2018, 02:38:31 PM »
You could output the current list to terminal, and then copy it from terminal.

15
General / Re: Retropie won't boot into Attract mode...
« on: December 03, 2018, 01:29:00 AM »
From the terminal:
Code: [Select]
$ sudo nano /etc/rc.local
Note the commands to exit and such at the bottom of the terminal window. control + q will ask if you want to save the buffer to file.
Isn't that control+x? It is at least on my Retropie 4.4 (based on Debian Stretch). Control + x just says "XON ignored, mumble mumble".

Probably. It says what options are. I just wasn’t sure if he knew what the character represented by ^ meant.

Pages: [1] 2 3 ... 45