Attract-Mode Support Forum

Attract-Mode Support => General => Topic started by: YellowBirdAZ on November 08, 2020, 07:25:50 PM

Title: Aggravating Menu Control Bug
Post by: YellowBirdAZ on November 08, 2020, 07:25:50 PM
I have tried and tried I can't figure this out. It is the last significant bug in my new cabinet.

When I exit a game in an emulator and return to the AM display, there is a stray input or something that causes a PREVIOUS FILTER input. The designated sound effect also emits.

In the case of my chosen display, this bumps you out of the list from which you launched your last game into a completely different list.

Most of my stuff runs in Retroarch, but it also happens with a few MAME-emulated games. It is also intermittent.

The stray input problem happens whether I exit directly from the emulator (like go to Retroarch menu and select Quit Retroarch), or if I push escape key on my keyboard, or if I hit the designated quit key on my control panel. (So it isn't a bug in my control panel setup or config.)

I've tried this on the latest release and on the last available nightly Windows build.

I think I read someone else report the same issue, but I can't find that, not using the right keywords in my searches or something...
Title: Re: Aggravating Menu Control Bug
Post by: YellowBirdAZ on November 08, 2020, 08:17:16 PM
OK, I found a cure. But there may still be a bug that needs addressing -- I just found an acceptable way around the problem.

After comparing my attract.cfg with a default attract.cfg, I saw left, right, up and down were mapped to keys and a single joystick in the default config. In mine, since I have two sets on controllers on the panel, I have two joysticks mapped. I thought I would like the person standing at P2 controls to be able to navigate the menu, too.

When I removed the P2 joystick mappings, everything works fine again.

In retrospect, I makes more sense for P1 to be the "driver's seat" anyway, instead of having two people being able to control the menu simultaneously.

So problem solved, but kind of weird and maybe there is an issue lurking there somewhere.