Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - UnknownFigure

Pages: [1] 2
1
General / Re: CPU Usage 100%!! PC User
« on: December 12, 2018, 02:09:47 AM »
Thanks again, man. Really appreciate your help with the ffmpeg stuff.

2
General / Re: CPU Usage 100%!! PC User
« on: December 12, 2018, 02:04:05 AM »
I didn't bother to do that, Oomek. I mean, encapsulating it is a great idea, but cpu usage increases a tiny bit (perhaps 5%) if you turn on the static effect. I just turned it off, less cpu usage. I don't really know why I should leave it on. It's supposed to be the effect you get when you don't have a certain snap of the rom per si, right?

Better to leave it off. Yea.

3
General / Re: CPU Usage 100%!! PC User
« on: December 12, 2018, 12:57:01 AM »
Mostly all of them, but Basic and Reflect seem to work fine.

4
General / Re: CPU Usage 100%!! PC User
« on: December 12, 2018, 12:53:15 AM »
Go to Settings section, and select Displays. Now, you'll have to do this to each display you have, even the main menu. Select the display and go to Layout Options. In here, you'll find Enable Monitor Static Effect turned on by default, turn it off.

I've been using the Cosmos theme, which is quite demanding. Cosmos theme, without snaps or boxart/cartart, is around 15 to 40% or so. Well, with snaps and boxart/cartart, it doesn't change, same cpu usage.

On the default themes, Basic, Reflect, Attract, etc.. You'll get 5 to 10% of cpu usage with snaps, same without snaps.

In terms of threaded optimizations, there is no difference for me. I tried it, and it's even worse, constant 100%. If you have several threads, I think you should leave this option to Auto.

5
General / Re: CPU Usage 100%!! PC User
« on: December 12, 2018, 12:07:58 AM »
I've SOOLVEEDD IT!! YEEEESSHHH! Finally! Heh!

Oomek! Forget the threaded and buffer-flipping mode! Turn those to their previous setting. Now you'll still have to do the ffmpeg process that you told me before (Thanks AGAIN!).

Execute Attract Mode, and to each display layout, including the main menu, turn off the Static Monitor Effect. On the Cosmos theme, which is very demanding, i'm getting 18 to 44%, being 44% the video reload. On any other theme, you'll get 5 to 10%.

Don't ask me why, but it works. Give it a try, please.

 

6
General / Re: CPU Usage 100%!! PC User
« on: December 11, 2018, 09:54:17 AM »
Sadly, I get the same results.

But I've noticed a few things. The default Basic and Reflect layouts, without snaps, are at 1% of Cpu usage (Yes!). With snaps, they're around 44 to 55%. All other layouts with snaps, 100%. All this without avi containers.

So, for all the other layouts, it's 50% layout 50% snap. But here's the strange thing, Orbit is always at 100%, yet it is as simple as Basic or Reflect.

In any case, thanks for the help, Oomek. I'll either have to try another front end, or wait for the lead designer to release a build with Video Decoding by Hardware.

7
General / Re: CPU Usage 100%!! PC User
« on: December 11, 2018, 03:14:38 AM »
Doesn't work, Oomek. I get the same results.

Only 5% of Cpu usage?! This clearly shows something is not right here.

Oomek, is this the latest release of Attract Mode or are you using a specific version? 

8
General / Re: CPU Usage 100%!! PC User
« on: December 10, 2018, 11:45:29 PM »
I've just been told by a few people, that their cpu usage runs between 25 and 40 while displaying videos. Something doesn't make sense here. If it's a problem with the Video Decoder (No Hardware Option), then all the people would be having the same problem. But that's not the case. Most computer users are not experiencing any problems at all, while others are.

9
General / Re: CPU Usage 100%!! PC User
« on: December 10, 2018, 11:35:06 PM »
It looks like it solved the constant 100% usage, but it still reaches those limits when you're spinning the wheels, mainly due to starting each video, which results in 100% usage. Displaying the video usually takes around 80% or so.

Is this actually normal? What sort of cpu usage do you people have? My Attract Mode without videos is 50%.

10
General / Re: CPU Usage 100%!! PC User
« on: December 08, 2018, 10:40:12 AM »
I'm on Windows 10. You just extract ffmpeg.exe make 2 folders mp4 and avi. Then you copy or move your mp4 files to the mp4 folder. Make a bat file and paste the line from my post and add "pause" in the 2nd line. So now you should have 2 folders, ffmpeg.exe and a convert.bat in the directory. Doubleclick the bat and let the magic happen.

I'll try this as soon as possible. Thanks!

11
General / Re: CPU Usage 100%!! PC User
« on: December 08, 2018, 10:31:17 AM »
Oomek, your AM is on windows, right? Not rasp..

If so, could you explain a bit more? When you install/extract ffmpeg (From ffmpeg.org?), the folder itself contains a mp4/avi folder. So I need to transfer all my videos to those folders, and run the batch command.

Does this process take that long? Also, could you tell me how much it went down?

12
General / Re: CPU Usage 100%!! PC User
« on: December 06, 2018, 08:32:47 AM »
AFAIK MMAL is a Raspberry Pi specific thing so won't work on Win machine. MMAL > https://github.com/techyian/MMALSharp/wiki/What-is-MMAL%3F

Only thing which comes to mind is that videos are not properly encoded (and EmuMovies does have this problem with some system video-packs)

This doesn't make any sense. How can mmal be a specific thing for Rasp, when the XP version of Attract Mode has hardware support by ffmpeg 3.4?

13
General / Re: CPU Usage 100%!! PC User
« on: December 05, 2018, 10:22:02 PM »
this should not be happening... i mean well first is this on a home computer, is it dedicated to attract mode or what? second you might have other stuff running in the background. i spent over a year building my 4 player cab using win 7 and i have 0 issues. if your machine is dedicated to attract mode ill gladly share the info i have. (arcade,daphne,nes,snes,atari2600. is what im running.) also whats your hardware specs?

Nothing running on my background, I'm a msconfig maniac. Intel Core 2 Duo E6850 (Best Dual Core on the Market), it's running pretty much everything nowadays., 4 gb of 800Mhz ddr2, a Nvidia GPU special edition OC 2GB GDDR5 and two brand new components, a SSD of 120GB, and a 2 Tetra HHD.

I suppose you're using the Windows Xp version of Attract Mode, which has the mmal option (Hardware video decoder). Problem is, I don't have that option. DO I need to download and install ffmpeg to have this option show up in the video decoder setting?

By checking the forums, several people are having the same problem. Some of them solved it without mentioning the process, others simply left the front end.

14
General / Re: CPU Usage 100%!! PC User
« on: December 05, 2018, 02:01:04 AM »
Need some help. What do you have to do to get the mmal option for the video decoder on the Windows XP version of Attract Mode? Only got dxva2 and software.

Do I need to download anything?

15
General / Re: CPU Usage 100%!! PC User
« on: December 04, 2018, 06:53:57 AM »
Thanks for the help man.

I tried the windows XP version, without changing the folder name, only adding the video, rom and emulator. Only decoding options I have are dxva2 and software. dxva2 seems to reach 100% quite fast.

Is dxva2 the name of the decoder? I've read something about having another option called mmal, but I don't have it in the XP release.

Pages: [1] 2