Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - pocketpal

Pages: [1]
1
General / Re: Windows games focus issue
« on: January 05, 2018, 01:11:57 PM »
The only thing I can think of is if the .exe you're running launches another executable, and then quits itself.  Were this the case, to your batch file (just like with the shortcuts in AM) it would appear as if the game had exited, and the batch file would close, which would signal to AM that it was time for it to resume control.

I also had loads of trouble with the resolution issues you describe.  Several of my emulators would screw up the AM menu after exit, and ResFix only helped with one of them.  After a great deal of tinkering around, I eventually gave up, and just ran the problem emulators at 640x480.  I'm not getting the crispiest resolution I would like on my arcade monitor this way, but it isn't bad.

2
General / Re: Windows games focus issue
« on: December 26, 2017, 08:11:27 PM »
I was having weird issues at first, too, until I realized that I needed to change to the directory containing the executable with the 'cd' command prior to running it. So my batch files look like this:
Code: [Select]
@echo off
cd [path to directory containing executable]
[executable]
The path will need to be in quotes if it contains spaces, but that's it, and it works perfectly.

3
General / Re: No sounds at first
« on: December 20, 2017, 08:05:56 AM »
For what it's worth, in addition to the UI movement sounds and video snap sounds not working, each video snap will only play through once and quit instead of looping, like it should.  After I launch a game and return to AM, however, it all works as it's supposed to.

4
General / Re: Windows games focus issue
« on: December 20, 2017, 08:03:03 AM »
For what it's worth, I switched from using Windows shortcut *.lnk files to using batch files, and everything is groovy. My guess is the problem goes something like:
  • AM launches shortcut
  • shortcut launches game
  • shortcut has done it's job, so it quits
  • AM sees shortcut is no longer running and thinks it's time to take back control

5
General / Re: No sounds at first
« on: December 11, 2017, 09:13:26 AM »

My cabinet is over a decade old  ;)

Maybe its focus, try turning off console in options

Thanks for the suggestion, but I am running the "no-console" version.

6
General / No sounds at first
« on: December 08, 2017, 06:20:03 AM »
I am running AM 2.3 as the shell in WinXP SP3.  When it boots, I don't get any sound effects in AM. Once I launch a game, the sounds work fine in that game, and upon exiting, sound works in AM, too.  If I exit the frontend and reopen it, sounds work from the start, which makes the issue appear to be related to the fact that AM is the shell.  It should be noted, however, that the espeak plugin works right from the beginning, even though the other sounds do not.  Thoughts?

7
General / Windows games focus issue
« on: December 05, 2017, 08:04:09 AM »
Since upgrading to 2.3, my Windows games (non-emulator) are not launching correctly.  AM launches the selected game, but then regains the focus and runs simultaneously with the game in the background.  I can alt+tab to the game and play it, but it's slow and stuttery, and I can still hear the video playing in AM and selection sounds when I move the joystick!  I have searched high and low for a solution to no avail, and am starting to wonder if it's a bug.  Is anyone else experiencing this?

Pages: [1]