Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - estefan3112

Pages: [1] 2
1
General / Re: The dreaded MAME black screen on exit
« on: Yesterday at 01:57:19 PM »
I've done it, I've finally done it, damn them all to hell!!! :) :) :)

I've tried everything and finally found a fix for this, at least with my setup.  If you go into the actual MAME config (Config menu, emulators, mame) you'll see an option that says 'Non-blocking Wait Mode', I changed this to 1 (or 2 if your system is slow) and with the latest version of AM, you'll see a quick blank screen (if you're running Attract True Black, if not, it's your desktop) followed by the AM menu!!  Now if I could just figure out how to run Attract True Black to not trigger the Windows UAC...

You are a hero - all problems resolved under MacOS as well! The value 1 in 'Non-blocking Wait Mode' just brought everything back to normal. Many thanks, AM works again!

2
General / Re: The dreaded MAME black screen on exit
« on: November 11, 2018, 11:59:57 PM »
Same problem here in MacOS. Need to force-quite AM every single time. Tried all the potential workarounds with no help (even the Windowed mode, which always worked in the past, no longer works). Older MAME versions make no difference, and also a version 2.4.1 that worked before no longer works. Is this OS-related?

Renders Attract Mode more or less unusable for me for the time being.

3
General / Re: Attract Mode quit working?
« on: November 05, 2018, 12:53:12 PM »
Same problem here on AM for Mac: after exiting MAME, AM ends in a black screen.
Issue is open since quite some time and seems to become more critical now:
https://github.com/mickelson/attract/issues/374
It seems to be a major problem now...

4
General / Re: Issue with attract and my Mac
« on: November 04, 2018, 01:14:32 AM »
Now that version 2.5.0 is out, easy to test with a blank .attract directory 👍🏻

5
General / Re: Issue with attract and my Mac
« on: October 29, 2018, 01:12:55 AM »
Hi, I just wrote s small Blog entry about how stable AM is currently running:
https://mameonmacs.blogspot.com/2018/10/brief-update-on-attract-mode-24128.html?m=1
In the past I had issues on my Mac, e.g videosnaps did not run in my favorite layouts. I eventually did a fresh AM configuration by archiving the .attract folder and let AM create a new one. Since then no problems any longer, and the latest optimizations in loading artwork are impressive. So far a quite perfect piece of software for me!
Cheers and good luck

6
General / Re: Mac Users: Unofficial Mac Package 2.3.0-13
« on: January 06, 2018, 02:32:00 AM »
Many thanks Raygun, I will give it a try and report back further. Maybe Attract Mode brings me into coding a bit :-).
Sorry for the late reply and happy 2018!

UPDATE - I think that I could limit the error to exactly the the bundlelibs.py script - this is what I did:
- I installed Python via Homebrew and changed directory into the MacOS bundle with the unmodified working attract binary
- I applied bundlelibs.py to the unmodified attract binary and launched it via Terminal

Voila - attract ends up with the known segmentation fault. The long Crash Report is saved under Issue #397 on Github, it is too long for here.

Which means:
- If I run Attract Mode with an unmodified binary, it works (but only with the necessary libraries installed externally via Homebrew)
- If I run Attract Mode with the modified binary linking it into the bundled libraries, it crashes with the segfault documented in Issue #397
So the problem seems to lie in that modification as done by bundlelibs.py.


Thanks Raygun, this gives an idea.

7
General / Re: Mac Users: Unofficial Mac Package 2.3.0-13
« on: December 15, 2017, 01:08:33 AM »
A user reported back that there are problems with this build:
dyld: Library not loaded: /usr/local/opt/sfml/lib/libsfml-graphics.2.4.dylib
Referenced from: Attract.app/Contents/MacOS/./attract
Reason: image not found
This might mean that the application does not use the libraries in the package, but the ones under /usr/local/opt/, which I use for compiling.
So the package still is not ready for prime time.

In the create-pkg.sh, there is this section that shall link the libraries into the bundle - this and the bundlelibs.py script does not seem to work correctly:
# Copy extra libs to bundle and fix link path
pushd "${APPCONTENT}"/MacOS >/dev/null
${SCRIPT_PATH}/bundlelibs.py attract
popd >/dev/null

8
General / Re: Mac Users: Unofficial Mac Package 2.3.0-13
« on: December 13, 2017, 11:13:54 PM »
No idea. But your posts were my inspiration to do it in the very bulky way: create the bin, create the dmg, set the dmg to edit mode, manually copy the working bin into the dmg, set the dmg back to read-only mode. Since this works, the question why the script does not work seems even more puzzling.

What I forgot to write: This binary has no SWF support, which I understand is rather new and alpha-esque. Just if some artwork does not function (in my case, Nevato, Robospin and other popular layouts just work).

9
General / Mac Users: Unofficial Mac Package 2.3.0-13
« on: December 13, 2017, 01:42:42 PM »
To the extent that Mac users are not yet aware - there is an unofficial Mac Package of Attract Mode 2.3.0, in which Andrew ironed out the most critical compile errors. From my own testing, it seems to work quite well, and so far I have not received any negative feedback. Feel free to download!
https://mameonmacs.blogspot.co.at/2017/12/attract-mode-23013-for-mac-unofficial.html
Cheers!

10
Announcements / Re: Version 2.3 Released
« on: December 06, 2017, 01:15:00 PM »
I can confirm this and manually modified the dmg by adding the running binary to it.
The compressed image is ready for download and install.
Here it is  ;D.

https://drive.google.com/file/d/1Gjt-YKvH97lt78biQuBdtxTU9W8B6Bba/view?usp=sharing

If this successfully installs with Mac users, it would be great to know!
Not the most elegant way, but we are getting somewhere!
Cheers!

11
Announcements / Re: Version 2.3 Released
« on: December 06, 2017, 03:13:02 AM »
Same segfault here. What worked for me wasanually copying the new binary into the 2.2.0 App container and replacing the confit data in .attract with the newly compiled data. Far from perfect, however running  :D.

12
Announcements / Re: Version 2.3 Released
« on: December 05, 2017, 12:56:33 PM »
Great news - Attract Mode starts compiling on the Mac! Thanks to Andrew's great work!
https://github.com/mickelson/attract/issues/390
Right now this makes the trick:
make NO_SWF=1
Tonight I did a manual update of my MacOS app as well as the data in the .attract folder - and it works! See the screenshot in the above post! I understand that Andrew will also try to sort out this last obstacle. I still have to figure out how to create the Mac bundle.
 :D ;D

13
Announcements / Re: Version 2.3 Released
« on: November 20, 2017, 10:32:05 PM »
More than happy to help (if I can), I sent you a PM. Cheers!

14
Announcements / Re: Version 2.3 Released
« on: November 20, 2017, 01:50:42 PM »
Whar about us MacOS users? Any chance for an upgrade? I am quite dependent on AM on my Mac because it just rocks! Thanks and cheers!

15
General / Re: Mac Stays Black
« on: May 16, 2017, 02:00:06 PM »

Pages: [1] 2