Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - Dal1980

Pages: [1] 2 3
1
Themes / Re: SNES Classic Theme
« on: Today at 08:39:17 AM »
Yep, another vote here for the PC versions (Both Linux and Windows). There's probably even a MAC user that exist somewhere but they are probably thinking of dumping Apple so probably not worth worrying about them :P

Pi's are great but they are not a substitute for real hardware.

Theme looks really well done. Thanks for teasing everyone ;D :P

2
Themes / Re: Hello-Nintendo Theme
« on: Yesterday at 06:44:35 PM »
Thanks chad.burdette88  very kind of you to say ;D

Hey nice suggestion. Let me include that in an update and I'll make it one of the layout options so you can choose either the mushroom or the NES controller.

Ok, it's been done: https://github.com/zombiesbyte/hello-nintendo






3
Themes / Re: Hello-Nintendo Theme
« on: July 20, 2018, 03:28:45 AM »
I always forget to set the Notify me of replies checkbox. I think it's the only forum I'm on that does not default to notifications on.

Anyway...

Thanks for your kind words akafox  ;D

I'm currently working on a System Menu layout/theme. It's taken a bit of time to gather all the assets although the mechanics are all working I think. I'll post that soon in a new thread.

4
General / Re: Attract Mode Freezes in game menu
« on: July 08, 2018, 10:41:19 AM »
Couldn't be something to do with the SD card could it?

Corruption on card possibly, I'd probably go down that route (this thread may help https://www.raspberrypi.org/forums/viewtopic.php?t=8451 with that angle)

Or you could clone the SD onto another of the same size and see if the problem persists.

Or access speed of your SD might be the bottleneck https://www.sdcard.org/developers/overview/speed_class/



5
General / Re: Attract Mode Freezes in game menu
« on: July 07, 2018, 01:04:48 PM »
I had a similar issue if I'm remembering correctly.

I'm sure it had something to do with either a corrupt video or a video file format issue (i.e. avi over mp4) (fyi I try to use just mp4 because I've had less problems over the years... not that avi should be a problem I don't think).

Also, maybe check the file sizes of your videos, there may be one or two that are way to big for the pi to handle (that's a guess only but it may help on the angle of identifying potential corruptions, look for files size too small as well)

Hope this helps



6
Scripting / Re: Draw a box
« on: July 07, 2018, 11:43:00 AM »
Cool, nice one zpaolo11x, thanks  :)

7
Scripting / Draw a box
« on: July 07, 2018, 05:02:54 AM »
I'm not being stupid right, you can't actually draw a box in AM?  ???

Draw a box
Colour the BG using set_bg_rgb(#,#,#)
Access standard properties like mybox.x and mybox.y

add_text() is the closest I've found but this does not have .x and .y properties for some reason

Surely I'm missing something  :-\

8
Scripting / Re: Arcade cabinet picture for missing artwork...
« on: July 06, 2018, 02:41:27 AM »
I had some questions if you don't mind.

What theme are you using?
Does it do this with all themes?
Is this graphic part of your actual graphic set (i.e. have you checked that this wasn't just a placeholder image included in your logo art set)?

Cheers
Dal1980


9
MVS-InsertCoin
---------------------------------------------------------------------
Topic Link: http://forum.attractmode.org/index.php?topic=2315.0
YouTube: https://www.youtube.com/watch?v=ebG0kWYazMc
Download: https://github.com/zombiesbyte/mvs-insertcoin
--------------------------------------------------------------------



10
Themes / MVS-InsertCoin (Neo Geo) Theme
« on: July 03, 2018, 10:05:51 AM »
Hi guys

Here's another theme (this one I was jumping backwards and forwards with as I had a few issue) but there's just the one issue left which is to pre-populate missing graphic with a place holder but that thing has been an issue for over a year and a half for me (http://forum.attractmode.org/index.php?topic=1132.0)

Anyway, 5:4 again since that's what my cab is but hope you get some use out of it too.









YouTube: https://www.youtube.com/watch?v=ebG0kWYazMc

Download: https://github.com/zombiesbyte/mvs-insertcoin

Enjoy!

11
Themes / Re: Hello-Nintendo Theme
« on: July 03, 2018, 08:56:51 AM »
Hi ilikecheese9000

Yes,  I'm hoping to get through all systems (and maybe some collections too)

I am still finishing off (I kind of went away and came back to) a NeoGeo theme which I'll post in it's own topic on here.

Thanks
 
Dal

12
Hello-Nintendo
---------------------------------------------------------------------
Topic Link: http://forum.attractmode.org/index.php?topic=2314.0
YouTube: https://www.youtube.com/watch?v=M9e8xJY-XY0
Download: https://github.com/zombiesbyte/hello-nintendo
--------------------------------------------------------------------


13
Themes / Hello-Nintendo Theme
« on: July 03, 2018, 03:23:28 AM »
Hi Guys

Wanted to share my new 5:4 theme I made based on the NES style.

V1.0



Favourites badge at the top




Various grid sizes and art configurations










Let me know if you have any questions

YouTube: https://www.youtube.com/watch?v=M9e8xJY-XY0

Download: https://github.com/zombiesbyte/hello-nintendo


14
keilmillerjr, You may have an idea on how to do this better but sharing it on a forum is the whole point of the forum!

Or should the world just PM you?  :o

Welcome to the Forums where people meet up and PM solutions

15
Scripting / Re: ScrollingText module
« on: June 27, 2018, 03:02:21 PM »
Don't know if this helps but I ended up having an annoying problem with sending values created from functions over to the scrollingtext. It would either cull any text after the function call even if I had stored the value in a variable before including it in the string or stop all other variables from being populated and somehow write over existing string with a populated value much like how the insert key works on the keyboard. My only guess was that it picked up a new line "/n" or carriage return "/r" (which doesn't explain everything anyway) somewhere but even after sanitising data it still seemed to be an issue. I ended up leaving it alone and just working around the problem.

Code: [Select]
    //function simpleCat just spits out the first cat name from catver.ini
    function simpleCat( ioffset ) {
      local m = fe.game_info(Info.Category, ioffset);
      return split( m, " / " )[0];
    }

    local txtMarquee = "*** [Title] *** Manufactured by [Manufacturer] in [Year] *** Listed Category: [!simpleCat]";
    local scroller = ScrollingText.add( txtMarquee + " ***", flw*0.450, flh*0.001, flw*0.370, flh*0.055 );

    //the above produces something like the following
    //*** A game title *** Manufactured by SomeCo in 1980 *** Listed Category: Sports
    //notice even concatenating the extra 3 **** at the end does not show

    //but if I do this
    local txtMarquee = "*** [Title] *** Listed as [!simpleCat] and Manufactured by [Manufacturer] in [Year] *** Insert Coin";
    local scroller = ScrollingText.add( txtMarquee + " ***", flw*0.450, flh*0.001, flw*0.370, flh*0.055 );
    //I get weird results
    //*** A game title *** Listed as Sportsufactured by in *** Insert Coin ***
    //I've lost my [Manufacturer] and [Year] magic tokens


I don't think this will be a fix in your script, you may need to start pulling the scrollingtext module apart. Maybe someone could shed some light on this but for me I went with a cheap workaround for now.

Pages: [1] 2 3