Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - tonberryhunter

Pages: 1 [2] 3 4
16
Themes / Re: TurboGrafx-16 mini layout update v1.0!
« on: May 21, 2020, 06:50:18 PM »
Some of these graphic assets seem to be much higher resolution than needed. "grafxmenu2.png" for example is 8000 x 842 this basically makes the theme unusable on the raspberry pi.  Is there any reason you chose to make these assets so high res?  Perhaps scale them down to 1080p since this is still the most common res.  I'm trying to think who has a screen res that is 8000 pixels wide?  The theme would run more efficiently with smaller sized assets.  Think of how images are prepared for web. 

Edit:  Just loaded one of your graphics and realized your running at 300 dpi.  Note this is a print resolution not a screen res.  Screen res is 72 dpi.  Also noticed you used some sort of crazy pixel scaling filter on the asset?   

17
General / White border around transparent pngs
« on: May 21, 2020, 06:21:39 PM »
I've noticed in the newer Retropie Builds of Attract mode that some of my transparent .pngs now have borders.  I double checked the same .pngs on my Windows build and they dont appear.  I also checked to see if there was infact any white or colored pixels around the border of the images in question.  They dont exist but for some reason I'm getting this border artifact in Attract Mode now on my Raspberry Pi. 

Further testing reveals that lower resolution wheel images are more likely to get this artifact.  So perhaps its related to how Attract Mode handles image scaling.   


18
General / Attract Mode missing from Retropie Setup on Pi 4?
« on: May 05, 2020, 01:14:27 PM »
I'm sure this has already been posted but why is Attract Mode missing from from the Retropie Setup menu?  If someone could point me in the direction of how to compile on the Pi 4 that would be much appreciated.

EDIT / Found this : https://github.com/mickelson/attract/wiki/Compiling-on-the-Raspberry-Pi-4-(Raspbian-Buster)

EDIT 2 / Now I'm getting an error message when trying to start Attract after compiling according to the above link

Code: [Select]
* failed to add service - already in use?
Thank you

19
I like the cross platform nature of Attract Mode.  So I'm constantly working on updating it for all my systems.  I also like running it on my handheld which has no choice but to run Retropie since its based on the Raspberry Pi.  In all honestly while the Raspberry Pi is weaker than my i7 gaming pc its more exciting getting a single board computer to emulate.  I wouldn't discount the Retropie development scene just because the hardware isnt as powerful.  The future of emulation seems to be single board computers and mobile based operating systems.  Sure it was exciting 10 years ago to take an old Windows XP machine and put it in a big old arcade machine but I think the portable emulation scene is far more exciting these days.  Attract Mode will eventually get left behind by faster more efficient frontends with the next wave of SBCs and Raspberry Pi models.  While I like Attract Mode the development has been stagnant with no major improvements in the last 3 or so years.  I appreciate the work done so far but fear the project is dead and I personally lack the coding skills to improve on it. 

Ive already compiled Attract Mode from scratch and an update from Retropie Setup menu doesnt break it aside from adding displays back in that you have previously removed.  Which isnt too much work to clean up.  I actually find the software decoder more reliable when it comes to video snaps on the Raspberry Pi.  The hardware decoder does not seem to improve playback that much and many times video snaps will lock up the system (regardless of file size).  The scraper in Attract Mode is still broken for both PC and Linux?   

Also noted on my Windows build video snaps have audio desync issues.       

Thanks for your time     

20
Hmm I might opt for the exiting AM loads Emulation Station.  That seems a little more graceful and faster?  Its critical to get back to Emulation Station to configure a new controller since Attract Mode configs arent tied to Retroarch or Emulation Station unless I'm missing a workaround there.  Attract Mode would be perfect if its controller configs acted globally like Emulation Station.  Will Attract Mode ever make it out of experimental in Retropie?   

Thanks for all your help. 

21
So it cant be done without a reboot everytime is what your saying?  This is a script that rewrites the autostart.sh config and reboots?  It would be essentially rewriting the autostart.sh everytime I wanted to switch between the two?   

Thanks for your reply

22
General / Switch to Emulation Station from Attract Mode (Retropie)?
« on: March 21, 2020, 05:45:25 PM »
Is it possible to add a menu shortcut back to Emulation Station once in Attract Mode?  Ive added links to Retropie Setup and various other configs from Attract Mode but cant seem to get back to Emulation Station without returning to the command line and typing emulationstation.  Would like something slicker than that. 

Thanks

23
General / Windows .bat files wont load in Attract Mode
« on: April 20, 2019, 08:14:45 PM »
I cant get .bat files to load within Attract Mode.  They work within Windows fine but not Attract Mode.

Here is my Windows.cfg

Code: [Select]
# Generated by Attract-Mode v2.5.1
#
executable           cmd
args                 /c "[romfilename]"
rompath              \roms\pc
romext               .bat
system               PC Games
exit_hotkey          Joy0 Button6+Joy0 Button7
artwork    flyer           \Attract Mode\scraper\Windows\flyer
artwork    marquee         \Attract Mode\scraper\Windows\marquee
artwork    snap            \Attract Mode\scraper\Windows\snap
artwork    wheel           \Attract Mode\scraper\Windows\wheel

Also here is a sample .bat file

Code: [Select]
@echo off

rem Run game application
cd .\Blade Strangers
start game.exe %*

24
Thanks progets Removing the screen redirection fixed it but why was this not an issue in an earlier version of Attract Mode I was running?  I believe I had that in there for a portable build I'm working on but it was never an issue for my non portable builds til the latest version of Attract Mode.  As I said I ran a quick test with this older install and only after compiling did it break this function.   

25
The plot thickens.  I just recompiled my other attract mode install that was working fine (aside from the broken scraper) and that indeed broke the Retropie menu in Attract Mode.  So the issue isnt on Retropies end its a fault of the latest Attract Mode build.   

This is the exact emulator setup I had for Retropie Setup that was working before I complied Attract mode just now.  Note that everything else functions as it should this includes all my emulators.  This file was last edited in April 2018 it has not been touched since. 

Code: [Select]
# Generated by Attract-Mode v2.2.1
#
executable sudo
args                 /home/pi/RetroPie-Setup/retropie_packages.sh retropiemenu launch "[romfilename]" </dev/tty >/dev/tty
rompath /home/pi/RetroPie/retropiemenu
romext .rp;.sh
system RetroPie
artwork    flyer           /home/pi/RetroPie/retropiemenu/flyer
artwork    marquee         /home/pi/RetroPie/retropiemenu/marquee
artwork    snap            /home/pi/RetroPie/retropiemenu/icons
artwork    wheel           /home/pi/RetroPie/retropiemenu/wheel

26
Yeah that used to fix issues with Retropie setup not loading from Attract Mode.  This issue has nothing to do with the screen settings of Attract Mode.  I tried that first before coming here.  I normally dont update Retropie because it always seems to break Attract Mode but I figured why the hell not and then well here we go.

 

27
I'm having the same problem.  Cant load any of the retropie setup items from within Attract Mode like I used to.  I get the vibe that Attract Mode development has come to a halt for Retropie. 

Here is the error I get when I try to load any of the items on the Retropie Setup menu from within Attract Mode.

Code: [Select]
*** Running: sudo /home/pi/RetroPie-Setup/retropie_packages.sh retropiemenu launch "/home/pi/RetroPie/retropiemenu/rpsetup.rp" </dev/tty >/dev/tty
Parameter word expansion failed. [/home/pi/RetroPie-Setup/retropie_packages.sh retropiemenu launch "/home/pi/RetroPie/retropiemenu/rpsetup.rp" </dev/tty >/dev/tty].

28
General / Attract Mode on Retropie Scraper still broken?
« on: October 11, 2018, 07:11:26 PM »
Apparently the Retropie version of Attract Mode still wont scrape since the TheGamesDB updated stuff.  I fixed it on my PC build but updating Attract Mode on my Raspberry Pi does not seem to fix the scraping function of Attract Mode.  Also why the hell is Attract Mode still "experimental" on the Retropie menu?  Do you guys have beef with the Retropie guys?

thanks

29
I tried getting used to Rocket Launcher way back in my Hyperspin days.  Yes it boasts some cool features but the software is obtuse and clunky to say the least.  After upgrading to Attract Mode, Retroarch and Emulation Station I dont ever want to think about all the struggles I had with RL and HS. 

30
General / Weird bug when loading Windows game with Attract Mode
« on: September 07, 2018, 08:05:33 PM »
When I try to load Tower Fall from within Attract Mode I get a Windows 7 error that pops up with "No suitable graphics card found!"

Even weirder is that if I run Attract Mode windowed it loads fine.  I tried both Windowed no border and with and it worked as long as the window was not maximized.  When maximized I would get the same error message again.

Note that the game loads fine outside of Attract Mode and when Attract Mode is windowed but not maximized.  Its as if Attract mode is blocking Tower Falls access to my GPU.   

Windows 7 x64 / latest attract mode / Game is Tower Fall - Ascension

Thanks in advance this is driving me nuts. 

Pages: 1 [2] 3 4