Recent Posts

Pages: [1] 2 3 ... 10
1
General / Re: Hotkey+F causing emulators to restart
« Last post by slowsl on Today at 12:25:15 PM »
Okay, I've abandoned modifying it, just using system specific config files now.  Strange thing is I've always used the /configs/all/retroarch.cfg file on my older build with zero problems ever. 
2
General / Re: OpenBor AttractMode
« Last post by hermine.potter on Today at 10:09:23 AM »
3
General / How can I change font size for the tag/filters menu?
« Last post by slowsl on Today at 06:36:27 AM »
The font is huge for some reason on my tag & filters menu, I can't seem to find where the font size is set.  I tried the layout.nut file, but could only find where it loads the font, nothing about the font size. 
4
General / OpenBor AttractMode
« Last post by cyclair on Today at 04:31:44 AM »
Good morning all,

I am currently installing the openbor which works fine with openbor.exe but in attractmode it opens openbor.exe for me and not the game directly.
How to do with the args line to directly open a game by openbor.exe.
here is my args for openbor.
thank you in advance.

# Generated by Attract-Mode v2.6.0
#
executable           E:\AttractMode\OpenBor\OpenBOR.exe
args                 -f
rompath              E:\AttractMode\OpenBor\Paks
romext               .pak
artwork    flyer           
artwork    marquee         
artwork    snap            E:\AttractMode\Roms\OpenBor\Snap
artwork    wheel           E:\AttractMode\Roms\OpenBor\Wheel
5
General / Re: Roms into subfolders
« Last post by Firefoxian on Yesterday at 08:13:11 PM »
e.g. zsnes:
if folder-name and romfilename are identical (C:\attract\EMU\zsnes\roms\mygame1234\mygame1234.smc)
Code: [Select]
executable           C:\attract\EMU\zsnes\zsnesw.exe
args                 -m "[romfilename]\[name].smc"
rompath              C:\attract\EMU\zsnes\roms\
romext               <DIR>

set as rom-extension <DIR>
and set as argument for zsnes -m "[romfilename]\[name].smc"

just adjust config to dreamcast arguments.

this was a good start for me, but does not factor in different rom types (for those that may have multiple). consider emulating with retroarch and using m3u files
args                 -m "[romfilename]\[name].m3u"
In this system, you can use many types of files like zip, iso, smc all under the same wheel/emulator. Look up https://forums.libretro.com/t/multi-disc-for-sony-playstation-and-sega-saturn-using-m3u-files/14161
One other thing that works for multiple rom types (in folders) under one wheel is to set up multiple emulators and then use "generate rom list" to combine them into one for a display. Both ways take some setting up.

also, a tip i'll note here is that [romfilename] and [rompath] add an extra / to the end which can mess up any  build. most of the time the /\ effective command line cancels itself out, but some emu's apparently don't like that. I I used a relative path like: args                 -m "..\roms\snes\[name]\[name].m3u"
6
General / Re: Atomisewave AttractMode
« Last post by akafox on Yesterday at 07:32:43 PM »
Please show me string from the command line you use to launch retroarch do not start the game with the gui please

(from the windows "run.." menu type [Press Windows+R to open “Run” box. Type “cmd” and then click “OK” to open a regular Command Prompt.
Code: [Select]
cmd.exe and use the command line and start a game that way then post it here. (please remember to replace your user name with the word user..as this is a "public" forum..)

just trust me here..I am here to help you..I am not after your chickens...
7
General / Re: Hotkey+F causing emulators to restart
« Last post by mahuti on November 21, 2020, 01:13:07 PM »
I've never had luck changing things globally with RetroPie.
8
General / Re: Daily Windows Build available.
« Last post by dabone on November 21, 2020, 12:06:38 PM »
Quote
your link is dead


Whoops... reconfigured the webserver the other day..



Fixed.
9
General / Re: Hotkey+F causing emulators to restart
« Last post by slowsl on November 21, 2020, 11:54:17 AM »
Thanks.  I understand the hierarchy.... global/core/game specific .cfg. files.  Was first trying editing the configs/all/retroarch.cfg, no luck, tried everything.  Deleted the file, restarted, and it made the new file, but was named retroarch.cfg.rp-dist, and I had to manually rename to retroarch.cfg.  the restart glitch was resolved, but then the hotkeys stopped working.  I even restarted to emulation station and setup my inputs again, making sure to bind my hotkey, but still no luck.  It must not be grabbing that .cfg file, the hotkey is clearly bound and enabled in the .cfg file.  There is no info in the autoconfig.cfg, and no files in the joypad folder (using ipac2 as keyboard).  This was extremely easy and clear cut on my old Floob's image, but this is acting very strangely.  I worked around it by opening the retroarch gui from a snes game, made all of my key bind changes and saved.  I then manually copied the .cfg to all of my other systems.  Not the proper way to do it but at least it's all working now, but still won't be able to globally change anything.
10
General / Re: Hotkey+F causing emulators to restart
« Last post by mahuti on November 21, 2020, 08:45:01 AM »
The master file isn't really a master. Its a default, and some settings you really have to work at changing.

Edit these:
/opt/retropie/configs/all/retroarch.cfg
/opt/retropie/configs/EACH_OF_YOUR_CONFIGURED_EMULATORs/retroarch.cfg
/opt/retropie/configs/all/retroarch-joypads/YOUR_CONFIGURED_JOYPADS.cfg  /opt/retropie/configs/arcade/retroarch.cfg

I keep track of all the things I have to do with the pi here https://github.com/mahuti/arcadepi that doc may be of some use with other weird and annoying pi things.
Pages: [1] 2 3 ... 10