Author Topic: Emulators wont Load  (Read 558 times)

Grahf

  • Newbie
  • *
  • Posts: 4
    • View Profile
Emulators wont Load
« on: February 13, 2019, 06:57:10 PM »
Can't get a game to launch with attract mode.  Running  retroarch -f -L /usr/lib/libretro/snes9x_libretro.so EarthBound.sfc
from a terminal works just fine.  BTW, I'm using Manjaro Linux.  But when I click the game title in attract mode..... the screen just blinks.

I've dried like a dozen different things in SNES.cfg.  Right now executable line reads /usr/lib/libretro/snes9x_libretro.so.  I've also tried Retroarch -f -L /usr/lib/libretro/snes9x_libretro.so %ROM% and retroarch -f -L /usr/lib/libretro/snes9x_libretro.so

 For args I have tried retroarch -f -L "[romfilename]" and "[romfilename]" and -f -L "[romfilename]"

How exactly is this supposed to be done?

rand0m

  • Sr. Member
  • ****
  • Posts: 240
    • View Profile
Re: Emulators wont Load
« Reply #1 on: February 13, 2019, 07:21:43 PM »
Code: [Select]
executable      Path\to\Retroarch\retroarch.exe
args                        -L "Path\to\Retroarch\cores\snes9x_libretro.dll" "[romfilename]"

Grahf

  • Newbie
  • *
  • Posts: 4
    • View Profile
Re: Emulators wont Load
« Reply #2 on: February 13, 2019, 07:51:46 PM »
Well I dont have dll files but ill try something similar when I get home

Grahf

  • Newbie
  • *
  • Posts: 4
    • View Profile
Re: Emulators wont Load
« Reply #3 on: February 14, 2019, 09:17:31 AM »
OK for anyone using linux the config is as follows:

executable           retroarch
args                 -f -L /usr/lib/libretro/snes9x_libretro.so "[romfilename]"

akafox

  • Hero Member
  • *****
  • Posts: 797
    • View Profile
Re: Emulators wont Load
« Reply #4 on: February 18, 2019, 03:13:41 PM »
I have to ask what the -f flag is for... (OH! fullscreen)

I use ubuntu mate everything works fine for me.

here is what I use

executable           retroarch
args                 -L /usr/lib/x86_64-linux-gnu/libretro/snes9x_libretro.so "[romfilename]"

to use the -f flag I had to do this:

executable           retroarch
args                 -L /usr/lib/x86_64-linux-gnu/libretro/snes9x_libretro.so "[romfilename]" -f

you can set the full screen flag from the retroarch gui though that is what i did
« Last Edit: February 18, 2019, 03:25:10 PM by akafox »
People want life easy..then complain about it