Author Topic: Exit Attract Mode  (Read 11857 times)

ozboss

  • Jr. Member
  • **
  • Posts: 17
    • View Profile
Exit Attract Mode
« on: December 11, 2016, 12:15:18 PM »
So in the displays menu there is, besides the emulators an option to "Exit Attract-Mode", but when i press it,
it just exits attract mode but doesn't execute the shutdown, like it does when i press esc in the displays menu and then exit.

How can i change this?
How would i be able to delete this from the displays menu entirely?

progets

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 749
    • View Profile
Re: Exit Attract Mode
« Reply #1 on: December 11, 2016, 04:13:13 PM »
Configure-->General-->Allow Exit from "Displays Menu" = No

ozboss

  • Jr. Member
  • **
  • Posts: 17
    • View Profile
Re: Exit Attract Mode
« Reply #2 on: December 12, 2016, 02:54:17 AM »
sry i forgot to mention that im running on retropie....
i don't have this option

ozboss

  • Jr. Member
  • **
  • Posts: 17
    • View Profile
Re: Exit Attract Mode
« Reply #3 on: December 13, 2016, 05:15:53 AM »
i actually found it, but it's in configure->displays->'displays menu' options, for anybody else that has this problem

pghretroguy

  • Full Member
  • ***
  • Posts: 27
    • View Profile
Re: Exit Attract Mode
« Reply #4 on: December 21, 2016, 10:38:02 AM »
This is funny. When I hit back a few times and select "yes" at "Exit Attract-Mode", it just takes me to the command prompt where I can type exit to take me back to AM. I want that function to shutdown the Pi. Any ideas? Thanks!

hermine.potter

  • Sr. Member
  • ****
  • Posts: 404
    • View Profile
Re: Exit Attract Mode
« Reply #5 on: December 21, 2016, 10:25:51 PM »
@pghretroguy
AM does, what you AM tell
Exit AM => it exits the application AM
closing an application doesn't mean a complete shutdown of OS
that's all.

start AM > press TAB > General > Exit Command : sudo poweroff
AM Version : 2.4.0
Input : Mad Catz Brawlstick; Mouse; Keyboard; Xbox360 Wireless
Cabinet : Yes
OS : WindowsXP x86 SP3
System : Dell Precision T3500 ; Intel X5650 ; 4GB RAM
Emulators : zsnes; mame; dosbox; scummvm; bsnes; fusion; openbor; windows_games; winuae; video; flashgames; vice; visualboy

tonberryhunter

  • Full Member
  • ***
  • Posts: 34
    • View Profile
Re: Exit Attract Mode
« Reply #6 on: December 25, 2016, 02:04:34 AM »
sudo poweroff just brings be to the command line same thing with sudo shutdown

foreverclumsy

  • Newbie
  • *
  • Posts: 3
    • View Profile
Re: Exit Attract Mode
« Reply #7 on: January 02, 2017, 01:58:26 PM »
sudo poweroff just brings be to the command line same thing with sudo shutdown
I am having the same issue as well. Both commands just exit to the command line.

gepponline

  • Jr. Member
  • **
  • Posts: 15
    • View Profile
Re: Exit Attract Mode
« Reply #8 on: January 02, 2017, 02:50:31 PM »
havw you tried with "sudo shutdown now"  ?

progets

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 749
    • View Profile
Re: Exit Attract Mode
« Reply #9 on: January 02, 2017, 08:53:03 PM »
FYI - When you add "sudo poweroff" it will not work on your first exit because the file is loaded in memory. If you have issues getting this working, reboot your Pi after adding it.

ozboss

  • Jr. Member
  • **
  • Posts: 17
    • View Profile
Re: Exit Attract Mode
« Reply #10 on: January 04, 2017, 09:53:20 AM »
the normal command i think is 'sudo shutdown now -P'

jretropie

  • Newbie
  • *
  • Posts: 9
    • View Profile
Re: Exit Attract Mode
« Reply #11 on: January 06, 2017, 07:57:42 AM »
sudo shutdown -P now

('P' must be capital)

foreverclumsy

  • Newbie
  • *
  • Posts: 3
    • View Profile
Re: Exit Attract Mode
« Reply #12 on: January 06, 2017, 01:53:21 PM »
i copied the exact run command that AM uses when you select "shutdown" option from "attract mode setup".

Code: [Select]
sudo /bin/bash "/home/pi/.attract/Attract Mode Setup/Shutdown.sh"
Which if you opened the Shutdown.sh, it says:

Code: [Select]
#!/usr/bin/env bash
sudo shutdown -P now

tekn0

  • Full Member
  • ***
  • Posts: 36
    • View Profile
Re: Exit Attract Mode
« Reply #13 on: July 06, 2017, 10:21:14 AM »
Is there a way to change the exit text on the Pi to say "Shut Down System" instead of "exit attract-mode?" I can not seem to find this file to edit it.

hermine.potter

  • Sr. Member
  • ****
  • Posts: 404
    • View Profile
Re: Exit Attract Mode
« Reply #14 on: July 06, 2017, 09:48:51 PM »
@tekn0
Thread...

if you're using english language file :
Code: [Select]
sudo nano /usr/local/share/attract/language/en.msg

add under '#Interface strings' this line:
Code: [Select]
Exit Attract-Mode?;Shut Down System
AM Version : 2.4.0
Input : Mad Catz Brawlstick; Mouse; Keyboard; Xbox360 Wireless
Cabinet : Yes
OS : WindowsXP x86 SP3
System : Dell Precision T3500 ; Intel X5650 ; 4GB RAM
Emulators : zsnes; mame; dosbox; scummvm; bsnes; fusion; openbor; windows_games; winuae; video; flashgames; vice; visualboy