Author Topic: Exit Emulator Leaves Game Running  (Read 3630 times)

kellyahlers

  • Newbie
  • *
  • Posts: 4
    • View Profile
Exit Emulator Leaves Game Running
« on: February 04, 2017, 10:23:04 AM »
Hey there. I setup the exit Emulator button to a dedicated button on my cab. Problem I have is it exits to attract mode but leaves the game running in the background. If I press start and select it exits the game properly but not the attract mode exit button. I configured the inputs in emulation station which I'm guessing sets up defaults for the emulators themselves? Help please.  :)

akafox

  • Hero Member
  • *****
  • Posts: 797
    • View Profile
Re: Exit Emulator Leaves Game Running
« Reply #1 on: February 04, 2017, 07:49:17 PM »
Are you trying to change the default exit button for attract mode or the default exit button for the emulators?

Are you wanting Attract mode to exit by pressing start select?

People want life easy..then complain about it

progets

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 885
    • View Profile
Re: Exit Emulator Leaves Game Running
« Reply #2 on: February 04, 2017, 09:30:02 PM »
You can try setting Configure-->Emulators-->emulator-name-->Exit Hotkey = your-button

kellyahlers

  • Newbie
  • *
  • Posts: 4
    • View Profile
Re: Exit Emulator Leaves Game Running
« Reply #3 on: February 05, 2017, 06:33:46 AM »
Hey guys. I did what progets suggested and when I press exit it returns to attract mode but leaves the emulator running in the background. 

I want a dedicated exit button as I have buttons dedicated for exit, favorites, menu and play.

akafox

  • Hero Member
  • *****
  • Posts: 797
    • View Profile
Re: Exit Emulator Leaves Game Running
« Reply #4 on: February 05, 2017, 06:59:35 AM »
OK so you want one single button to exit the game and attract mode? Like I use the center button on mu controller and not the start select combo?
So when you exit what happens? Attract mode exits but the game (if running) is still running in the background? I understand wanting one button to quit games..but I would want a combo for attract mode...just to keep others from exiting Attract Mode and screwing something up.

What progets suggested is correct. You know that the "exit button" on the emulators are managed by retroarch configs unless you are using advmame. IF you are using advmame for arcade then you just load a game inadvmame and press the TAB key --> input general --> user interface --> UI cancel ..Change that key there (you can set up a combo too.)

If you are using a retroarch core then it's more complicated. That depends on what core and how many cores you are using. What cores are you using and systems are you running..maybe i can walk you through it.

Are you using a raspberry pi and an image or are you using a PC and which operating system are you using?
People want life easy..then complain about it

kellyahlers

  • Newbie
  • *
  • Posts: 4
    • View Profile
Re: Exit Emulator Leaves Game Running
« Reply #5 on: February 05, 2017, 08:27:52 AM »
Hi akafox.  I want a single button to exit the game. No button to exit attract mode as I just turn off the arcade. I'm running a raspberry pi 3 with an image. It's retropie with ES and attract mode.  I believe it was floob image but can't remember. . I used emulation station to configure the joystick which seems to automatically create a hotkey. Im assuming I need to edit a retroarch.cfg or the xin mo controller config but wasn't sure which to start with.

I tried the exit Emulator in attract mode and while it does return to attract mode the game is still playing in the background. 

kellyahlers

  • Newbie
  • *
  • Posts: 4
    • View Profile
Re: Exit Emulator Leaves Game Running
« Reply #6 on: February 05, 2017, 09:08:01 AM »
Figured it out.  Had to edit  /opt/retropie/configs/all/retroarch-joypads/Xin-Mo Xin-Mo Dual Arcade.cfg and I took out the hotkey button and edited the buttons I wanted for exit, play, etc...

At least it seems to work for now.  I'll go with this for now.  Thanks for all the suggestions and help!