Author Topic: New Issue with DOS window  (Read 1415 times)

epicrean

  • Jr. Member
  • **
  • Posts: 11
    • View Profile
New Issue with DOS window
« on: February 25, 2017, 02:39:15 PM »
When I start attract mode a black dos windows opens and shows the behind the scene magic, this window was minimizing on its own, now it sits there and I need to click on attract mode.  thoughts?

kaptainsteve

  • Jr. Member
  • **
  • Posts: 22
    • View Profile
Re: New Issue with DOS window
« Reply #1 on: February 26, 2017, 07:34:46 AM »
Try changing the setting from fill or full screen to windowed mode with no borders.
Worked for me.

djrobx

  • Full Member
  • ***
  • Posts: 30
    • View Profile
Re: New Issue with DOS window
« Reply #2 on: February 26, 2017, 08:02:47 AM »
I had this problem too.  Full screen mode helps mostly but sometimes the console window will pop back up over the UI.   It also breaks the trackball/mouse support (the mouse cursor will appear wherever the console window is and AM won't get the movement events properly).

There's a utility you can google for called Hidden Start (hstart.exe).   If you launch attract.exe through it (hstart.exe /NOCONSOLE attract.exe) the console window goes away fully and it works properly.
 

8bitsdeep

  • Full Member
  • ***
  • Posts: 49
    • View Profile
Re: New Issue with DOS window
« Reply #3 on: February 26, 2017, 01:07:43 PM »
If you don't care about the console window at all (handy for debugging sometimes), do this:

In attract.cfg, in the general section: change hide_console from no to yes.

djrobx

  • Full Member
  • ***
  • Posts: 30
    • View Profile
Re: New Issue with DOS window
« Reply #4 on: February 26, 2017, 05:01:00 PM »
Thanks!

I thought I saw that option somewhere but couldn't find it again when I later determined that the console window was causing me issues.  :)