Author Topic: Fix For glGetError 0X500  (Read 1123 times)


  • Newbie
  • *
  • Posts: 5
    • View Profile
Fix For glGetError 0X500
« on: September 11, 2017, 12:47:25 PM »
Has a fix ever been found for the glGetError 0X500 on the Raspberry Pi 3?  I've done a full new fresh install from the Experimental Menu in the Retropie Setup Script but I still have the error.  I can see that it appears from commits were made to fix this issue within the GLideN64 chain of code but I'm still getting the error pop up every time I launch something.

I understand this code affects the system in no away but I'm trying to make my setup as clean as possible and because it's kicking out this error every time I launch a game I can see the terminal pop up for a couple of seconds.

Thanks in advance.  I've looked all over and studied the code that was supposed to fix this issue but I can't see to locate it on my set up to clean it up and updating what I can doesn't seem to provide a fix either.


  • Newbie
  • *
  • Posts: 2
    • View Profile
Re: Fix For glGetError 0X500
« Reply #1 on: February 01, 2018, 10:41:31 AM »
In case you never solved this: after compiling the latest AM from source this error no longer appears for me.

There is a useful tip at the bottom of the build instructions:

"Add the parameter "-j4" when you run make on a pi2 or pi3 to speed the build significantly."

This tip would probably be more useful at the top of the instructions!

AM itself doesn't take long to compile on an RPi3. FFMPEG, on the other hand, takes about an hour if you don't use -j4... you know, because you didn't read that far down at the start :P

Caveat: Your layout may or may not be 100% compatible with AM 2.3.0, depending on how recent your layout is. Take a backup of your SD card first! I used an older (10 months or so) pre-built image and had to make a couple of modifications to the layout files after building the latest AM.
« Last Edit: February 01, 2018, 04:12:20 PM by wildstoo »