Author Topic: Problem plugin - Random  (Read 2262 times)

manivanilli

  • Newbie
  • *
  • Posts: 3
    • View Profile
Re: Problem plugin - Random
« Reply #45 on: December 06, 2018, 10:07:53 AM »
Pushed small update. Plugin should wait for intro to finish before activating plugin. Please test and report back if it doesn’t work. I didn’t actually test it.

As is, screensaver will never become active unless screensaver time is less than sequencers delay time (which would be pointless). One option is to not use a screensaver. Harsh, I know. Second option, differentiate between signals from the plugin and actual user plugins. I could then keep track of time the user was away and activate the screensaver manually a signal that you preset in the config to activate the screensaver. Plugin would have to disable when the screensaver is active, and enable when returning. Thoughts?

Thanks for the update, the sequencer plugin now waits correctly for the intro-video as long as the delay time set in the sequencer settings is not shorter than the intro-video length itself (for example if you set sequencer delay time to 5sec and the intro-video length is 10sec then it will still interrupt the intro-video at 5sec and jump into AM). This is really a non-issue since most of us use ~30sec as sequencer delay time (the normal video length of EmuMovies) and usually don't use long intro-videos (but I know some people love those super long intro videos in their arcade cabinets). Mine is just around 10 sec.

I just wish that AM would have a function that would ignore keyboard/joystick key inputs during the intro-video as an optional option. I use AHK script for that as a workaround until I learn how to do it via the intro.nut file correctly.

PS. This great plug-in has completely removed the need for a screensaver for me, and it works much better as a "Attract-Mode" attention grabber in an Arcade cabinet than the built in AM screensavers.

Keep up the good work and best regards.

/Edit, forgot to quote the post I was replying to
« Last Edit: December 06, 2018, 10:10:36 AM by manivanilli »

keilmillerjr

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 673
    • View Profile
Re: Problem plugin - Random
« Reply #46 on: December 09, 2018, 01:17:11 AM »
Pushed small update. Plugin should wait for intro to finish before activating plugin. Please test and report back if it doesn’t work. I didn’t actually test it.

As is, screensaver will never become active unless screensaver time is less than sequencers delay time (which would be pointless). One option is to not use a screensaver. Harsh, I know. Second option, differentiate between signals from the plugin and actual user plugins. I could then keep track of time the user was away and activate the screensaver manually a signal that you preset in the config to activate the screensaver. Plugin would have to disable when the screensaver is active, and enable when returning. Thoughts?

Thanks for the update, the sequencer plugin now waits correctly for the intro-video as long as the delay time set in the sequencer settings is not shorter than the intro-video length itself (for example if you set sequencer delay time to 5sec and the intro-video length is 10sec then it will still interrupt the intro-video at 5sec and jump into AM). This is really a non-issue since most of us use ~30sec as sequencer delay time (the normal video length of EmuMovies) and usually don't use long intro-videos (but I know some people love those super long intro videos in their arcade cabinets). Mine is just around 10 sec.

I just wish that AM would have a function that would ignore keyboard/joystick key inputs during the intro-video as an optional option. I use AHK script for that as a workaround until I learn how to do it via the intro.nut file correctly.

PS. This great plug-in has completely removed the need for a screensaver for me, and it works much better as a "Attract-Mode" attention grabber in an Arcade cabinet than the built in AM screensavers.

Keep up the good work and best regards.

/Edit, forgot to quote the post I was replying to

Thank you for trying it out and your detailed review! Resolved the issue with the intro. Sorry about that. Fully tested now. Pushed update to GitHub.

I can disable signals when the intro is active, but this would best be handled by the intro script because the plugin would not know the length of the video object and it would be stuck on a never ending loop. You would have to add a signal handler and return true unless video is done playing.