Author Topic: MAME slow rom loading and exiting  (Read 211 times)

slydog43

  • Full Member
  • ***
  • Posts: 62
    • View Profile
MAME slow rom loading and exiting
« on: August 22, 2018, 11:45:19 AM »
I have had this trouble for a while now, so I'm not sure what is causing it.  I have windows 10x64 (all latest patches) and MAME.200b (tried older ones also).  When I run mame64.exe and pick rom, it takes 3 seconds to come up (it used to take .5 second) and another 2-3 seconds to quit rom and get back control in mame.  Any ideas?  thanks

I did try turning off MS defender, which I thought worked, but still slow.  I thought it was fast for 1 game load, but can't repeat.

Thanks


PS. I did a clean install of Win7 on another computer and MAME.200bx86 runs super fast, so I assume it has something to do with Windows 10x64 and one of the latest updates.  Anyone running Win10x64??
« Last Edit: August 22, 2018, 04:51:36 PM by slydog43 »

slydog43

  • Full Member
  • ***
  • Posts: 62
    • View Profile
Re: MAME slow rom loading and exiting
« Reply #1 on: August 23, 2018, 09:13:23 AM »
I figured more info out.  I reinstalled a clean windows 10x64 Pro (version 1709) on one of my MAME cabs and MAME/AttractMode are running great again.  Instant start of Rom and instant exit.  Something is messed up with 1803 Windows 10.  Stay away if you run MAME.

Just curious if anyone else had run into this issue.  (I have 4 mame machines in my house and all had the same issues)

Daztronics

  • Newbie
  • *
  • Posts: 2
    • View Profile
Re: MAME slow rom loading and exiting
« Reply #2 on: August 23, 2018, 04:18:05 PM »
I wonder if these tweaks would have solved your issues?

Windows 10 version 1803 update broke HLSL scanlines