Author Topic: Scraping in Linux  (Read 265 times)

johnodon

  • Newbie
  • *
  • Posts: 1
    • View Profile
Scraping in Linux
« on: September 27, 2018, 04:25:57 PM »
I have AM running on Lubuntu 18.04 (installed using the deb package).  However, when I try to scrape I get a message that the bottom that says "Unable to scrape, frontend was built without libcurl enabled!"

Can anyone help?  If scraping is not possible in the FE, what standalone scraper is recommended?

TIA!

John

raygun

  • Administrator
  • Sr. Member
  • *****
  • Posts: 380
    • View Profile
Re: Scraping in Linux
« Reply #1 on: September 28, 2018, 06:35:58 PM »
this is due to a very recent change to the frontend

You need to have the development headers and library for “libcurl” installed on your system when you compile attractmode for network scraping to work with the newest development version.

on lubuntu I think you will need to run:

Code: [Select]
sudo apt-get install libcurl4-openssl-dev
(the package name may different)

then do a ‘make clean’ and ‘make’ on attractmode to re-compile AM(assuming you have compiled yourself)

I hope this helps