Author Topic: AttractMode doesn't remember last lunched game  (Read 587 times)

galactico

  • Newbie
  • *
  • Posts: 4
    • View Profile
AttractMode doesn't remember last lunched game
« on: November 09, 2018, 10:41:41 AM »
Hello everyone
I am using Model 2 Emulator on attract-mode in Windows XP 32bit. I'm new to this emulator and AM. I want to run a specific game on startup. I've set General->Startup mode->last lunch game. when I close AM and re-run it, it opens the last lunched ROM perfectly. but when I restart my PC, it doesn't lunch rom, and shows the menu. any help would be appreciated  :)

progets

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 1011
    • View Profile
Re: AttractMode doesn't remember last lunched game
« Reply #1 on: November 10, 2018, 01:12:20 AM »
This should be pretty simple and you mention it works but just not when you reboot. Is it possible that you are trying to launch AM too quickly after you reboot for your hardware? When you reboot, let the OS sit doing nothing for 10 minutes before running AM, maybe background processes or dependencies haven't had time to start (since your're using XP I'm guessing your hardware is old).

How launching the last game on start in the AM FE works:
- there is an entry in your attract.cfg file like "startup_mode         launch_last_game"
- the attract.am file contains the information of the last game played (though it's cryptic). make sure this file is not read only and has the proper permissions if using the NTFS file system

You can make sure these files are correct and don't have permission issues but since you say it works right when you don't reboot makes me think they're fine. How are you launching AM in the OS and how are you shutting down AM and the OS? This is more likely your issue.

galactico

  • Newbie
  • *
  • Posts: 4
    • View Profile
Re: AttractMode doesn't remember last lunched game
« Reply #2 on: November 10, 2018, 08:50:58 AM »
Wow, you were right! thank you so much!  ;D