Author Topic: Version 2.5.1 bugfix release  (Read 1053 times)

raygun

  • Administrator
  • Sr. Member
  • *****
  • Posts: 380
    • View Profile
Version 2.5.1 bugfix release
« on: November 13, 2018, 09:34:27 PM »
We are pleased to announce the release of version 2.5.1 of Attract-Mode!

This is a bugfix release that squashes some of the more unfortunate bugs we were able to track down in 2.5.0.  Download available at: http://attractmode.org/download.html

Enjoy!

# Changelog #

## Commits from v2.5.0 to v2.5.1

### Andrew Mickelson (3 commits)

* Version 2.5.1
* Issue #499 - Fixed to show empty space when image/artwork fails to load
* Small style updates to PR501

### Radek Dutkiewicz (5 commits)

* Fix for textures loosing smoothing (#506)
* Redraw surfaces fix (#504)
* nowide typo fix (#502)
* Fixed SWF BlendMode
* Fixed SWF regression on SFML 2.5.0

bundangdon

  • Sr. Member
  • ****
  • Posts: 156
    • View Profile
Re: Version 2.5.1 bugfix release
« Reply #1 on: November 14, 2018, 12:58:48 AM »
Great work! Thank you very much for fixing issue #499  ;D

yaron

  • Newbie
  • *
  • Posts: 6
    • View Profile
Re: Version 2.5.1 bugfix release
« Reply #2 on: November 15, 2018, 06:08:02 AM »
Thank you for your hard work. AM is a wonderful front end!

There are two consistent bugs regarding the search function:
1. The game logo and boxart do not update after search:
- go into any system wheel where games are listed and search for a game. Then without moving the wheel, search for another game. The wheel logo and boxart are not updated and still shows the previous search result.
Example: Let's say we are in the MS-DOS wheel which has many games and I search for "Loom", then without moving the wheel, I search for "Warcraft". The Loom game logo and boxart will still be shown. Please see attached screenshot.

2. AM crashes if you search for a game in the System wheel (where only systems are listed).

These bugs where tested on v2.5.1 as well.

Cheers.

keilmillerjr

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 666
    • View Profile
Re: Version 2.5.1 bugfix release
« Reply #3 on: November 15, 2018, 05:13:20 PM »
Thank you for your hard work. AM is a wonderful front end!

There are two consistent bugs regarding the search function:
1. The game logo and boxart do not update after search:
- go into any system wheel where games are listed and search for a game. Then without moving the wheel, search for another game. The wheel logo and boxart are not updated and still shows the previous search result.
Example: Let's say we are in the MS-DOS wheel which has many games and I search for "Loom", then without moving the wheel, I search for "Warcraft". The Loom game logo and boxart will still be shown. Please see attached screenshot.

2. AM crashes if you search for a game in the System wheel (where only systems are listed).

These bugs where tested on v2.5.1 as well.

Cheers.

I could be wrong, but perhaps whoever created this “wheel” (a few different versions) is changing indexes tied to button presses? It’s probably not attract related. What module is in use?

yaron

  • Newbie
  • *
  • Posts: 6
    • View Profile
Re: Version 2.5.1 bugfix release
« Reply #4 on: November 16, 2018, 12:08:28 AM »
I could be wrong, but perhaps whoever created this “wheel” (a few different versions) is changing indexes tied to button presses? It’s probably not attract related. What module is in use?

Thank you for your reply.
I'm not sure what you mean but I generated all the wheels through AM's menu (Generate Collection/Rom List) and use the 'Cosmo Systems' layouts I downloaded from these forums. What do you mean by "what module is in use"?

Cheers

keilmillerjr

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 666
    • View Profile
Re: Version 2.5.1 bugfix release
« Reply #5 on: November 16, 2018, 01:58:37 AM »
I could be wrong, but perhaps whoever created this “wheel” (a few different versions) is changing indexes tied to button presses? It’s probably not attract related. What module is in use?

Thank you for your reply.
I'm not sure what you mean but I generated all the wheels through AM's menu (Generate Collection/Rom List) and use the 'Cosmo Systems' layouts I downloaded from these forums. What do you mean by "what module is in use"?

Cheers
Attract only generates a romlist. The “wheel” is something someone coded in squirrel. Two different things.

Source is published as a zip, so I can’t examine it until tonight when on pc. You need to examine what’s packages in that zip.

yaron

  • Newbie
  • *
  • Posts: 6
    • View Profile
Re: Version 2.5.1 bugfix release
« Reply #6 on: November 17, 2018, 06:18:23 AM »

Attract only generates a romlist. The “wheel” is something someone coded in squirrel. Two different things.

Source is published as a zip, so I can’t examine it until tonight when on pc. You need to examine what’s packages in that zip.


Thank you, I didn't know that. However, I did the following test with three other layouts and the ONLY layout that did NOT have this bug is the default 'Attrac-Man'. I assume because it does not show any logos or boxart anyway...

I had the same bug with the popular 'Robospin' layout and 'Filter Grid' (isn't it a default layout as well?).
Three layouts, developed by three different individuals showing the same bug. To me it suggests that they are using something in common.

BTW, I am performing these searches using the 'KeyboardSearch plugin' supplied by AM.

Following are the screenhots:
« Last Edit: November 17, 2018, 06:48:32 AM by yaron »

keilmillerjr

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 666
    • View Profile
Re: Version 2.5.1 bugfix release
« Reply #7 on: November 17, 2018, 07:37:00 AM »
Start looking through the source code for the plugin you are using.

https://github.com/mickelson/attract/blob/master/config/plugins/KeyboardSearch.nut

yaron

  • Newbie
  • *
  • Posts: 6
    • View Profile
Re: Version 2.5.1 bugfix release
« Reply #8 on: November 17, 2018, 11:17:24 AM »

keilmillerjr

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 666
    • View Profile
Re: Version 2.5.1 bugfix release
« Reply #9 on: November 17, 2018, 02:45:33 PM »
Start looking through the source code for the plugin you are using.

https://github.com/mickelson/attract/blob/master/config/plugins/KeyboardSearch.nut

I am not a programmer.

I’ve spent the past 24hrs broken down in my pickup in the cold with little help. I’m on a cell phone buddy. Take a look. See what you can do. Or don’t use the search plugin.

yaron

  • Newbie
  • *
  • Posts: 6
    • View Profile
Re: Version 2.5.1 bugfix release
« Reply #10 on: November 18, 2018, 01:08:49 AM »

I’ve spent the past 24hrs broken down in my pickup in the cold with little help. I’m on a cell phone buddy. Take a look. See what you can do. Or don’t use the search plugin.

Well if the search function worked properly I could've launched a search & rescue party!
« Last Edit: November 18, 2018, 01:11:11 AM by yaron »