Author Topic: New user here and many questions.  (Read 1209 times)

Bgoulette

  • Sr. Member
  • ****
  • Posts: 112
  • I wrote a book.
    • View Profile
    • BlakeGoulette.com
Re: New user here and many questions.
« Reply #15 on: January 07, 2019, 11:03:55 AM »
It looks like what happened with my latest AM install: the romlist generator (I'm not at my PC right now: forgive misleading terms!) included all the devices and drivers in its mame.txt file: that's what it looks like you're seeing based on your screen shot.

Good point! I remember when I set up my MAME + AM system I put all the actual game roms in one folder and all the devices, bioses etc in another folder. Then MAME settings point to both folders, while AM ROM folder setting only points to the "actual games" ROM folder. In this way you should clean up the romlist from drivers etc

This is such a great idea, I'm ashamed I didn't consider it! Probably because I'm not sure how. I'm relatively new to mucking with mame.ini: is that where you point to the drivers, etc.? (in addition to the roms themselves?)

Autotec,

zpaolo11's suggestion sounds a lot less labor-intensive, but because I started with a small number of roms, it was a small matter to remove the items I recognized as devices/drivers and test anything else on a per-"rom" basis. With a full set...yeah, I wouldn't want to deal with that, either! I'd pursue zpaolo11's idea!

Autotec

  • Jr. Member
  • **
  • Posts: 12
    • View Profile
Re: New user here and many questions.
« Reply #16 on: January 07, 2019, 03:57:47 PM »
No, it actually is “mame.exe”. It was a typo on my own part that I didn’t notice until after I took the picture. That has been fixed, but nothing has changed. And that I find kinda strange.

Did you try what I asked? Can you generate the xml manually?

I’m going to sound dumb, but how would I attempt to do that? This is the part of this build where I’m out of my comfort zone.


For you, open cmd and type the following:

D:/MAME/MAME v.204/mame.exe mame -listxml >D:/MAME/MAME v.204/mame.xml

Let me know if it’s generated. It should be a large file measured in mb.

https://docs.mamedev.org/commandline/commandline-all.html

Finally got home and the quick answer is no, nothing came up. I tried forward and back slashes just to make sure. The image is what I was getting.

Thank you, Justin

keilmillerjr

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 890
    • View Profile
Re: New user here and many questions.
« Reply #17 on: January 07, 2019, 04:20:39 PM »
Get rid of that “mame” parameter. Sorry, I typed on an iPhone and it can get tough some times. Essentially, you want to tell the terminal to execute a script or binary, and then pass parameters to it. In your case, the parameter would be listing xml, and the second part is to capture terminal output and store it in a file.

Autotec

  • Jr. Member
  • **
  • Posts: 12
    • View Profile
Re: New user here and many questions.
« Reply #18 on: January 07, 2019, 04:29:47 PM »
It looks like what happened with my latest AM install: the romlist generator (I'm not at my PC right now: forgive misleading terms!) included all the devices and drivers in its mame.txt file: that's what it looks like you're seeing based on your screen shot.

Good point! I remember when I set up my MAME + AM system I put all the actual game roms in one folder and all the devices, bioses etc in another folder. Then MAME settings point to both folders, while AM ROM folder setting only points to the "actual games" ROM folder. In this way you should clean up the romlist from drivers etc

This is such a great idea, I'm ashamed I didn't consider it! Probably because I'm not sure how. I'm relatively new to mucking with mame.ini: is that where you point to the drivers, etc.? (in addition to the roms themselves?)

Autotec,

zpaolo11's suggestion sounds a lot less labor-intensive, but because I started with a small number of roms, it was a small matter to remove the items I recognized as devices/drivers and test anything else on a per-"rom" basis. With a full set...yeah, I wouldn't want to deal with that, either! I'd pursue zpaolo11's idea!

Alright, looking at the folders, I have two folders named "roms" on 2 different levels. One has all the separate files and folders, and the other is a text file that says "place ROM directories here". But I don't see anything but game titles in the folder. At this point I think I need to look at MAME setup since I didn't configure it. But it shows I was pointed at the correct folder.

Like I said, I'm learning at every click....

Autotec

  • Jr. Member
  • **
  • Posts: 12
    • View Profile
Re: New user here and many questions.
« Reply #19 on: January 07, 2019, 04:40:33 PM »
Get rid of that “mame” parameter. Sorry, I typed on an iPhone and it can get tough some times. Essentially, you want to tell the terminal to execute a script or binary, and then pass parameters to it. In your case, the parameter would be listing xml, and the second part is to capture terminal output and store it in a file.

OK, let me try that. I'll report back in a few minutes.

progets

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 865
    • View Profile
Re: New user here and many questions.
« Reply #20 on: January 07, 2019, 04:41:27 PM »
@Autotec - your command above failed because is has spaces in it. You need to wrap each section of the command in double quotes (") when using spaces. Also, you need to verify/confirm the actual name of your mame.exe (mae64.exe, mame64.exe, etc.).

Autotec

  • Jr. Member
  • **
  • Posts: 12
    • View Profile
Re: New user here and many questions.
« Reply #21 on: January 07, 2019, 04:59:24 PM »
Ugh, still no luck. I can build a engine, transmission or diagnose any electrical problem in any car, but this is getting to me. I don't suppose anyone wants to log in through Team Viewer to tell me what I'm doing wrong? I hate asking, but I will pay. This is the last step to getting this running.

Autotec

  • Jr. Member
  • **
  • Posts: 12
    • View Profile
Re: New user here and many questions.
« Reply #22 on: January 08, 2019, 03:03:15 PM »
A big shout out to Keilmillerjr, he was able to log in and find my mistake in the file routing. All the game names show up correctly now. Thanks again!

Now it's back to research to find out why when I chose a game, Attract Mode freezes. I'm thinking it's a control setup problem, but that's just a guess. Then there's the artwork I still need to find.

I give all of you guys props who have been through this, there's a lot more involved than I thought.

Thank you, Justin

Autotec

  • Jr. Member
  • **
  • Posts: 12
    • View Profile
Re: New user here and many questions.
« Reply #23 on: January 08, 2019, 05:23:45 PM »
With the freezing, I don't think it's a control configuration problem. Both the MAME and AM control config is the same now. Games still play with MAME only open, but when I load AM everything stops when I press select/enter to chose the game. Things will unfreeze when I press exit/back as long as I don't hit enter too many times.

Any ideas?

Thank you, Justin