Author Topic: CPU Usage 100%!! PC User  (Read 1193 times)

Oomek

  • Sr. Member
  • ****
  • Posts: 258
  • Radek Dutkiewicz
    • View Profile
    • github.com/oomek
Re: CPU Usage 100%!! PC User
« Reply #15 on: December 08, 2018, 10:36:11 AM »
I'm on Windows 10. You just extract ffmpeg.exe make 2 folders mp4 and avi. Then you copy or move your mp4 files to the mp4 folder. Make a bat file and paste the line from my post and add "pause" in the 2nd line. So now you should have 2 folders, ffmpeg.exe and a convert.bat in the directory. Doubleclick the bat and let the magic happen.

UnknownFigure

  • Jr. Member
  • **
  • Posts: 24
    • View Profile
Re: CPU Usage 100%!! PC User
« Reply #16 on: December 08, 2018, 10:40:12 AM »
I'm on Windows 10. You just extract ffmpeg.exe make 2 folders mp4 and avi. Then you copy or move your mp4 files to the mp4 folder. Make a bat file and paste the line from my post and add "pause" in the 2nd line. So now you should have 2 folders, ffmpeg.exe and a convert.bat in the directory. Doubleclick the bat and let the magic happen.

I'll try this as soon as possible. Thanks!
« Last Edit: December 08, 2018, 10:41:57 AM by UnknownFigure »

Oomek

  • Sr. Member
  • ****
  • Posts: 258
  • Radek Dutkiewicz
    • View Profile
    • github.com/oomek
Re: CPU Usage 100%!! PC User
« Reply #17 on: December 08, 2018, 10:44:36 AM »
It's not a problem. The only problem there is, is that we still can't find a solution for this excessive cpu consumption and we have to rely on workarounds.

UnknownFigure

  • Jr. Member
  • **
  • Posts: 24
    • View Profile
Re: CPU Usage 100%!! PC User
« Reply #18 on: December 10, 2018, 11:35:06 PM »
It looks like it solved the constant 100% usage, but it still reaches those limits when you're spinning the wheels, mainly due to starting each video, which results in 100% usage. Displaying the video usually takes around 80% or so.

Is this actually normal? What sort of cpu usage do you people have? My Attract Mode without videos is 50%.

UnknownFigure

  • Jr. Member
  • **
  • Posts: 24
    • View Profile
Re: CPU Usage 100%!! PC User
« Reply #19 on: December 10, 2018, 11:45:29 PM »
I've just been told by a few people, that their cpu usage runs between 25 and 40 while displaying videos. Something doesn't make sense here. If it's a problem with the Video Decoder (No Hardware Option), then all the people would be having the same problem. But that's not the case. Most computer users are not experiencing any problems at all, while others are.

Oomek

  • Sr. Member
  • ****
  • Posts: 258
  • Radek Dutkiewicz
    • View Profile
    • github.com/oomek
Re: CPU Usage 100%!! PC User
« Reply #20 on: December 11, 2018, 02:14:56 AM »
If you have nvidia card disable Threaded Optimization just for attract mode in nvidia control panel. This will reduce cpu usage by 25%. Another 25% can be reduced by forcing Buffer-flipping mode to ON in nVidia Profile Inspector also just for AM. This last option will disable double/triplebuffering though, so AM will be more prone to stuttering on artwork reloading

With those 2 flags on and with mp4 in avi containers I get around 5% of CPU usage, with spikes at around 11% on reloading ( can't tell exactly as my cpu is downclocking )

And one more thing, just in case. Make sure you disabled Focus Assist in Windows 10.

UnknownFigure

  • Jr. Member
  • **
  • Posts: 24
    • View Profile
Re: CPU Usage 100%!! PC User
« Reply #21 on: December 11, 2018, 03:14:38 AM »
Doesn't work, Oomek. I get the same results.

Only 5% of Cpu usage?! This clearly shows something is not right here.

Oomek, is this the latest release of Attract Mode or are you using a specific version? 

Oomek

  • Sr. Member
  • ****
  • Posts: 258
  • Radek Dutkiewicz
    • View Profile
    • github.com/oomek
Re: CPU Usage 100%!! PC User
« Reply #22 on: December 11, 2018, 03:31:18 AM »
I did my test on 2.5.1. Please make sure your nv profile has correctly bound exe in the nvidia inspector

Oomek

  • Sr. Member
  • ****
  • Posts: 258
  • Radek Dutkiewicz
    • View Profile
    • github.com/oomek
Re: CPU Usage 100%!! PC User
« Reply #23 on: December 11, 2018, 04:17:53 AM »
I'm uploading a video showing how all that what I mentioned affects my CPU usage.

https://youtu.be/dMttc8KL-kg
« Last Edit: December 11, 2018, 04:51:08 AM by Oomek »

UnknownFigure

  • Jr. Member
  • **
  • Posts: 24
    • View Profile
Re: CPU Usage 100%!! PC User
« Reply #24 on: December 11, 2018, 09:54:17 AM »
Sadly, I get the same results.

But I've noticed a few things. The default Basic and Reflect layouts, without snaps, are at 1% of Cpu usage (Yes!). With snaps, they're around 44 to 55%. All other layouts with snaps, 100%. All this without avi containers.

So, for all the other layouts, it's 50% layout 50% snap. But here's the strange thing, Orbit is always at 100%, yet it is as simple as Basic or Reflect.

In any case, thanks for the help, Oomek. I'll either have to try another front end, or wait for the lead designer to release a build with Video Decoding by Hardware.

UnknownFigure

  • Jr. Member
  • **
  • Posts: 24
    • View Profile
Re: CPU Usage 100%!! PC User
« Reply #25 on: December 12, 2018, 12:07:58 AM »
I've SOOLVEEDD IT!! YEEEESSHHH! Finally! Heh!

Oomek! Forget the threaded and buffer-flipping mode! Turn those to their previous setting. Now you'll still have to do the ffmpeg process that you told me before (Thanks AGAIN!).

Execute Attract Mode, and to each display layout, including the main menu, turn off the Static Monitor Effect. On the Cosmos theme, which is very demanding, i'm getting 18 to 44%, being 44% the video reload. On any other theme, you'll get 5 to 10%.

Don't ask me why, but it works. Give it a try, please.

 

Oomek

  • Sr. Member
  • ****
  • Posts: 258
  • Radek Dutkiewicz
    • View Profile
    • github.com/oomek
Re: CPU Usage 100%!! PC User
« Reply #26 on: December 12, 2018, 12:29:31 AM »
Great news. Could you elaborate a bit more please about that static monitor effect? I'm not entirely sure what are you referring to. You were trying default themes right?
Regarding the threaded optimizations, it should be set to off anyway for nvidia cards as it slows down the transitions and introduce more stuttering. I wanted to set this off by default, but I need to figure out how to make the nvapi.dll calls to compile under MinGW as it seems that this api is not multiplatform.

UnknownFigure

  • Jr. Member
  • **
  • Posts: 24
    • View Profile
Re: CPU Usage 100%!! PC User
« Reply #27 on: December 12, 2018, 12:53:15 AM »
Go to Settings section, and select Displays. Now, you'll have to do this to each display you have, even the main menu. Select the display and go to Layout Options. In here, you'll find Enable Monitor Static Effect turned on by default, turn it off.

I've been using the Cosmos theme, which is quite demanding. Cosmos theme, without snaps or boxart/cartart, is around 15 to 40% or so. Well, with snaps and boxart/cartart, it doesn't change, same cpu usage.

On the default themes, Basic, Reflect, Attract, etc.. You'll get 5 to 10% of cpu usage with snaps, same without snaps.

In terms of threaded optimizations, there is no difference for me. I tried it, and it's even worse, constant 100%. If you have several threads, I think you should leave this option to Auto.
« Last Edit: December 12, 2018, 12:56:07 AM by UnknownFigure »

Oomek

  • Sr. Member
  • ****
  • Posts: 258
  • Radek Dutkiewicz
    • View Profile
    • github.com/oomek
Re: CPU Usage 100%!! PC User
« Reply #28 on: December 12, 2018, 12:56:00 AM »
On what default theme you have 100% of CPU usage with threaded optimizations set to off?

UnknownFigure

  • Jr. Member
  • **
  • Posts: 24
    • View Profile
Re: CPU Usage 100%!! PC User
« Reply #29 on: December 12, 2018, 12:57:01 AM »
Mostly all of them, but Basic and Reflect seem to work fine.