Author Topic: Attract-Mode 2.5.1 Breaks My Layouts - [UPDATE - NO IT DOESNT]  (Read 280 times)

FrizzleFried

  • Sr. Member
  • ****
  • Posts: 179
    • View Profile
    • Idaho Garagecade
Attract-Mode 2.5.1 Breaks My Layouts - [UPDATE - NO IT DOESNT]
« on: January 11, 2019, 05:34:05 PM »
Attract-Mode 2.5.1 breaks a number of my layouts.  It appears that the CARRIER module is not working properly in 2.5.1... I can say FOR SURE that it works in 2.3.0... and unfortunately I do not have any versions between 2.3.0 and 2.5.1 to determine exactly when the issue arises.

Can someone point me to where i can find the versions between 2.3.0 and 2.5.1 to test?

Anyone know knows more than I willing to poke around my layouts to see why they are broke on 2.5.1?

The layouts in question are:

SDArcade v2+ (I have not had time to test the original version yet,  but I am confident it too will be broken as it appears the issue is with the CARRIER module).
SDAMax v1 and v1.1

Can someone tell me the official way to report this issue to the author (if there is one)?

Thanks!
« Last Edit: January 11, 2019, 10:17:16 PM by FrizzleFried »
Visit my arcade blog ... www.idahogaragecade.com (updated 03-18-19)

FrizzleFried

  • Sr. Member
  • ****
  • Posts: 179
    • View Profile
    • Idaho Garagecade
Re: Attract-Mode 2.5.1 Breaks My Layouts
« Reply #1 on: January 11, 2019, 05:39:55 PM »
...and I can now confirm that the original SDArcade version is also broke.

What is strange is that the SDARcade versions all are broke but will load up and show the marquee, etc... whereas my SDAMax layouts are so broke that the "default" menu comes up...

ALL work great in 2.3.0.

HELP!
Visit my arcade blog ... www.idahogaragecade.com (updated 03-18-19)

FrizzleFried

  • Sr. Member
  • ****
  • Posts: 179
    • View Profile
    • Idaho Garagecade
Re: Attract-Mode 2.5.1 Breaks My Layouts
« Reply #2 on: January 11, 2019, 05:44:43 PM »
Found all past releases (durr)... I will spend some time tonight trying to determine at which version the layouts broke.  I suspect it may be the latest as I am currently running 2.5.0 on my Pi3 without issue using the layouts in question.
Visit my arcade blog ... www.idahogaragecade.com (updated 03-18-19)

FrizzleFried

  • Sr. Member
  • ****
  • Posts: 179
    • View Profile
    • Idaho Garagecade
Re: Attract-Mode 2.5.1 Breaks My Layouts
« Reply #3 on: January 11, 2019, 06:18:56 PM »
SMALL UPDATE: Actually, the ARpiCADE 3.83 includes Attract-Mode 2.5.1... so oddly the layouts work fine with the Pi3 version 2.5.1. but are utterly broke using the PC version of 2.5.1...

Does that make sense at all?

 :o
Visit my arcade blog ... www.idahogaragecade.com (updated 03-18-19)

FrizzleFried

  • Sr. Member
  • ****
  • Posts: 179
    • View Profile
    • Idaho Garagecade
Re: Attract-Mode 2.5.1 Breaks My Layouts
« Reply #4 on: January 11, 2019, 06:23:03 PM »
UPDATE:  If I move the conveyor.nut from my scrips folder (which worked before) and put it in the MODULE folder... it seems to work... MOSTLY. 

SDAMax now seems to work... however the SDArcade layouts appear to still be partially broke.  It appears the x and y coordinates for the location of the "carrier" isn't working right simply putting the carrier at 0,0 it appears...

Visit my arcade blog ... www.idahogaragecade.com (updated 03-18-19)

FrizzleFried

  • Sr. Member
  • ****
  • Posts: 179
    • View Profile
    • Idaho Garagecade
Re: Attract-Mode 2.5.1 Breaks My Layouts
« Reply #5 on: January 11, 2019, 07:29:29 PM »
UPDATE: I am an idiot (acutally,  that's not much of an update but whatever).  Apparently I'd put the carrier.nut file in the modules folder of 2.3.0 a long time ago and forgot about it.  All this time I thought it was loading from the scripts folder ... nope... the reason it works out of the box on the ARpiCADE is because Dee2er,  the ARpiCADE guy puts that carrier module in the modules folder for their release...

SO,  now i get to figure out how to force the layout to load the script from the layouts scripts folder... and then update those modules.

Until then,  all anyone who wants to get those layouts to work has to do is copy the carrier.nut file from the scripts folder to the modules folder.

My apologies for the confusion.

Yes... I am a hack.
Visit my arcade blog ... www.idahogaragecade.com (updated 03-18-19)

toothlessgrinn

  • Sr. Member
  • ****
  • Posts: 139
    • View Profile
Re: Attract-Mode 2.5.1 Breaks My Layouts - [UPDATE - NO IT DOESNT]
« Reply #6 on: January 12, 2019, 01:12:55 PM »
lmao!!! 

all good man WE ALL make screwups!! its how we learn!

you did good work and they defiantly work very WELL on my rigs!!





wish i could get the hang of the layout building...... 
we came , we saw , we lost LOTS of quarters...

Win 7
Asus mobo amd 64bit 3core
12g ram
4 player. Custom built woody cab
46" plasma screen with 22" marquee