Author Topic: Attract Mode @ 640x480i  (Read 502 times)

FrizzleFried

  • Sr. Member
  • ****
  • Posts: 243
    • View Profile
    • Idaho Garagecade
Attract Mode @ 640x480i
« on: May 30, 2019, 09:05:36 PM »
System: New MAME rig I've built using a JPAC and CRT Emudriver...

My desktop is at 640x480i (interlaced) because my arcade monitor is a 15khz Wells Gardner K7000.

My front end layouts are at 640x480.

I was under the impression that Attract Mode used the desktop resolution?  Then can someone explain how I can stop attract-mode from kicking to 640x480p (31khz) VGA when I load up?   When I exit it kicks back to 640x480 interlaced (15khz).

What do I do to prevent attract mode from switching from interlaced to progressive modes?
Visit my arcade blog ... www.idahogaragecade.com (updated 06-27-19)

FrizzleFried

  • Sr. Member
  • ****
  • Posts: 243
    • View Profile
    • Idaho Garagecade
Re: Attract Mode @ 640x480i
« Reply #1 on: May 30, 2019, 09:21:50 PM »
I read a potential work around of choosing in the ADVANCED DRIVERS section of Windows 10 "HIDE MODES THIS MONITOR CAN NOT DISPLAY"... which worked GREAT... for the initial load.  When I loaded up attract mode it looked fantastic at 640x480i!  I was thrilled.  I played a game and when I came back to attract mode... it was back in 640x480p (31 khz) mode.

:(

Any suggestions?
Visit my arcade blog ... www.idahogaragecade.com (updated 06-27-19)

FrizzleFried

  • Sr. Member
  • ****
  • Posts: 243
    • View Profile
    • Idaho Garagecade
Re: Attract Mode @ 640x480i
« Reply #2 on: May 30, 2019, 09:57:01 PM »
BTW... testing this it seems that after playing a game and exiting back to attract mode,  for some reason the "HIDE MODES THIS MONITOR CAN NOT DISPLAY" gets automatically unchecked.  To fix the issue again re check it... but after a single load of attract mode and then a game... it's back to 640x480p rather than 640x480i...

:(

Visit my arcade blog ... www.idahogaragecade.com (updated 06-27-19)

keilmillerjr

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 980
    • View Profile
Re: Attract Mode @ 640x480i
« Reply #3 on: May 30, 2019, 10:21:43 PM »
I have the k7000 and jpac as well. I used windows 10 enterprise 1607 with crt emu driver and attractmode. I did not experience the issue you are having. Are you using groovymame?

FrizzleFried

  • Sr. Member
  • ****
  • Posts: 243
    • View Profile
    • Idaho Garagecade
Re: Attract Mode @ 640x480i
« Reply #4 on: May 30, 2019, 10:25:34 PM »
I have the k7000 and jpac as well. I used windows 10 enterprise 1607 with crt emu driver and attractmode. I did not experience the issue you are having. Are you using groovymame?
Correct... it only exhibits this issue at 640x480... at any other resolution it "sticks" to that resolution.  At 640x480,  because there are two modes available (640x480i and 640x480p) it seems to choose 640x480p even though the desktop is set for 640x480i.   And guess what resolution EVERY one of my layouts is designed at... you guessed it... 640x480.

I'm not even sure how to "remove" a mode... I'd try removing 640x480p.  Because it's not a "custom" mode... it's not one I can edit via the Catalyst tools.
Visit my arcade blog ... www.idahogaragecade.com (updated 06-27-19)

keilmillerjr

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 980
    • View Profile
Re: Attract Mode @ 640x480i
« Reply #5 on: May 30, 2019, 10:54:56 PM »
What video card are you using? Perhaps its a monitor detection issue with pre-hd5000 cards, and using dvi with dvi-via will solve the problem?

FrizzleFried

  • Sr. Member
  • ****
  • Posts: 243
    • View Profile
    • Idaho Garagecade
Re: Attract Mode @ 640x480i
« Reply #6 on: May 31, 2019, 08:15:28 AM »
What video card are you using? Perhaps its a monitor detection issue with pre-hd5000 cards, and using dvi with dvi-via will solve the problem?

Radeon R5 220.  The drivers come up as a HD 6250 (or something similar...).
 
Visit my arcade blog ... www.idahogaragecade.com (updated 06-27-19)

FrizzleFried

  • Sr. Member
  • ****
  • Posts: 243
    • View Profile
    • Idaho Garagecade
Re: Attract Mode @ 640x480i
« Reply #7 on: May 31, 2019, 09:11:59 AM »
More odd behavior:

OK... in WINDOWED mode... it works fine.  It maintains 640x480i ... all works great... except that there is (of course) the window showing... and the start bar at the bottom,  etc... MEH...

In every other mode (WINDOWED (BORDERLESS), FULL SCREEN, FILL SCREEN) it switches to 640x480p (31khz) mode.  USUALLY it will revert back to 640x480i when exiting attract mode. There was one time,  however,  it did exit to windows and maintain 640x480p... but I can't remember which mode (windowed, full, etc) I was in.

It seems that if I can "block" (hide) the 640x480p mode... attract-mode can't choose to use it and it works great once... but I can't get it to "stick".  If I can figure out how to permanently remove 640x480p ... I would,  but I doubt  that is going to happen as that is standard VGA and usually a hard-coded mode (probably necessary to get in to BIOS, etc).

At this point it appears I am going to be forced to go up to the next resolution then use "fill" mode... which causes a bit of a blur and breaks some layouts it seems.

Visit my arcade blog ... www.idahogaragecade.com (updated 06-27-19)

FrizzleFried

  • Sr. Member
  • ****
  • Posts: 243
    • View Profile
    • Idaho Garagecade
Re: Attract Mode @ 640x480i
« Reply #8 on: June 09, 2019, 09:24:58 PM »
I found a solution to this problem.  If,  when you click to not display modes your monitor can not support it ... but that goes away after a single resolution change... this will fix the problem:

1 - Stop and Disable service: AMD External events utility
2 - Ensure that the Windows advanced display option is enable: "hide modes that is monitor cannot display"
3 - You're golden... 640x480 will display in interlaced mode,  not progressive.

:)

Visit my arcade blog ... www.idahogaragecade.com (updated 06-27-19)

naoto.awai

  • Newbie
  • *
  • Posts: 3
    • View Profile
Re: Attract Mode @ 640x480i
« Reply #9 on: June 09, 2019, 11:10:43 PM »
Maybe this thread from Calamity (CRT Emudriver creator) may be usefull:

http://geedorah.com/eiusdemmodi/forum/viewtopic.php?id=416

I'm using 648x486@60 for Windows desktop and Attract Mode and It works.

keilmillerjr

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 980
    • View Profile
Re: Attract Mode @ 640x480i
« Reply #10 on: June 10, 2019, 05:04:33 AM »
I found a solution to this problem.  If,  when you click to not display modes your monitor can not support it ... but that goes away after a single resolution change... this will fix the problem:

1 - Stop and Disable service: AMD External events utility
2 - Ensure that the Windows advanced display option is enable: "hide modes that is monitor cannot display"
3 - You're golden... 640x480 will display in interlaced mode,  not progressive.

:)

I forgot, I did read that on byoac forum. I don’t believe I had that installed. Is it something that comes preinstalled on computers you buy from store?

FrizzleFried

  • Sr. Member
  • ****
  • Posts: 243
    • View Profile
    • Idaho Garagecade
Re: Attract Mode @ 640x480i
« Reply #11 on: June 10, 2019, 12:35:28 PM »
I found a solution to this problem.  If,  when you click to not display modes your monitor can not support it ... but that goes away after a single resolution change... this will fix the problem:

1 - Stop and Disable service: AMD External events utility
2 - Ensure that the Windows advanced display option is enable: "hide modes that is monitor cannot display"
3 - You're golden... 640x480 will display in interlaced mode,  not progressive.

:)

I forgot, I did read that on byoac forum. I don’t believe I had that installed. Is it something that comes preinstalled on computers you buy from store?

Nope... I bought and built my computer from the ground up and installed a fresh copy of Windows 10 Enterprise edition.  That was installed in a STOCK Windows 10 installation... or when I installed my chipset drivers for my AMD motherboard/CPU.  Thinking on it...probably the latter...

Visit my arcade blog ... www.idahogaragecade.com (updated 06-27-19)

FrizzleFried

  • Sr. Member
  • ****
  • Posts: 243
    • View Profile
    • Idaho Garagecade
Re: Attract Mode @ 640x480i
« Reply #12 on: June 10, 2019, 12:39:48 PM »
Maybe this thread from Calamity (CRT Emudriver creator) may be usefull:

http://geedorah.com/eiusdemmodi/forum/viewtopic.php?id=416

I'm using 648x486@60 for Windows desktop and Attract Mode and It works.

Actually,  that is exactly what I was doing before I figured out how to stop Attract-Mode from choosing 640x480p versus 640x480i...  I too was running at 648x486.

Visit my arcade blog ... www.idahogaragecade.com (updated 06-27-19)