Author Topic: Help Installing on Ubuntu 19.04  (Read 944 times)

Favdeacon

  • Sr. Member
  • ****
  • Posts: 124
    • View Profile
Re: Help Installing on Ubuntu 19.04
« Reply #15 on: July 25, 2019, 10:07:02 PM »
After trying many things, I re-booted my system and it was taking forever. There was all kinds of script running and running and running. I went to work, came home, still booting.... 12 hours later. I don't know what I did, but I was about to give up on everything.
It would've been interesting which processes were running at that time exactly. You can see (and maybe show us) the running processes sorted by CPU and memory usage with the command top, or htop for a more colorful view. Similarly, the disk activity of processes can be show by iotop. You may have to install the latter two from the official sources in a standard Ubuntu system, but that means they're only one sudo apt install htop iotop away.

I know you already gave up, so this is meant as an advice for the future. Many of us long-time Linux users like to examine and maybe solve a problem instead of giving up "too soon"™.  :) But it's your setup and anything that works for you is okay.

edit: just some wording corrected.
« Last Edit: July 25, 2019, 10:17:09 PM by Favdeacon »

akafox

  • Hero Member
  • *****
  • Posts: 800
    • View Profile
Re: Help Installing on Ubuntu 19.04
« Reply #16 on: August 17, 2019, 02:00:54 PM »
I can run Attract Mode without problem..well that was I COULD until I updated from 16.04 to 18.04 I get this error:

Code: [Select]
attract: /usr/lib/x86_64-linux-gnu/libcurl.so.4: version `CURL_OPENSSL_3' not found (required by attract)
now I can install the package needed from the package manager..however it wants to remove some of my programs (needed!) if I do so.
For now I will be okay using an older version of linux for my game machine..ray will look into it I am sure..

*WAVES MY PAW AND BARKS LOUDLY IN RAYGUN'S DIRECTION*

hmm..I might try compiling it now on the updated system..I'll get back to you
People want life easy..then complain about it

akafox

  • Hero Member
  • *****
  • Posts: 800
    • View Profile
Re: Help Installing on Ubuntu 19.04
« Reply #17 on: August 17, 2019, 02:13:15 PM »
I can run Attract Mode without problem..well that was I COULD until I updated from 16.04 to 18.04 I get this error:

Code: [Select]
attract: /usr/lib/x86_64-linux-gnu/libcurl.so.4: version `CURL_OPENSSL_3' not found (required by attract)
now I can install the package needed from the package manager..however it wants to remove some of my programs (needed!) if I do so.
IF I didn/t need the programs I would just let the package manager remove them and I am sure everything would be fine. On my games machine I will be okay using an older version of linux for my game machine..ray will look into it I am sure..

*WAVES MY PAWS AND BARKS LOUDLY IN RAYGUN'S DIRECTION*

hmm..I might try compiling it now on the updated system..I'll get back to you

nope still get the same error
People want life easy..then complain about it

Favdeacon

  • Sr. Member
  • ****
  • Posts: 124
    • View Profile
Re: Help Installing on Ubuntu 19.04
« Reply #18 on: August 17, 2019, 03:10:24 PM »
This seems to be (three links) a common problem in 18.04 with applications that rely on libcurl3 instead of the newer libcurl4 that comes with 18.04. Unfortunately, it seems that both can't be installed at the same time in Ubuntu.

The only promising solution that I found is to install a custom libcurl that serves both APIs #3 and #4:

https://launchpad.net/~xapienz/+archive/ubuntu/curl34

Maybe that is worth a try, but I didn't test it myself. I just searched the web a bit about it. But keep in mind that any PPA is not part of the official software sources and thus, a potential security risk.


akafox

  • Hero Member
  • *****
  • Posts: 800
    • View Profile
Re: Help Installing on Ubuntu 19.04
« Reply #19 on: September 03, 2019, 03:25:58 PM »
okay I'll take a crack at it..I'll have to run from a USB drive but it will be 19.04 and i'll let you know if i have any luck. It's really strange though that i can not run AM not after updating my system.

@Favdeacon thanks for the info but yeah as it IS a risk I can't take it with my system...
People want life easy..then complain about it

Favdeacon

  • Sr. Member
  • ****
  • Posts: 124
    • View Profile
Re: Help Installing on Ubuntu 19.04
« Reply #20 on: September 04, 2019, 10:11:58 AM »
It's really strange though that i can not run AM not after updating my system.

According to a developer of curl, the Ubuntu package maintainers changed something in curl, and that broke some applications. AM seems to be one of them.

I am looking forward to hear from you in this matter. You may also try this solution from the same bugreport.