Author Topic: Wheel Art Stretch  (Read 384 times)

davisband

  • Newbie
  • *
  • Posts: 5
    • View Profile
Wheel Art Stretch
« on: June 07, 2019, 12:12:30 PM »
I recently rebuilt retropie (stretch) with attract mode.  I noticed that the wheel art no longer stretches to fit.  My old build (from Floob's image) didn't have this issue.  Any ideas how to fix this?  My monitor resolution is 1366x768.



Thanks!

FrizzleFried

  • Sr. Member
  • ****
  • Posts: 243
    • View Profile
    • Idaho Garagecade
Re: Wheel Art Stretch
« Reply #1 on: June 11, 2019, 06:41:16 AM »
Do you have preserve_aspect_ratio set somewhere in your layout?

Visit my arcade blog ... www.idahogaragecade.com (updated 06-27-19)

davisband

  • Newbie
  • *
  • Posts: 5
    • View Profile
Re: Wheel Art Stretch
« Reply #2 on: June 14, 2019, 09:20:13 AM »
I use two layouts (nevato and unified) and it seems to occur on both of them.  I believe its the default layout.nut(s) but I did tweak the dimensions in nevato
    fe.layout.width = 1366;
    fe.layout.height = 768;

The layouts were copied from my old build but I did find this..

class WheelEntry extends ConveyorSlot
{
   constructor()
   {
      base.constructor( ::fe.add_artwork( my_config["spinwheelArt"] ) );
    preserve_aspect_ratio = true;
    video_flags=Vid.ImagesOnly; // added just in case if you have video marquees - like I do :)
   }

I'll test tweaking that tonight to see if its the culprit.

Thanks!


davisband

  • Newbie
  • *
  • Posts: 5
    • View Profile
Re: Wheel Art Stretch
« Reply #3 on: June 20, 2019, 09:25:19 PM »
I tried tweaking the variable in the post above to true but it didn't seem to fix the problem for the nevato layout.  Is there a global preserve aspect ratio setting?

davisband

  • Newbie
  • *
  • Posts: 5
    • View Profile
Re: Wheel Art Stretch
« Reply #4 on: June 22, 2019, 04:23:12 PM »
Quick correction - I had set the variable above to false :)