Author Topic: [Solved!] Can't get Final Burn Neo (RetroArch core) to launch  (Read 321 times)

8bitsdeep

  • Full Member
  • ***
  • Posts: 45
    • View Profile
I've not had to config AM stuff for a while and I must be rusty cause this is stumping me.  Nothing happens when I try to launch a game with this config:

Code: [Select]
executable           ..\RetroArch\retroarch.exe
args                 -L ..\RetroArch\cores\fbneo_libretro.dll "[romfilename]"
rompath              ..\games\Arcade
romext               .zip
system               Arcade
artwork    flyer           ..\media\boxart\arcade
artwork    marquee         
artwork    snap            ..\media\video\arcade
artwork    wheel           ..\media\logos\arcade

  • The games run fine when launched from within RetroArch.
  • This same config format works fine with other RA cores.
  • I typed:  ..\RetroArch\retroarch.exe -L ..\RetroArch\cores\fbneo_libretro.dll ..\games\arcade\galaga.zip
    into the command line from the AM directory and that worked.
  • The AM log doesn't show any errors.

« Last Edit: July 20, 2019, 10:52:54 PM by 8bitsdeep »

rand0m

  • Sr. Member
  • ****
  • Posts: 226
    • View Profile
Re: Rusty. Can't get Final Burn Neo (RetroArch core) to launch
« Reply #1 on: July 03, 2019, 09:56:49 PM »
Have you tried absolulte paths? Everything else seems to be in order.

8bitsdeep

  • Full Member
  • ***
  • Posts: 45
    • View Profile
Re: Rusty. Can't get Final Burn Neo (RetroArch core) to launch
« Reply #2 on: July 04, 2019, 03:38:17 AM »
Absolute paths don't worth either.  :-\

jedione

  • Hero Member
  • *****
  • Posts: 706
  • punktoe
    • View Profile
Re: Rusty. Can't get Final Burn Neo (RetroArch core) to launch
« Reply #3 on: July 04, 2019, 05:38:56 AM »
this should work.

args                 "[romfilename]" -L cores/fbneo_libretro.dll
help a friend....

8bitsdeep

  • Full Member
  • ***
  • Posts: 45
    • View Profile
Re: Rusty. Can't get Final Burn Neo (RetroArch core) to launch
« Reply #4 on: July 19, 2019, 10:53:46 AM »
That also didn't work.  Thanks for trying though!

clockman

  • Full Member
  • ***
  • Posts: 32
    • View Profile
Re: Rusty. Can't get Final Burn Neo (RetroArch core) to launch
« Reply #5 on: July 19, 2019, 05:32:30 PM »
Have you tried absolulte paths? Everything else seems to be in order.
So i can help you. Your args is wrong first it should be this  -f -L cores\fbneo_libretro.dll "[romfilename]"
and your rom path must end with \
hers mine
executable           C:\AttractMode\RetroArch\retroarch.exe
args                 -f -L cores\fbneo_libretro.dll "[romfilename]"
rompath              C:\AttractMode\Games\fbneo\

rand0m

  • Sr. Member
  • ****
  • Posts: 226
    • View Profile
Re: Rusty. Can't get Final Burn Neo (RetroArch core) to launch
« Reply #6 on: July 19, 2019, 07:09:43 PM »
Absolute paths don't worth either.  :-\

Code: [Select]
args                 -L "..\RetroArch\cores\fbneo_libretro.dll" "[romfilename]"
There might be spaces in path try adding quotes in args (path). If that doesn't work then double check the given path for any typing mistakes. I'm using fb neo on am (Win) without any issues.

8bitsdeep

  • Full Member
  • ***
  • Posts: 45
    • View Profile
Re: Rusty. Can't get Final Burn Neo (RetroArch core) to launch
« Reply #7 on: July 19, 2019, 07:53:04 PM »
Still no luck after trying the above options.this. 

RetroArch error log:

Code: [Select]
[INFO] Loading dynamic libretro core from: "D:\Arcade\RetroArch\cores\fbneo_libretro.dll"
[INFO] [Overrides] no core-specific overrides found at D:\Arcade\RetroArch\config\FinalBurn Neo\FinalBurn Neo.cfg.
[INFO] [Overrides] no content-dir-specific overrides found at D:\Arcade\RetroArch\config\FinalBurn Neo\Arcade.cfg.
[INFO] [Overrides] no game-specific overrides found at D:\Arcade\RetroArch\config\FinalBurn Neo\galaga.cfg.
[INFO] [Shaders]: preset directory: D:\Arcade\RetroArch\shaders\presets
[INFO] [Remaps]: remap directory: D:\Arcade\RetroArch\config\remaps
[INFO] [Remaps]: no game-specific remap found at D:\Arcade\RetroArch\config\remaps\FinalBurn Neo\galaga.rmp.
[INFO] [Remaps]: no content-dir-specific remap found at D:\Arcade\RetroArch\config\remaps\FinalBurn Neo\Arcade.rmp.
[INFO] [Remaps]: no core-specific remap found at D:\Arcade\RetroArch\config\remaps\FinalBurn Neo\FinalBurn Neo.rmp.
[INFO] Redirecting save file to "D:\Arcade\RetroArch\saves\galaga.srm".
[INFO] Redirecting savestate to "D:\Arcade\RetroArch\states\galaga.state".
[INFO] Environ GET_LOG_INTERFACE.
[INFO] Content loading skipped. Implementation will load it on its own.
[INFO] CRC32: 0x25a4b18e .
[INFO] Environ SYSTEM_DIRECTORY: "D:\Arcade\RetroArch\system".
[INFO] Environ SET_CONTROLLER_INFO.
     [libretro ERROR] [FBNEO] Couldn't locate the galaga archive anywhere, this game probably won't boot.
     [libretro ERROR] [FBNEO] ROM at index 0 with CRC 0xab036c9f is required ...
     [libretro ERROR] [FBNEO] Can't launch this game, some files are missing.
[ERROR] Failed to load content.
[INFO] Content ran for a total of: 00 hours, 00 minutes, 00 seconds.
[INFO] Unloading game..
[INFO] Unloading core..
[INFO] Unloading core symbols..this.

This is my current cfg.
Code: [Select]
# Generated by Attract-Mode v2.5.1
#
executable           "D:\Arcade\RetroArch\retroarch.exe"
args                 -L "D:\Arcade\RetroArch\cores\fbneo_libretro.dll" "[romfilename]"
rompath              "D:\Arcade\games\Arcade"
romext               .zip
system               Arcade
artwork    flyer           ..\media\boxart\arcade
artwork    marquee         
artwork    snap            ..\media\video\arcade
artwork    wheel           ..\media\logos\arcade

If I add an \ on the end of the rompath, the indented lines in the error log go away but the game still doesn't launch and the rest of the log is the same.

rand0m

  • Sr. Member
  • ****
  • Posts: 226
    • View Profile
Re: Rusty. Can't get Final Burn Neo (RetroArch core) to launch
« Reply #8 on: July 19, 2019, 10:29:10 PM »
Thats really strange, there is a bug with zipped files (& crc error) another reason might be that rom set version is old while fb-neo requires later version but in both cases you wouldn't be able to run the rom directly.

8bitsdeep

  • Full Member
  • ***
  • Posts: 45
    • View Profile
Re: Rusty. Can't get Final Burn Neo (RetroArch core) to launch
« Reply #9 on: July 20, 2019, 06:58:31 AM »
Yeah, this doesn't make any sense at all.  :-\

clockman

  • Full Member
  • ***
  • Posts: 32
    • View Profile
Re: Rusty. Can't get Final Burn Neo (RetroArch core) to launch
« Reply #10 on: July 20, 2019, 08:04:39 AM »
Thats really strange, there is a bug with zipped files (& crc error) another reason might be that rom set version is old while fb-neo requires later version but in both cases you wouldn't be able to run the rom directly.
Try to copy and paste my args line i have this this core launching on 4 different systems using this

executable           C:\AttractMode\RetroArch\retroarch.exe
args                 -f -L cores\fbneo_libretro.dll "[romfilename]"
rompath              C:\AttractMode\Games\fbneo\

I am also using romsets FBA_v0.2.97.42 and FBA_v0.2.97.39

8bitsdeep

  • Full Member
  • ***
  • Posts: 45
    • View Profile
Re: Rusty. Can't get Final Burn Neo (RetroArch core) to launch
« Reply #11 on: July 20, 2019, 11:27:56 AM »
It worked!!!

I pasted in clockman's lines and altered the paths accordingly and it worked.  Altered them to relative paths, still worked. Best as I can tell it was the lack of \ on the end of the rompath that was the problem.  Weird, since I could have sworn I tried adding that in several times. *facepalm*

Thanks everyone!