Author Topic: OSX Catalina - Attract mode does not Not Work - HELP!!!!!  (Read 2737 times)

glazball

  • Newbie
  • *
  • Posts: 3
    • View Profile
Re: OSX Catalina - Attract mode does not Not Work - HELP!!!!!
« Reply #30 on: July 26, 2020, 06:39:36 AM »
I'm still looking for a solution myself.

When launch Attract.app from my Applications folder, it launches fine but it doesn't see any ROMs (all blank).
When I launch the attract executable from within in Attract.app package, it launches through Terminal and everything works fine.

I've tried tweaking all the permissions by giving full disk access to AttradeMode, the executable itself, the .attract folder, Terminal and RetroArch and it just will not see the ROMs unless I launch from Terminal.  It's an annoying workaround but I'm glad it all still works.

zpaolo11x

  • Hero Member
  • *****
  • Posts: 867
    • View Profile
    • My deviantart page
Re: OSX Catalina - Attract mode does not Not Work - HELP!!!!!
« Reply #31 on: July 26, 2020, 11:29:50 AM »
Have you tried giving the permissions to bash too, not just terminal

glazball

  • Newbie
  • *
  • Posts: 3
    • View Profile
Re: OSX Catalina - Attract mode does not Not Work - HELP!!!!!
« Reply #32 on: July 26, 2020, 03:50:36 PM »
Excellent, that fixed it! By giving full disk permission to bash, AM is able to see and launch ROMs again.  In fact, bash seems to be the only permission needed to get AM to work on Catalina (not even Terminal).  I'll continue to allow AM and Retroarch though just to play it safe.  Thank you for the tip!!

zpaolo11x

  • Hero Member
  • *****
  • Posts: 867
    • View Profile
    • My deviantart page
Re: OSX Catalina - Attract mode does not Not Work - HELP!!!!!
« Reply #33 on: July 27, 2020, 10:24:22 PM »
You are welcome! Now if only I could fix OpenEmu not responding to key presses....