Author Topic: Common fault to all the themes published in the forum or Attract-Mode bug?  (Read 537 times)

iOtero

  • Sr. Member
  • ****
  • Posts: 414
    • View Profile
Well, i have titled the post as "Common fault to all the themes published in the forum", when i should have added "that i have tried, that is almost all", but it did not fit, i'm sorry. Made this reservation, i continue with the post.

Trying the latest versions of some themes that have been published in the forum i have found something that i think everyone is missing. And i have noticed this little mistake, because my themes also have the same thing, which i am already correcting in the new versions, with a lot of difficulty, by the way.

I will try to explain it as best i can:

Usually, my Attract-Mode have two controls defined to go from one filter to another, for example to switch from All to Favorites (Next Filter) or from Favorites to All (Prev Filter). Well, when i use them in any theme, if there is still no game marked as a favorite, when switching from All to Favorites it does nothing, and everything else remains immovable, just like in the All screen. I think the right thing would be that nothing from any game appeared on the screen and gave me a warning that there are no favorites.

I am not sure if it is an Attract-Mode bug or that the programmers simply have not anticipated this situation. Situation that usually occurs, especially in the first steps with a new system when it has not yet begun to mark games as Favorites.

Maybe it should be the same Attract-Mode who warns that there is no game in Favorites, or in any other filter, but that should be Mickelson who decides. I don't know if i should generate a "bug report" requesting that this be corrected. What do you think? Do i do it or not?
« Last Edit: December 22, 2019, 06:26:05 AM by iOtero »
Nacer a los 15 años Una novela de iOtero

jedione

  • Hero Member
  • *****
  • Posts: 930
  • punktoe
    • View Profile
Re: Common fault to all the themes published in the forum or Attract-Mode bug?
« Reply #1 on: December 22, 2019, 06:33:19 AM »
do you have a way to solve it from within the layout.
help a friend....

keilmillerjr

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 1147
    • View Profile
Re: Common fault to all the themes published in the forum or Attract-Mode bug?
« Reply #2 on: December 22, 2019, 06:46:45 AM »
This is why I created the leap plugin two years ago. I will eventually add it into attract source to automatically skip an empty filter. But lot’s of things in the works at the moment.

iOtero

  • Sr. Member
  • ****
  • Posts: 414
    • View Profile
Re: Common fault to all the themes published in the forum or Attract-Mode bug?
« Reply #3 on: December 22, 2019, 07:07:33 AM »
This is why I created the leap plugin two years ago. I will eventually add it into attract source to automatically skip an empty filter. But lot’s of things in the works at the moment.

I didn't know that plugin of yours, it works great. I was complicating my life, hiding things by finding the empty filter. Your approach is much better and more practical.  :-[  Thanks.   :)

I know you have a lot of work, but it could do me good if one day you finished the Shuffle list, which doesn't work well at all. ;)
Nacer a los 15 años Una novela de iOtero

keilmillerjr

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 1147
    • View Profile
Re: Common fault to all the themes published in the forum or Attract-Mode bug?
« Reply #4 on: December 22, 2019, 09:15:54 AM »
This is why I created the leap plugin two years ago. I will eventually add it into attract source to automatically skip an empty filter. But lot’s of things in the works at the moment.

I didn't know that plugin of yours, it works great. I was complicating my life, hiding things by finding the empty filter. Your approach is much better and more practical.  :-[  Thanks.   :)

I know you have a lot of work, but it could do me good if one day you finished the Shuffle list, which doesn't work well at all. ;)

Why doesn’t it work well?

jedione

  • Hero Member
  • *****
  • Posts: 930
  • punktoe
    • View Profile
Re: Common fault to all the themes published in the forum or Attract-Mode bug?
« Reply #5 on: December 22, 2019, 12:10:48 PM »
i think it works well,,   my onley beef is the lack of knowledge on my part

 in the older shuffle,   each slot had its one # and i could control that individual slot easier so

i could change things per slot..

im sure their is a way to do that with the latest,   just clules as to know how.

since slot just controls them all.

 ie
Code: [Select]
local list = Shuffle(8, "text", "[FilterName]");


list.slots[0].set_pos(x, fly*0.020, w, h);

list.slots[0].set_rgb (R,G,B);

list.slots[0].font ="futureforces";

list.slots[0].charsize = font_size;

list.slots[0].alpha = alpf;

list.slots[0].align = Align.Left;

this worked so well for me....that i changed the older shuffle to new name "slotmate" so i can use that one with no conflict
with the newer shuffle,,

any who..  cant wait to see whats a brewing keil...
« Last Edit: December 22, 2019, 12:13:00 PM by jedione »
help a friend....

keilmillerjr

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 1147
    • View Profile
Re: Common fault to all the themes published in the forum or Attract-Mode bug?
« Reply #6 on: December 22, 2019, 12:32:15 PM »
Some days off due to xmas. Might integrate “mvscomplete” into picknmix... which will require shuffle and an update. :) picknmix has a huge update almost ready thanks to oomek for help with frame rate things.

iOtero

  • Sr. Member
  • ****
  • Posts: 414
    • View Profile
Re: Common fault to all the themes published in the forum or Attract-Mode bug?
« Reply #7 on: December 24, 2019, 06:27:49 AM »
I don't think anything, I know there are things that must be corrected. I already said it before in the same thread of the Shuffle:


http://forum.attractmode.org/index.php?topic=2946.msg20995#msg20995
Nacer a los 15 años Una novela de iOtero