Author Topic: Hyperspin Theme Mode [Release v3.0]  (Read 4117 times)

Yaron2019

  • Sr. Member
  • ****
  • Posts: 199
    • View Profile
Re: Hyperspin Theme Mode [Release v1.4]
« Reply #15 on: March 16, 2020, 12:48:55 AM »
The reason it's happening is because the ftp access is not free. Your account level is "Content Contributor" so you were given FTP access, but it's not free for non-paying and non-contributing users.

If that is indeed the case then you can download the HQ version available for free from their website and set the option for 'Theme visual quality' to medium in the layout menu - it will be great with the HQ resolution and honestly there is a very little difference within the theme - when coding it, I myself could barely notice the difference...

https://emumovies.com/files/file/2162-mame-hyperspin-video-themes-4x3-hq-pack-1/
https://emumovies.com/files/file/2168-mame-hyperspin-video-themes-4x3-hq-pack-2/
https://emumovies.com/files/file/2173-mame-hyperspin-video-themes-4x3-hq-pack-3/
« Last Edit: March 16, 2020, 12:56:00 AM by Yaron2019 »

takoni

  • Full Member
  • ***
  • Posts: 43
    • View Profile
Re: Hyperspin Theme Mode [Release v1.4]
« Reply #16 on: March 20, 2020, 12:16:32 PM »
great  work dude !!!!!!!  working fine in my rPi 3 with 4:3 cabinet. thanks so much

Yaron2019

  • Sr. Member
  • ****
  • Posts: 199
    • View Profile
Re: Hyperspin Theme Mode [Release v2.0]
« Reply #17 on: April 10, 2020, 08:17:52 AM »
Version 2.0 Released!
------------------------
- Full compatibility with 16:9 and 16:10 screen aspect ratios
- Random sounds function memory leak bug fixed (special thanks to Oomek)
- New and very cool bezels added
- Rewritten layout menu for easy access to features

AoiMasa

  • Newbie
  • *
  • Posts: 3
    • View Profile
Re: Hyperspin Theme Mode [Release v2.0]
« Reply #18 on: April 14, 2020, 02:25:27 AM »
Hi,

First of all, thank you for your amazing work !

Sadly the theme is very laggy on my setup. Here's a video that demonstrates how laggy it is on my Naomi cabinet:
https://drive.google.com/file/d/1iHlzfv5ubBos9aflnOBU96B4-jGfKurH/view

I tried to remove all the animations (including the wheel) and modules on your layout and while it's reduce the lag, it's still not perfect.

I also tried to reduce quality and fps of the video but it doesn't seems to change much.

For my setup, I use Odroid XU4 with the OGST image (Debian Jessie) connected to a Naomi cabinet (4:3). As for the videos, I use the HQ version from emumovies

Do you have any ideas/tips to remove this lag ?

Yaron2019

  • Sr. Member
  • ****
  • Posts: 199
    • View Profile
Re: Hyperspin Theme Mode [Release v2.0]
« Reply #19 on: April 14, 2020, 04:55:33 AM »
That's not laggy, that's a powerpoint presentation...  ;)
 
The first thing I would try is to disable the videos themselves. Use the original code of the theme as you downloaded it. Just delete the theme from the layout menu and place the original theme folder back there. Then rename the 'themes' folder in 'attract/menu-art/' to something like _themes_. This will not enable the Hyperspin Theme Mode to play the videos. Then run attractmode and see if there is any lag in the theme itself - how the wheel and other animations move and behave.

If there is no lag, your device has a problem running these videos and you should rencode them to a format that works for it. From what I see, the videos are encoded as H64 MPEG 4 AVC (part 10)(avc1) according to VLC media player.
If not, please upload another video showing me how it behaves.


AoiMasa

  • Newbie
  • *
  • Posts: 3
    • View Profile
Re: Hyperspin Theme Mode [Release v2.0]
« Reply #20 on: April 15, 2020, 09:20:12 AM »
Thanks for the fast reply ! :)

I tried to remove only the themes like you said but the lag still seems here. I made a new video that show how it behave. As you can see, even attract menu has some lag when I turn the monitor static effect off.. https://drive.google.com/file/d/1aj6usYsTg8lxz1BXiP2w8zBN0b8GXw8g/view

Also the press start and next game image are upside down  ???

For the video format, I also read that attract mode is not very fan of MPEG 4 format so rencoding the videos can be a solution. I will looking more into it.

But I really don't get why your theme is slow on my Odroid because other than that, videos run smoothly on VLC and I don't have any lag problem with the games...



Yaron2019

  • Sr. Member
  • ****
  • Posts: 199
    • View Profile
Re: Hyperspin Theme Mode [Release v2.0]
« Reply #21 on: April 15, 2020, 11:12:30 AM »
I am attaching to this message the layout file with an option to turn off the wheel fadeout effect.
Download it and replace the current layout.nut file you have in the Hyperspin Theme Mode folder.

Then run attractmode, go into the theme options and set 'Enable Wheel Fadeout' to 'No'.
Test and see result.

If there is no change, go into the theme options and turn 'Set perspective' to 4:3.
Test and see result.

If there is no change, in theme options turn 'Enable screen bezel' to 'No'
Test and see result.

If there is no change, turn 'Enable hyperspin extra animations' to 'No'
Test and see result.

Also, what version of attractmode are you using?
Tell me what happened.
« Last Edit: April 15, 2020, 11:31:17 AM by Yaron2019 »

d4funky1

  • Newbie
  • *
  • Posts: 3
    • View Profile
Re: Hyperspin Theme Mode [Release v2.0]
« Reply #22 on: April 16, 2020, 03:57:32 AM »
Hi,

I have downloaded your theme but I am having some issues with getting it looking as per your video.

At present I have the static screen playing with the wheel of game choices on the right hand side.  The bezel seems to be non-existent.  When I select a new bezel design I can see a small slither (2 or 3 pixel width) of the bezel colour down the side but nothing else?

Also, I have downloaded all flyers, marquees, mp4 for all of my ROMs and placed them in the correct paths and even changed the path in the options but I still only get the static screen and nothing else.

All of these game videos play fine when the screensaver kicks in?

I'm sure this is only a small issue that I am missing but it is bugging the hell out of me and your help would be appreciated.

**EDIT**

I am using a 4:3 monitor
« Last Edit: April 16, 2020, 04:05:11 AM by d4funky1 »

Yaron2019

  • Sr. Member
  • ****
  • Posts: 199
    • View Profile
Re: Hyperspin Theme Mode [Release v2.0]
« Reply #23 on: April 16, 2020, 05:43:55 AM »
Hi,

I am using a 4:3 monitor

Hi, the bezel is intended for use when running 4:3 aspet ratio on a 16:9 monitor (in this scenario there are large black squares on the sides so the bezels cover them). There is no use for them on a 4:3 monitor.

As for the videos - this should be a "paths" issue. This theme will look for the videos in this path: attract/menu-art/mame/themes. The Hyperspin Theme Mode layout is a display that uses the data you provide for the emulator you use to run the games. Make sure the emulator you are using - in my case MAME - looks for the videos in the same path. Here is the settings for my MAME emulator where the layout will pull the paths from:

# Generated by Attract-Mode v2.6.1
#
executable           E:/Arcade/Attract/apps/Mame/mame64nonag.exe
args                 [name]
rompath              E:/Arcade/Attract/apps/Mame/roms
romext               .zip;.chd
system               Arcade
info_source          listxml
exit_hotkey          Escape
artwork    flyer           $PROGDIR/menu-art/mame/flyer
artwork    marquee         $PROGDIR/menu-art/mame/marquee
artwork    themes          $PROGDIR/menu-art/mame/themes  <- THIS IS WHERE YOU WANT THE THEME TO LOOK FOR THE VIDEO FILES
artwork    wheel           $PROGDIR/menu-art/mame/wheel <- THIS IS WHERE YOU WANT THE THEME TO LOOK FOR THE WHEEL LOGO FILES
artwork    boxart          $PROGDIR/menu-art/mame/boxart <- THIS IS WHERE YOU WANT THE THEME TO LOOK FOR THE BOXART FILES

'$PROGDIR' just tells attractmode to look for the folder where attractmode is located (like "C:\My Arcade\attract...")


LAST THING: Make sure you are using the latest version of attractmoed (2.6.1).
« Last Edit: April 16, 2020, 05:50:51 AM by Yaron2019 »

d4funky1

  • Newbie
  • *
  • Posts: 3
    • View Profile
Re: Hyperspin Theme Mode [Release v2.0]
« Reply #24 on: April 16, 2020, 06:50:20 AM »
Thanks for your reply.

I'm not sure how to find out which version of attract mode I am using, I simple installed the latest RetroPie and then from the Manage Experimental Packages installed and updated attract mode.  **EDIT** 2.6.1 definitely.

I am using the arcade folder to base all of my games and selecting various emulators and therefore I am not using the MAME folders as such.

In my set up connecting via iMac the path that I have usually follows the following route:

configs/all/attractmode/menu-art/ then either fanart, flyer, marquee, snap, wheel

There is no emulator named in the path?  Also as I am using a Mac to connect to the Pi it only give me access to bios, configs, roms & splashscreens folders.

**EDIT**

Just had another look and can confirm that I only have options for Flyer, Marquee, Snap & Wheel

There is no Theme option in my settings?

I also don't have a theme folder within the menu-art folder
« Last Edit: April 16, 2020, 06:58:09 AM by d4funky1 »

Yaron2019

  • Sr. Member
  • ****
  • Posts: 199
    • View Profile
Re: Hyperspin Theme Mode [Release v2.0]
« Reply #25 on: April 16, 2020, 07:02:14 AM »
Attached is a customized layout file. Copy it to the 'Hyperspin Theme Mode' folder so it replaces the current one.
Make sure you theme videos are now in attract/menu-art/snap

Tell me if you see the videos.

d4funky1

  • Newbie
  • *
  • Posts: 3
    • View Profile
Re: Hyperspin Theme Mode [Release v2.0]
« Reply #26 on: April 16, 2020, 07:16:37 AM »
Quote
Make sure you theme videos are now in attract/menu-art/snap

Do you mean attractmode/menu-art/snap?

My full path to the video folder is:

configs/all/attractmode/menu-art/snap

Thanks again for your quick replies.
D4

Yaron2019

  • Sr. Member
  • ****
  • Posts: 199
    • View Profile
Re: Hyperspin Theme Mode [Release v2.0]
« Reply #27 on: April 16, 2020, 09:24:13 AM »
Just try it and update me please

AoiMasa

  • Newbie
  • *
  • Posts: 3
    • View Profile
Re: Hyperspin Theme Mode [Release v2.0]
« Reply #28 on: April 24, 2020, 06:47:12 AM »
I am attaching to this message the layout file with an option to turn off the wheel fadeout effect.
Download it and replace the current layout.nut file you have in the Hyperspin Theme Mode folder.

Then run attractmode, go into the theme options and set 'Enable Wheel Fadeout' to 'No'.
Test and see result.

If there is no change, go into the theme options and turn 'Set perspective' to 4:3.
Test and see result.

If there is no change, in theme options turn 'Enable screen bezel' to 'No'
Test and see result.

If there is no change, turn 'Enable hyperspin extra animations' to 'No'
Test and see result.

Also, what version of attractmode are you using?
Tell me what happened.


Sorry for the late reply !  :-[ I tried all your suggestions but the lag was still here.

BUT I managed to make the lag go away by using the custom attract mode package made for the OGST debian image. This custom package use the v2.4 of Attract mode but for some reason it has much better performance than the version I installed myself. I also discovered that all softwares on OGST image are custom package made by the creator of this image so he had to make some "magical" optimizations to make anything run smoothly or something like that....

However since I now use a earlier version of attract, the theme had some bugs but I managed to fix them. I put them here in case someone encounters these problems as well:

  • Video didn't appear at first..
     Remove any reference of surface_snap (Don't forget to also remove it on the FadeArt method)
     By doing this, it display the video but its size can be messed up.   
     Since I only need one size, I used the layout size => snap = FadeArt("themes", 0, 0, flw, flh);
  • The .swf animations weren't working so I converted them to .gif.  the press start and next game can be find attached to this post

With theses fixes, your theme finally runs perfectly on my setup !  ;D Next step is now to implement the main menu theme you made. ;)

Thanks again for your help !




Yaron2019

  • Sr. Member
  • ****
  • Posts: 199
    • View Profile
Re: Hyperspin Theme Mode [Release v2.0]
« Reply #29 on: April 25, 2020, 11:27:16 AM »

With theses fixes, your theme finally runs perfectly on my setup !  ;D Next step is now to implement the main menu theme you made. ;)

Thanks again for your help !

Very cool! thanks for sharing your solutions. I recommend going with the latest version of attractmode if possible.