Author Topic: AM locks up after creating gamelist and restarting  (Read 295 times)

Whoremoan

  • Jr. Member
  • **
  • Posts: 10
    • View Profile
AM locks up after creating gamelist and restarting
« on: November 05, 2020, 03:14:42 PM »
I'm in the process of setting up AM on an Ubuntu PC build.
AM installed ok and I have set up a couple of emulators and everything seems fine.
However, when I generate the game list in an emulator, all looks good, but as soon as I exit AM and go back in again I cant do anything.
AM opens at the last emulator screen I was on but nothing works. It's as though AM has locked up, but the little packman animation is still playing.
If I remove the gamelist .txt file(s) from the romlists folder, go back in, it all works, but i obviously have no game list.
I have a test VM system and I set it up on that yesterday and that all worked fine.
I tried copying one of the game list files from that and placing it in place of my one and that worked.
The only difference between the two files is the VM one has only a couple of games in it and my one has a lot!
I've tried changing permissions of the file and directory after exiting AM to full control for all users.

I'm currently running Emulation Station with a view to switching to AM once it's working, but the VM has that on too, so don't think it's that causing the issue.

AM was installed from the version on the website, not from a 3rd party or Retropie build.

mahuti

  • Administrator
  • Sr. Member
  • *****
  • Posts: 128
    • View Profile
    • Github Repositories
Re: AM locks up after creating gamelist and restarting
« Reply #1 on: November 05, 2020, 03:54:41 PM »
I wonder if it could possibly have something to do with corrupted snap/marquee/video files or something? Or some plugin that's activated that's causing problems?

Whoremoan

  • Jr. Member
  • **
  • Posts: 10
    • View Profile
Re: AM locks up after creating gamelist and restarting
« Reply #2 on: November 05, 2020, 04:12:46 PM »
I litterally installed AM, it found I hade Mame installed and set that up and found the games.
rebooted and the problem occured.
I then tried ignoring Mame and manually added some other emulators just in case it was something in the mame list causing the issue but whatever emulator I add, as soon as I generate the game list and restart, I get the issue.
It's the basic install. No plugins, screenshot, etc directroies set

mahuti

  • Administrator
  • Sr. Member
  • *****
  • Posts: 128
    • View Profile
    • Github Repositories
Re: AM locks up after creating gamelist and restarting
« Reply #3 on: November 05, 2020, 04:32:33 PM »
oh, I had an idea:

launch attractmode like this:

attract --loglevel debug

see if that sheds any light on anything.

akafox

  • Hero Member
  • *****
  • Posts: 906
    • View Profile
Re: AM locks up after creating gamelist and restarting
« Reply #4 on: November 05, 2020, 08:37:29 PM »
Which flavor of ubuntu are you using? and what version?

also how did you get AM loaded? was it a deb install from the ppa or compiled?

Also try deleting your attract.cfg, list(s) and emulator(s).cfg and starting over from scratch.

if you start over..NO EMULATORS set up...does AM run okay?
People want life easy..then complain about it

mahuti

  • Administrator
  • Sr. Member
  • *****
  • Posts: 128
    • View Profile
    • Github Repositories
Re: AM locks up after creating gamelist and restarting
« Reply #5 on: November 05, 2020, 08:46:32 PM »
He mentioned it runs fine until he has a large rom list. When he runs a short list its ok.

Whoremoan

  • Jr. Member
  • **
  • Posts: 10
    • View Profile
Re: AM locks up after creating gamelist and restarting
« Reply #6 on: November 06, 2020, 04:55:02 AM »
Thanks for all the replies so far

Which flavor of ubuntu are you using? and what version?

also how did you get AM loaded? was it a deb install from the ppa or compiled?

Also try deleting your attract.cfg, list(s) and emulator(s).cfg and starting over from scratch.

if you start over..NO EMULATORS set up...does AM run okay?

I'm using Regular Ubuntu Desktop, latest version (I think)
I downloaded the .tar file from the AM website, unpacked it then ran make & sudo make install.
If I delete the attract and emulator config files it runs OK, but if I just delete the emulator config files without deleting the attract config, it also runs OK.

He mentioned it runs fine until he has a large rom list. When he runs a short list its ok.

The emulator config file that works was from a VM test system I made.
When I get home later I'm going to copy a few rom files to another directory and use that to generate the list to see if I can determine if it's the amount of roms in a directory that is causing the issue or the fact it was generated from another computer.

oh, I had an idea:

launch attractmode like this:

attract --loglevel debug

see if that sheds any light on anything.

Tried that and it didn't really show anything up that I would interpret as an error, but it was quite late at that point, so will also try that again later.

mahuti

  • Administrator
  • Sr. Member
  • *****
  • Posts: 128
    • View Profile
    • Github Repositories
Re: AM locks up after creating gamelist and restarting
« Reply #7 on: November 06, 2020, 09:26:58 AM »
Quote
When I get home later I'm going to copy a few rom files to another directory and use that to generate the list to see if I can determine if it's the amount of roms in a directory that is causing the issue or the fact it was generated from another computer.

You could try just cutting the list in half on the problem machine. If it locks up, cut it again. Keep cutting it til it doesn't lock up. Eventually you'll figure out if it's the list length, the file, or... maybe give you some other hint.

Whoremoan

  • Jr. Member
  • **
  • Posts: 10
    • View Profile
Re: AM locks up after creating gamelist and restarting
« Reply #8 on: November 06, 2020, 03:20:14 PM »
So made a new directory and put in about 10 roms. Still doesn't work.
Copied the file from my test system, just to double check - No problems, but now all of a sudden that isn't working either!
I did notice that if I start AM when it's got to the point it's not working, I notice that when it gets to the game list if I push up or down, it does actually work for a split second then locks up.
I'm now wondering, in the instructions for installing AM, there was a list of dependencies. What if I've missed one of those and I'm missing an important component?
I'm going to go back and check through the list.


Whoremoan

  • Jr. Member
  • **
  • Posts: 10
    • View Profile
Re: AM locks up after creating gamelist and restarting
« Reply #9 on: November 06, 2020, 04:08:55 PM »
OK, so I checked all the dependencies and all OK.

So here is where it gets weird!
I've had issues with other things before where your rom names have ! in them or things in brackets like (U) and the few roms I'm using to test have that kind of naming format.
So, even though it would not explain my MAME roms not working, as they are not named like that and something as established as AM would have fixed a common issue like that long ago, I thought I would give it a try.
I editied the romlist file and took out the (U) in the name and title section. Loaded up AM and it worked, I could navigate through the menus again. Obviously this would be no good because the info in the romlist file now doesn't relate to anything.
I then removed those elements from the rom file names themselves and started from scratch. Exited AM, went back in, didn't work again!
I went back into the romlist file, put a couple of random characters in the name and title section of each line, loaded AM and it worked again.
Exited, went back in, didn't work.
I then tried adding another random character to the list but it didn't work this time.
AM discovered I was on to it and locked me out  ;D

I really am confused by this. it doesn't make any sense.

mahuti

  • Administrator
  • Sr. Member
  • *****
  • Posts: 128
    • View Profile
    • Github Repositories
Re: AM locks up after creating gamelist and restarting
« Reply #10 on: November 06, 2020, 04:20:29 PM »
Sounds like something in the roms is in some format that's causing the problem in AM maybe? The other day I had some weird romlist problem where the list was being duplicated twice and couldn't figured out what was wrong... changed permissions and it was all fine. So, somehow AM was doing more than just looking at filenames... I don't know what, but something.

Have you checked to make sure there are no "dot" files in your folders?  . or ._   those can wreak havoc too.

Whoremoan

  • Jr. Member
  • **
  • Posts: 10
    • View Profile
Re: AM locks up after creating gamelist and restarting
« Reply #11 on: November 06, 2020, 04:24:51 PM »
Just tried changing the permissions on the attract.cfg, emulators config and romlist file to full control.
I did already try this and was one of the first things I did, but the files have been replaced since.
Went into AM all working. Came out and back in - not working.
If you make any changes to the romlist file, most of the time it will work when you go back in but then stop working when you exit and re launch. It's like something is happening to that files when you exit AM, but i can't figure out what it is.

Sounds like something in the roms is in some format that's causing the problem in AM maybe? The other day I had some weird romlist problem where the list was being duplicated twice and couldn't figured out what was wrong... changed permissions and it was all fine. So, somehow AM was doing more than just looking at filenames... I don't know what, but something.

Have you checked to make sure there are no "dot" files in your folders?  . or ._   those can wreak havoc too.


Don't think so, but it's happening with MAME and that has a pretty basic, set, filenaming structure plus the 2 roms I'm now using to test I've removed all that from them.

Whoremoan

  • Jr. Member
  • **
  • Posts: 10
    • View Profile
Re: AM locks up after creating gamelist and restarting
« Reply #12 on: November 06, 2020, 04:33:45 PM »
So i started again from scratch, created my romlist using my 2 roms. exited and reloaded to get it to the point it no longer works.
Changed the file permissions on the files, went back in and not working.

It just seems completely random as to what gets it working and what doesn't, but either way as soon as you exit and go back in, it screws you over again!

Whoremoan

  • Jr. Member
  • **
  • Posts: 10
    • View Profile
Re: AM locks up after creating gamelist and restarting
« Reply #13 on: November 06, 2020, 04:42:12 PM »
Apologies for the many posts on this tonight, but i thought I'd try one last thing before I give up on this for today.
I thought I would try the permissions again, but in reverse.
I re-setup AM and got it to the point that its working. So before exiting AM I went and changed the permissions on those 3 files, but to read only, so in theory nothing can happen to those files on exit.
Came out, went back in - not working.
So i'm now thinking that whatever weirdness is going on is happening somewhere else other than those 3 config files?

mahuti

  • Administrator
  • Sr. Member
  • *****
  • Posts: 128
    • View Profile
    • Github Repositories
Re: AM locks up after creating gamelist and restarting
« Reply #14 on: November 06, 2020, 04:52:35 PM »
What about some kind of  problem with a scraper?