Author Topic: Can you compile an older version of AM onto an existing retropie 4.0 image?  (Read 1510 times)

Chillimonster

  • Newbie
  • *
  • Posts: 5
    • View Profile
Morning.

I have a retropie 4.0 image that is just how i like it and want to play with Attract mode on the same image

The latest 4.0 image from Floob will not work correctly as there is a bug in the Atttract Mode stopping my dragonrise usb encoders from working properly so would need to install the 2.0 version of Attract mode.

How would i do this?

Hopefully its quite simple :-)

Thanks

Chilli

Chillimonster

  • Newbie
  • *
  • Posts: 5
    • View Profile
Re: Can you compile an older version of AM onto an existing retropie 4.0 image?
« Reply #1 on: September 01, 2016, 06:15:05 AM »
Anyone any idea?

I really dont want to have to start from scratch :-(

nitrogen_widget

  • Sr. Member
  • ****
  • Posts: 307
    • View Profile
Re: Can you compile an older version of AM onto an existing retropie 4.0 image?
« Reply #2 on: September 01, 2016, 10:28:42 AM »
Just follow the instructions for whichever distro retropie is based on.
I can't remember.

https://github.com/mickelson/attract/wiki/Compiling-on-the-Raspberry-Pi-%28Raspbian-Jessie%29

Far as I know depends didn't change for compiling between versions.

Chillimonster

  • Newbie
  • *
  • Posts: 5
    • View Profile
Re: Can you compile an older version of AM onto an existing retropie 4.0 image?
« Reply #3 on: September 02, 2016, 12:59:07 AM »
Would that not download and install the latest version of AM (2.1)?

That will not work with my usb encoders hnce the question of installing an 'older' version (2.0)


nitrogen_widget

  • Sr. Member
  • ****
  • Posts: 307
    • View Profile
Re: Can you compile an older version of AM onto an existing retropie 4.0 image?
« Reply #4 on: September 02, 2016, 08:42:15 AM »
Not if you download the source for 2.0.  ;)
https://github.com/mickelson/attract/releases