Author Topic: [download v1.0] FLAT BLUE theme released  (Read 151098 times)

Rupert H

  • Jr. Member
  • **
  • Posts: 21
    • View Profile
Re: [download v1.0] FLAT BLUE theme released
« Reply #195 on: February 15, 2019, 06:09:16 AM »
I have no expertise in fixing it, but I guess it couldn’t harm to have it out there so that those who had the ability could fix it.

Once again, a huge thanks for your work. It’s an excellent theme.

bundangdon

  • Sr. Member
  • ****
  • Posts: 208
    • View Profile
Re: [download v1.0] FLAT BLUE theme released
« Reply #196 on: May 24, 2019, 07:32:59 PM »
FLAT BLUE theme v 1.0 released

Finally it is ready to download.
Get it here:
www.ONYXarcade.com/flat_blue


Verion, really like this theme and have used it for a while. But I was wondering, is there any way possible to replace the wheel art (on the top right of the screen) with flyer/boxart? I've messed around with the code (.nut) but couldn't find a way, at least not yet. Any help would be appreciated  ;D

verion

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 861
    • View Profile
    • new projects
Re: [download v1.0] FLAT BLUE theme released
« Reply #197 on: May 25, 2019, 10:08:53 AM »
Can't help you with the code, it's my design but the theme is coded by Chris Van Graas (chrisvg).

If I were you, I'd simply search the code for the word "wheel" and start to tinker there.
Or just put your flyer/boxart into your wheel folder (or change the path for wheel graphics to the flyer or artwork folder). You may want to tinker with the size probably.

yellertoof

  • Newbie
  • *
  • Posts: 1
    • View Profile
Re: [download v1.0] FLAT BLUE theme released
« Reply #198 on: June 17, 2019, 11:44:47 AM »
Great looking theme, hoping to run this on rpi3+.  Any news on 2.0?
Also, the download link is broken at the moment.

Kaizen777

  • Newbie
  • *
  • Posts: 5
    • View Profile
Re: [download v1.0] FLAT BLUE theme released
« Reply #199 on: May 27, 2020, 05:27:16 PM »
Hello, thanks for this - look awesome.  The link is broken, where can I get it?  Thanks!

verion

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 861
    • View Profile
    • new projects
Re: [download v1.0] FLAT BLUE theme released
« Reply #200 on: July 08, 2020, 03:12:16 PM »
Sorry guys - link is working again.

Airart

  • Newbie
  • *
  • Posts: 1
    • View Profile
Re: [download v1.0] FLAT BLUE theme released
« Reply #201 on: October 26, 2020, 12:20:01 AM »
Hi guys ! I have a problem with AM on win 10 old laptop , AM version 261 , i use the theme, flatblue, it’s very cool but i’v this missing pic on a background , i’v already downloaded all picure .....

verion

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 861
    • View Profile
    • new projects
Re: [download v1.0] FLAT BLUE theme released
« Reply #202 on: November 02, 2020, 10:01:54 AM »
do you see the images with any other theme?
If not - there is something wrong in your config

mjnman

  • Newbie
  • *
  • Posts: 7
    • View Profile
Re: [download v1.0] FLAT BLUE theme released
« Reply #203 on: March 30, 2021, 05:09:34 AM »
I kept the theme zipped, it would not run otherwise
I've heard that before - maybe it has something with the file structure (having subfolders)

Same here. Unzipped it doesn't work with either AM 2.2.0-3 or 2.2.1-50. Output from the latter:

Code: [Select]
*** Initializing display: 'Flat Blue'
 - Loaded master romlist 'mame' in 273 ms (33336 entries kept, 0 discarded)
 - Constructed 2 filters in 6 ms (66672 comparisons)
Error, file not found: /home/user/.attract/layouts/flat_blue/ (scripts/helperfunctions.nut)
Error, file not found: /home/user/.attract/layouts/flat_blue/ (scripts/vectors.nut)
Error, file not found: /home/user/.attract/layouts/flat_blue/ (scripts/layoutsettings.nut)
Error, file not found: /home/user/.attract/layouts/flat_blue/ (scripts/sidebar.nut)
Error, file not found: /home/user/.attract/layouts/flat_blue/ (scripts/mamedats.nut)
Error, file not found: /home/user/.attract/layouts/flat_blue/ (scripts/mainmenu.nut)
Error, file not found: /home/user/.attract/layouts/flat_blue/ (scripts/background.nut)
Error, file not found: /home/user/.attract/layouts/flat_blue/ (scripts/infopanel.nut)

AN ERROR HAS OCCURED [the index 'LayoutSettings' does not exist]

CALLSTACK                                                                                                                                                                                                                                             
*FUNCTION [main()] /home/user/.attract/layouts/flat_blue/layout.nut line [63]                                                                                                                                                                       
                                                                                                                                                                                                                                                     
LOCALS                                                                                                                                                                                                                                               
[vargv] ARRAY                                                                                                                                                                                                                                         
[this] TABLE                                                                                                                                                                                                                                         
Script Error in /home/user/.attract/layouts/flat_blue/layout.nut - the index 'LayoutSettings' does not exist                                                                                                                                       
 - Loaded layout: /home/user/.attract/layouts/flat_blue/ (layout.nut)                                                                                                                                                                               
 - Layout is empty, initializing with the default layout settings                                                                                                                                                                                     

In zipped form it works fine.

Another matter:

How do I point the theme to my icons folder for icons instead of snaps in the sidebar? I tried to set an artwork folder names "icons" to the icons folder, but it didn't work.

The problem are the case sensitive linux path in file layout.nut.
The correct values is:

fe.do_nut("scripts/HelperFunctions.nut");
fe.do_nut("scripts/Vectors.nut");
fe.do_nut("scripts/LayoutSettings.nut");
fe.do_nut("scripts/SideBar.nut");
fe.do_nut("scripts/MAMEDats.nut");
fe.do_nut("scripts/MainMenu.nut");
fe.do_nut("scripts/Background.nut");
fe.do_nut("scripts/InfoPanel.nut");
// fe.do_nut("scripts/OverlayMenu.nut");

nellino

  • Full Member
  • ***
  • Posts: 42
    • View Profile
Re: [download v1.0] FLAT BLUE theme released
« Reply #204 on: April 13, 2021, 02:17:54 PM »
thank you so much for this wonderful job, i am using this theme for my vertical, but i wish i could center the snap video so it doesn't get cut (photo), usually i can adjust these videos in .nut files but now they are not successful in any way, could you tell me the string to do it?

https://ibb.co/KDHYrLz

dynastyed

  • Newbie
  • *
  • Posts: 2
    • View Profile
Re: [download v1.0] FLAT BLUE theme released
« Reply #205 on: May 14, 2021, 09:47:52 AM »
this is a great job thanks,
I ve got a dual core I'm just wondering if any knows how i could change resolution manually to low res in the .nut file.
Thanks.

coasterpro

  • Newbie
  • *
  • Posts: 2
    • View Profile
Re: [download v1.0] FLAT BLUE theme released
« Reply #206 on: March 10, 2022, 01:23:04 AM »
I give in and I need help. :'(

I'm trying to get a vertical theme working for a cocktail build, literally ANY vertical theme, but nothing is working for me. For example, here is Flat Blue.



The display is set to rotate left, but it looks like this regardless of the rotation setting. Am I missing a dependency?

* Ubuntu 20.04.10
* MAME 0.220
* Attract-Mode 2.6.2

AM was compiled from code in $HOME/.attract. MAME is the only emulator installed. All paths are set correctly and most horizontal themes look wonderful.

Immediate thought is config. But what other config is there? I've run out of configs to config.

I'm hoping someone has seen this specific symptom and can point me in a direction. If needed I can post a trimmed down version of my entire attract folder (minus ROMs of course). It's got to be something simple.
« Last Edit: March 10, 2022, 01:52:19 AM by coasterpro »

Mark Norville

  • Sr. Member
  • ****
  • Posts: 235
    • View Profile
Re: [download v1.0] FLAT BLUE theme released
« Reply #207 on: March 10, 2022, 08:07:25 AM »
I have not used this theme, especially not in vertical mode.

However looking at your pictures you have some really weird file names going on there.

The chances are your XML file is not the same as your file names

Terra Force (US) will be correct in the XML as an example *** Actually it will be wrong as it should be (USA)

Terra Force (USA) (Set 1) (Rev B) (12/9/83) would not be

Firstly you need to have everything matched up, your file names for the roms, must match your logos, must match your videos etc.

If they are different, then it is going to screw up. Sadly a lot of people just compile a lot of roms and don't worry about file structure or anything else.

AM is XML dependant but something like coinops is whack any old rubbish into a folder and it works.

Regards

Mark
« Last Edit: March 10, 2022, 10:16:35 AM by Mark Norville »
Well I am back a new PC I7 4790K, 780 TI, 16 Gigs, Windows 10. Hopefully will get delivered at weekend.

Computer Specs : I7 3770K, 780 TI, 16 Gigs, Win 10
HD Specs : 1 x 1 TB SSD + 4 x 8 TB = 33 TB (fullish)
First system : ZX81 (Yes I am an old fart)
PS Network : MarkNorvile
Xbox : Mark Norville

coasterpro

  • Newbie
  • *
  • Posts: 2
    • View Profile
Re: [download v1.0] FLAT BLUE theme released
« Reply #208 on: March 10, 2022, 07:37:02 PM »
Thanks for the reply. Unfortunately even paring down the ROM list and making sure all names match did not resolve the problem with the display. However, in playing around with the machine today I did notice that the 'Basic' layout, which comes with AM, actually looks quite acceptable in portrait mode. There is some stretching and it's not as flashy or refined as dedicated vertical themes, but I'll take it for now.

Mark Norville

  • Sr. Member
  • ****
  • Posts: 235
    • View Profile
Re: [download v1.0] FLAT BLUE theme released
« Reply #209 on: March 10, 2022, 11:52:08 PM »
I see you are using ubuntu or what ever it is called. I would not be able to help with that anyway, as I am windows all the way.

I will give the skin a try and see if it works my end as I am just waiting for things to unzip, it should at least go vertical if I change the settings.

Sadly some of these skins, you have to do X Y and Z to get them working, rather than just being able to plug and play.

I will give it a go now as just waking up and the coffee is still going down my throat.

I have tried it, and it works for myself, I went left and straight away it broke my neck having to turn it so much to look at it.

Just make sure you have the following folder structure

Layouts > flat_blue (as it is in when you unpack)

Make sure you do not have Layouts > Unpack Directory > Flat Blue > files

It has to be Layouts > One Directory Only > Files

As I have more time

AM > Layouts > Flat_Blue

images (Directory)
scripts (Directory)
shaders (Directory)
Lato-Black (File)
Lato-Heavy (File)
Lato-Medium (File)
Lato-Regular (File)
layout (File)

Regards

Mark
« Last Edit: March 11, 2022, 02:46:26 AM by Mark Norville »
Well I am back a new PC I7 4790K, 780 TI, 16 Gigs, Windows 10. Hopefully will get delivered at weekend.

Computer Specs : I7 3770K, 780 TI, 16 Gigs, Win 10
HD Specs : 1 x 1 TB SSD + 4 x 8 TB = 33 TB (fullish)
First system : ZX81 (Yes I am an old fart)
PS Network : MarkNorvile
Xbox : Mark Norville