Author Topic: Issue starting a game, The game starts in the background  (Read 484 times)

pacman_fan

  • Newbie
  • *
  • Posts: 3
    • View Profile
Issue starting a game, The game starts in the background
« on: October 13, 2023, 12:37:48 PM »
I've narrowed the problem down to a key being pressed while mame is loading.
I believe its a windows thing, same happens opening up any application in wndows. if ctrl, alt or shift are pressed or held when starting word, IE, or MAME, that app launches in the back.

As hard as I try to start it, sometimes a player will just pressed buttons after selecting their game, then the game isn't visable, or the coin/start commands goto the background, app not functioning, until I Alt-Tab with a keyboard!  not fun.
« Last Edit: October 13, 2023, 12:51:47 PM by pacman_fan »

pacman_fan

  • Newbie
  • *
  • Posts: 3
    • View Profile
Re: Issue starting a game, The game starts in the background
« Reply #1 on: October 13, 2023, 06:05:18 PM »
Experimenting with this some more, its when the user presses a key multiple time after selecting the game!
usually it's the CTRL (fire) or Coinin (5) keys

progets

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 1271
    • View Profile
Re: Issue starting a game, The game starts in the background
« Reply #2 on: October 13, 2023, 09:51:09 PM »
Try Configure-->Emulator--(your_emulator_name)-->Non-Blocking Mode Wait = 10.

If this works you can play with the 10 number and reduce it as low as possible before the problem returns. BTW - 10 equals the number of seconds AttractMode will wait before putting focus on the emulator when launching a game so be patient when testing.

pacman_fan

  • Newbie
  • *
  • Posts: 3
    • View Profile
Re: Issue starting a game, The game starts in the background
« Reply #3 on: October 15, 2023, 06:50:50 PM »
Thank you for the suggestion, but that had no effect.

I managed to find an article with a solution using autohotkey, it works well!

https://www.autohotkey.com/boards/viewtopic.php?style=19&t=93082