Author Topic: Installation help in Ubuntu  (Read 933 times)

nespcbuild

  • Jr. Member
  • **
  • Posts: 19
    • View Profile
Installation help in Ubuntu
« on: June 05, 2021, 07:11:32 PM »
Does anyone know how I can get past this error? What am I doing wrong here?

Ubuntu 20.04.2 LTS

Code: [Select]
$ sudo add-apt-repository ppa:daveg/attract
 Attract-Mode is a graphical frontend for command line emulators such as MAME, MESS and Nestopia. It hides the underlying operating system and is intended to be controlled with a joystick, gamepad or spin dial, making it ideal for use in arcade cabinets. Attract-Mode is open source and runs on Linux, OS X and Windows-based systems.

 More info: https://launchpad.net/~daveg/+archive/ubuntu/attract
Press [ENTER] to continue or Ctrl-c to cancel adding it.

Hit:1 http://archive.ubuntu.com/ubuntu focal InRelease
Ign:2 http://ppa.launchpad.net/daveg/attract/ubuntu focal InRelease
Hit:3 http://archive.ubuntu.com/ubuntu focal-updates InRelease
Hit:4 http://archive.ubuntu.com/ubuntu focal-backports InRelease
Err:5 http://ppa.launchpad.net/daveg/attract/ubuntu focal Release
  404  Not Found [IP: 91.189.95.85 80]
Hit:6 http://archive.ubuntu.com/ubuntu focal-security InRelease
Reading package lists... Done
E: The repository 'http://ppa.launchpad.net/daveg/attract/ubuntu focal Release' does not have a Release file.
N: Updating from such a repository can't be done securely, and is therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user configuration details.

kent79

  • Hero Member
  • *****
  • Posts: 804
    • View Profile
Re: Installation help in Ubuntu
« Reply #1 on: June 06, 2021, 05:33:36 AM »
Code: [Select]
sudo apt-get -y install make g++ git libsfml-dev libopenal-dev libavformat-dev libfontconfig1-dev libfreetype6-dev libswscale-dev libavresample-dev libarchive-dev libjpeg-dev libglu1-mesa-dev libxcursor-dev libxrandr-dev libxinerama-dev libxi-dev
gi t clone https://github.com/mickelson/attract.git && cd attract
make
sudo make install
You may try  :)
« Last Edit: June 06, 2021, 05:40:18 AM by kent79 »

akafox

  • Hero Member
  • *****
  • Posts: 979
    • View Profile
Re: Installation help in Ubuntu
« Reply #2 on: June 06, 2021, 10:34:15 AM »
Linux user here,

I am not sure the ppa repository as been updated in a while. You will have to compile it yourself.

go here to install dependencies. You can just copy and paste the whole line there into your terminal.  (Remember you have to be 'root' to do this!)

Note: Add libcurl4-openssl-dev so that the scraper within AM will work. If do not add it not add it you get a "cannot scrape because AM was built without curl" error." You can compile without this if you are not going to use the scraper.

Download the tarball from here. (Note: I suggest using the tarball because I was having problems compiling from the github repository.)

Note: The gihub version is now working (have no idea what it was). It is better to use it as kent79 suggested as it is the 'most recent code'.

Now you can compile:
1. Change to the directory you downloaded the tar file into (i.e. cd Downloads)
2. Decompress the archive using
Code: [Select]
tar -xvzf attract-2.6.1.tar.gz3. cd into the folder Attract-2.6.1
Code: [Select]
cd Attract-2.6.14. type
Code: [Select]
make5. to "install" it change to your root (admin) user and type
Code: [Select]
sudo make install6. As a normal user type
Code: [Select]
attract7. Setup Attract Mode http://forum.attractmode.org/index.php?topic=328.0
« Last Edit: June 06, 2021, 11:47:53 AM by akafox »
People want life easy..then complain about it

nespcbuild

  • Jr. Member
  • **
  • Posts: 19
    • View Profile
Re: Installation help in Ubuntu
« Reply #3 on: June 06, 2021, 12:28:56 PM »
Thanks to both of you for replying and helping me out. Finally got it up and running using akafox's instructions.