Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - hermine.potter

Pages: 1 ... 49 50 [51] 52
751
aah! escape characters, of course!
Thank you. It works.

local death_sound = fe.add_sound ( "C:\\attract\\sounds\\death1.wav" );
death_sound.playing=true;

752
General / Re: mame ui 64 get an error on AM
« on: May 29, 2015, 04:42:41 AM »
I'm using mame v0.159 on a x86 windows. My steps:

1) First I've started mame manually under windows with mame.exe and configured the emulator (fullscreen, joystick-inputs and so on).

2) then I've configured mame under attractmode with these settings:
# Generated by Attract-Mode 1.5.3
#
executable           C:\attract\EMU\mame\mamepp.exe
args                 [name] -skip_gameinfo
rompath              C:\attract\EMU\mame\roms
romext               .zip;.7z;<DIR>
system               Arcade
info_source          mame
artwork    flyer           
artwork    marquee         $HOME/mame/marquees
artwork    snap            $HOME/mame/videos;$HOME/mame/snap
artwork    wheel 

I've added the parameter -skip_gameinfo because you can't find an option under mame.exe directly. So you have to use it by setting as a parameter.

Next time I'm upgrade mame to version 0.162 and do the same steps again:
1) Configure the emulator under windows and looking what options are not available under the emulator (this would probable be -skip_gameinfo again).
2) If it not available as option I'll left the arguments-line in AM as shown as above.
If it's now available as option I'll delete parameter in AM and left this line (without any parameters):
args                 [name]

753
Scripting / Re: how to add a soundfiles to layout / play sounds
« on: May 29, 2015, 03:46:36 AM »
thank you and never mind. that's ok. now i'm able to playing soundfiles and that's the clou ^-^

first time putted on the folder of attracman-layout and it doesn't worked
(as told as in the reference : fe.add_sound( name )
name - the name of the sound file located in the layout directory.

next putted on sounds-folder and doesnt't worked

puttend on root => perfect. play sounds ^-^
learning by doing..

754
Scripting / Re: how to add a soundfiles to layout / play sounds
« on: May 28, 2015, 10:52:58 PM »
Thank you for confirming my code-snippet (it's the same. I used death_sound instead Wheelclick as variable ^-^).

I've found a solution. I've copied the death1.wav to the root of AM (where attract.exe is found).
In my case: C:\attract

Now attracman dies with the pacman death soundfile. Please notice that attracman is only a cousin of pacman ^-^

Is it possible, adding a path to file? This doesn't work:
local Wheelclick = fe.add_sound("C:\attract\sounds\Click.mp3")
=> unrecognised escaper char


755
General / Re: mame ui 64 get an error on AM
« on: May 28, 2015, 10:21:57 PM »
Your argument [rompath] is not correct. Use [name] instead.
It's important using the correct syntax and notation.

the mame-emulator (and all another emulator-systems) works similar this way:
path_to_emulator\emulator.exe filename_of_game -other_parameters
e.g. : B:\Emulators\MAME\MameUI64\Mameui64.exe game_abc_123.zip

What you do with your config, is starting a folder, instead a gamefile:
path_to_emulator\emulator.exe rompath -other_parameters
B:\Emulators\MAME\MameUI64\Mameui64.exe B:\mame151\MAME151roms

756
Hi!
I'm trying adding soundfiles to a layout (especially a die-sound of attracman in attracman-layout). squirrel isn't my language yet. I've found the play-function, but wasn't able playing the soundfile yet. Please help ^-^

I've found pacman-soundfiles there.., copy the death1.wav to layouts/attracman and added this extra phrases on line #1257 in layouts/attracman/engine.nut

::pman.death ( animate_frame );
//declare
local death_sound = fe.add_sound ( "death1.wav" );
//execute
death_sound.playing=true;

g.collided = false;

757
General / Re: emulator cover / automatic cover download
« on: May 28, 2015, 05:45:50 AM »
the new added scraper options works nearly perfect. Thank you

But : I've got still the same problems with emumovies and other cover providers : I do not get the covers of many asia / japanese games (like games of Super Famicom ).

1) Is it possible adding another or extra InfoSource/Scraper? Like this ones:

http://archive.vg/
http://www.giantbomb.com/
http://www.mobygames.com/
http://maws.mameworld.info/

2)
On the website of www.gamefaqs.com their offer a nearly complete overview of all covers that exists. Like this one:
http://www.gamefaqs.com/snes/581919-chibi-maruko-chan-mezase-minami-no-island/images

Is it possible adding game-covers from gamefaqs? Have no idea to solve it...
 

758
General / Re: mame ui 64 get an error on AM
« on: May 28, 2015, 03:45:06 AM »
'Generate Collection/Rom List' and try again.

once again : check your correct syntax and notation

 .zip;rom => wrong
correct : .zip;.rom

Are the paths to your roms correct?
 B:\mame151\MAME 0.151 ROMs
not this? B:\mame151\MAME 0.151\ROMs

759
General / Re: cannot get it to run any emulator
« on: May 22, 2015, 04:07:23 AM »
Congratulations. The Emulator Fusion364 now starts your game '688 sub attack' successfully!
Set the Arguments (as told many posts ago) to fullscreen and auto. Enjoy:

args                 "[romfilename]" -fullscreen -auto

btw: use this version of fusion364 (your installed version seems not to supporting exit with esc-button)
http://segaretro.org/images/6/6c/Fusion364.7z

And for another emulators the same procedure as every year:
1) Set path to the executable of the emulator & set the name of the executable & set the extension of the executable: 
D:\attracmoded151\emulation\whatever_emulator\whatever.exe

2) Set the arguments of emulator ( use google or emulator website ):
"[romfilename]" -fullscreen -whatever

3) Set rom folder
D:\attracmoded151\emulation\whatever_emulator\roms

4) Set extensions of roms
.zip; .whatever

760
General / Re: cannot get it to run any emulator
« on: May 22, 2015, 03:03:05 AM »
@abls1
>First:
Please consider that attract.exe is found there:
D:\attracmoded151\attract.exe

and not (like your screenshot tells)
D:\attracmoded151\emulation\attract.exe

It's the wrong folder for the attract.exe

>Second:
I've tested your mediafire-files on another win7 64bit system. It works by modify the fusion.cfg (but i think the sonic-rom is broken. Attack Sub worked fine):

executable           D:\attracmoded151\emulation\Fusion364\fusion.exe
romext               .sms;.sg;.sc;.mv;.gg;.cue;.bin;.zip;.gen

Code: [Select]
# Generated by Attract-Mode 1.5.1
#
executable           D:\attracmoded151\emulation\Fusion364\fusion.exe
args                 "[romfilename]"
rompath              D:\attracmoded151\emulation\Fusion364\roms
romext               .sms;.sg;.sc;.mv;.gg;.cue;.bin;.zip;.gen
system               Sega Genesis
info_source          thegamesdb.net
artwork    flyer           $HOME/fusion/boxart
artwork    marquee         
artwork    snap            $HOME/fusion/videos;$HOME/fusion/snap
artwork    wheel   

761
General / Re: cannot get it to run any emulator
« on: May 20, 2015, 07:36:47 AM »
I've tested this config & it works..
-auto sets the region of game to automatic (pal, jp, eur).
I don't know your parameter --quickexit. Is it even necessary (because fusion exits already by pushing the ESC Button)?

executable           C:\attract\EMU\Fusion364\Fusion.exe
args                 "[romfilename]" -gen -auto -fullscreen
rompath              C:\attract\EMU\Fusion364\roms
romext               .sms;.sg;.sc;.mv;.gg;.cue;.bin;.zip
system               Sega Genesis

762
General / Re: Launch Chrome Browser or any EXE
« on: May 20, 2015, 06:29:55 AM »
@michel almeida
problems?
Use this autoit-script. It kills the task of attract.exe after closing firefox.

763
General / Re: cannot get it to run any emulator
« on: May 19, 2015, 04:42:21 AM »
please enter full path to .exe, put the .exe-extension behind and set the arguments/parameters (in your case:-gen "[romfilename]")
Please note :  http://www.launchbox-app.com/forum/emulation/command-line-parameters-arguments
Please turn off hiding extensions : https://support.microsoft.com/de-de/kb/865219/en-us

e.g. zsnes:

764
General / Re: Launch Chrome Browser or any EXE
« on: May 18, 2015, 01:12:40 AM »
After closing browser, AM being closed immediately too, right?!

Use this autoit-script. It kills the task of attract.exe after closing firefox.
Code: [Select]
#include <MsgBoxConstants.au3>

run ('C:\Program Files\Mozilla Firefox\firefox.exe')
;run ('C:\Program Files (x86)\Mozilla Firefox\firefox.exe')

While 1

If ProcessExists("firefox.exe") Then

Else
ProcessClose("attract.exe")
Exit

EndIf

WEnd

765
General / Re: Running DICE with Attract Mode
« on: April 13, 2015, 10:32:20 PM »
Another way is, that the emulator dice supports his own parameters starting games:
path_to_dice\dice.exe name_of_game

antiaircraft
attack
breakout
cleansweep
crashnscore
crossfire
gotcha
jetfighter
hiway
indy4
pinpong
pong
pongdoubles
quadrapong
rebound
sharkjaws
spacerace
steeplechase
stuntcycle
tvbasketball
wipeout

So you can create links to dice.exe and set as target the desired game as a parameter:
path_to_dice\dice.exe pong

in AM (attractmode)
Executable : cmd
Command Arguments : /c "[romfilename]"
Rom Path(s) : path_to_your_links
Rom Extension(s) : .lnk

Pages: 1 ... 49 50 [51] 52