Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - hermine.potter

Pages: 1 [2] 3 4 ... 51
16
General / Re: Scraping only for missing art?
« on: August 30, 2021, 01:25:07 AM »
Just tested a few monents ago:

Scrape artwork for 40 rom-files: 5 seconds (40 files(s) downloaded)

delete one of the artworks and scrape again : 1 second (1 file(s) downloaded)

replaced an existing artwork with another artwork (which has nothing to do with the game) : 1 second (0 file(s) downloaded)

Seems that AM only replace missing files (and not existing).

17
@ gameroommedic
by pressing the Exit-Button, AM kills the program that you stored in the executable line.

executable           E:\emulators\TeknoParrot\TeknoParrotUi.exe
AM kills : TeknoParrotUi.exe

the problem with previous started emulator-UI / GUI is:
if UI/GUI closes, the games do not exit too (game still running).

>Different options (depends on emulator UI / GUI):



-Game stops with UI/GUI automatic

if UI/GUI closes, the game closes too.
depends on UI/GUI programming / coder.



-Exit-Button in UI/GUI:

Set Exit-Button in UI/GUI + Do NOT SET Exit-Button in AM.
if you press Exit-Button: GUI closes the game + GUI close itself + you return to AM.



-Set a after-script with taskkill / process-close / run after commands:

Use this plugin

use batch, autoit, autohotkey, whatever to make a taskkill / process-close.
close with this script your game.exe

like this:
Code: [Select]
@echo off
taskkill /F /IM "JoyToKey.exe"
taskkill /F /IM "notepad.exe"
taskkill /F /IM "myGame123.exe"
exit



-Set a before-script, that waits for specific key press:
use autoit, autohotkey, whatever to make a taskkill / process-close.

Like here

18
Uploading dubious .exe-files and not sourecode? :-)

I'm not using Teknoparrot.
Seems that this are the parameters in AM
Are your xml-files correct?
this plugin starts external scripts before and after emulator launch.

19
General / Re: difference between mame64 standalone and the same in AM
« on: August 12, 2021, 11:32:22 PM »
No idea where the error is.
Maybe MAME gets a wrong resolution from AM.
If MAME is started directly, it may read the Desktop resolution.
If Mame is started from AM, it may read the resolution from AM and also start this resolution in MAME.
Try the switchres and resolution MAME-parameter with different resolutions:

Code: [Select]
executable           C:\attract\EMU\MAME\mame.exe
args                 [name] -skip_gameinfo -switchres -resolution 640x480

20
General / Re: difference between mame64 standalone and the same in AM
« on: August 12, 2021, 08:05:20 AM »
maybe any plugins are not loaded?
what happens, if you start a specific romfile with Mame64.exe direct from commandline?

21
General / Re: Mouse/Trackball cursor/issues when launching from AM
« on: August 12, 2021, 08:02:26 AM »
please check, how emulation station starts mame games (emulator, cores, parameters).
please adopt this settings to AM.

22
Themes / Re: Multiple layouts in attract mode
« on: August 12, 2021, 07:59:41 AM »
Start AM > press TAB key > Displays > choose your 'nesica' display > Layout : choose another layout
Start AM > press TAB key > Displays > choose your 'ringedge' display > Layout : choose another layout

23
General / Re: Joysticks
« on: August 10, 2021, 01:47:43 AM »

24
Emulators / Re: Mame compile question?
« on: August 09, 2021, 01:28:52 AM »

25
Scripting / Re: Code problem
« on: August 07, 2021, 01:11:10 AM »
today, error again:
Code: [Select]
500 Internal Server Error

Internal Server Error

The server encountered an internal error or misconfiguration and was unable to complete your request.

Please contact the server administrator at webmaster@forum.attractmode.org to inform them of the time this error occurred, and the actions you performed just before this error.

More information about this error may be available in the server error log.

Windows 10
different Browser (no plugins)
no vpn

tried to edit this post => Error 500
tried to edit this post => Error 500
edit this post => edit successful (no error 500)

it seems, that the board blocks any batch or autoit code. or specific commands of them.
it already worked, because I could save the threads. But now can't save again.
are there some server security options meanwhile enabled? something like disable exec, shell-exec-commands in threads?

26
General / Re: 2 rom same name
« on: August 06, 2021, 01:59:25 AM »
by generating a romlist, AM removes duplicates automatically.
so it won't works.

find a unique name.

for example:
C:\attract3\EMU\ZSNES\ROMS1\Game1.smc
C:\attract3\EMU\ZSNES\ROMS2\Game1_(HACK).smc

Code: [Select]
executable           C:\attract3\EMU\ZSNES\zsnesw.exe
args                 "[romfilename]"
rompath              C:\attract3\EMU\ZSNES\ROMS1;C:\attract3\EMU\ZSNES\ROMS2
romext               .smc
exit_hotkey          Escape

OR

Try hardcoding romlist.

for example:
C:\attract3\EMU\ZSNES\ROMS1\Game1.smc
C:\attract3\EMU\ZSNES\ROMS2\Game1.smc

leave rompath empty:
Code: [Select]
executable           C:\attract3\EMU\ZSNES\zsnesw.exe
args                 "[romfilename]"
romext               .smc
exit_hotkey          Escape

edit romlist:
your_AM_folder\romlists\your_display.txt

C:\attract3\EMU\ZSNES\ROMS1\Game1;Name_of_Game1_whatever_you_want_to_see_in_AM;ZSNES;;;;;;;;;;;;;;;;;;
C:\attract3\EMU\ZSNES\ROMS2\Game1;Name_of_Game2_whatever_you_want_to_see_in_AM;ZSNES;;;;;;;;;;;;;;;;;;

27
Themes / Re: Searching high and low for a layout
« on: August 02, 2021, 10:53:54 AM »
this is the thread you search
but it seems, that the download-links are down

28
Scripting / Re: Code problem
« on: July 29, 2021, 09:02:43 PM »
me too.
I've tried to post batch-code in this thread.

and get this error message:
Code: [Select]
Internal Server Error

The server encountered an internal error or misconfiguration and was unable to complete your request.

Please contact the server administrator at webmaster@forum.attractmode.org to inform them of the time this error occurred, and the actions you performed just before this error.

More information about this error may be available in the server error log.

the workaround:
uploaded the sourcecode as textfile-attachment

29
General / Re: ZXSpin Emulator
« on: July 29, 2021, 10:05:11 AM »
i think, your config-file is wrong.
please try fully qualified paths (static paths) before trying relative paths. i guess, you use drive-letter C:\ (fit to your drive-letter and paths):

Code: [Select]
executable           C:\emulate\zxspin\zxspin.exe
args                 "[romfilename]"
rompath              C:\roms\zxspectrum
romext               .dsk;.tap

or use another emulator. See here Section ZX Spectrum / Sinclair ZX Spectrum

30
>setup AM:
Here
Example

>setup Artwork:
Here

>Setup RL:
Here

Pages: 1 [2] 3 4 ... 51