Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - akafox

Pages: [1] 2 3 ... 64
1
Emulators / Re: Ubuntu x64 Commodore VIC-20
« on: July 31, 2021, 07:01:48 AM »
Okay let me get this understood...

You have installed retropie on a Ubuntu 20.04 based 64 bit PC not a raspberry pi correct?

1. How did you install the emulator?
2. What is your default emulator?

(I'm assuming VICE as it is the default.)

RetroPie install on Ubuntu 20.04 x64 ( Vic-20 runs fine from RetroPie)

So it loads just fine...

try this instead:
Code: [Select]
# Generated by Attract-Mode v2.6.1
#
executable           /opt/retropie/supplementary/runcommand/runcommand.sh 0 _SYS_ vic20
args                  "[romfilename]"

If i recall correctly that is what I had to do...do you have any other systems running on your setup through AM now?

also check /dev/shm/runcoomand.log and see if there are any errors reported.

2
General / Re: "generate Collection/Rom List" takes VERY long
« on: July 30, 2021, 10:51:24 AM »
I will toos my two chicken wings in here...this is mainly for people that find this later.

As was stated before if you create a list against the gamedb.net it can take a long time...sometimes "forever" (I left mine running one night to make a list of megadrive games...woke up..it is till wasn't done) It all depends on the what ever network issues per say I guess. I tried the same list a day later (26 hours) and I could get it in about a minute.

You can scrape locally and it is FAST..but it's only a half tailed list....

You CAN use a player.ini and a category.ini ect. for making console lists and is it FAST (it's all local). Arcade roms have a standard to make them easy to "scrape" from an xml file but the problem is the naming format for console roms are not. Your roms may not be named exactly as mine are therefore it doesn't pick up those roms or even work at all. After you scrape everything you can make your own custom "information files" and then use them as you see fit however. It's tedious work at best but I can build a fully filled out list without any internet connection at all. But most won't take the time or trouble.

Best thing to do is to backup your lists after you have them built. After that you can pull info from them or even re-use them if needed to save time. Remember the lists are just plain text files separated by semi-colons..so they are TINY and easy to store.

3
Emulators / Re: Windows 9x games emulation?
« on: July 22, 2021, 11:05:39 AM »
You have a serious machine to be able to do that....


Note though that emulation like that is really still hit or miss. Sure you can add them. I add native games to my system using scripts. Know though depending on the games you want to use there maybe modern versions of that games out there...For example Command & Conquer: Red Alert can be played on a modern machine without and emulations or "hacks" Heck even Doom can be  run that way now.

If you are interested about that you can IM me...
If you want to try to set up with windows 95 98 ect then you can answer here on the thread..but like I said that is hit or miss and can be difficult at best.

4
Emulators / Re: EPSXe and multidisk games. How?
« on: July 22, 2021, 10:59:50 AM »
@Leecher psx2psp_v.1.4.2 should handle up to five discs. I had all of my psx discs in PBP format at one time. However I will point out that I never did play though many multi-disc games however the few that I did worked flawlessly. I left psx2psp_v.1.4.2 on the default settings and never ran into a problem...well that wasn't cased by user error any way.

I do have to point out That ePEXe is not almost five years old. That is a long time in emulation time. So I have to ask do you need to use epsxe? i.e. your computer that old it will not run a more modern psx emulator? If so I understand as i have one of my own like that. However if you can use a more modern emulator see if that will help you. Mednfen does work however I am not sure the stand alone Mednafen reads pbp format. I moved to duckstation as it is a stand alone emulator and a retroarch core just like Mednafen is.

Duckstation is here https://github.com/stenzek/duckstation/releases/tag/latest

if you need to use epsxe then let us know ans will will try to help you

5
Emulators / Re: ENVIRONMENT VARIABLES NOT WORKING
« on: July 04, 2021, 10:20:48 AM »
For the args
A. The core

1. Open your file manager
2. Click Local Disk C: on the left
3. Open the folder Users
4. Open your user's folder
4. Open AppData folder
5. Open Roaming
6. Open RetroArch
7. Open cores folder
8. Click the path bar (the thing that has "This PC > Local Disk (C:) > Users > [your user name] > AppData > RetroArch > cores )
9. (once clicked it will be highlighted) Right Click and copy the path (ex. C:\Users\username\AppData\Roaming\RetroArch\cores)
10. copy that into your AM system config file so you get -L C:\Users\username\AppData\Roaming\RetroArch\cores\[insert core here].dll

B. The config file
1. Follow steps above to step six.
2. Open the config folder
3. go to the system folder you want
4. Copy the path as you did above
5 paste the path in your args line to append your config file
6. at the end of that path enter the config file that you want to use

So you end up with:

executable           C:\Users\yourusername\AppData\Roaming\RetroArch\retroarch.exe
args                 -L  C:\Users\username\AppData\Roaming\RetroArch\cores\picodrive_libretro.dll "[romfilename]" --appendconfig "C:\Users\yourusername\AppData\Roaming\RetroArch\config\Sega 32x\sega 32x.cfg"


Note that my config files have the extension .opt NOT .cfg That should work. Yeah I know there are more elegant ways..but first let's try to find out why it is not working then we can mess around with path names and be clean about it.

6
General / Re: Tagging and filtering games with the same name.
« on: July 04, 2021, 09:29:07 AM »
I would assume that because they are separate systems this would not be a problem. However, are you wanting to combine them into one list of '2D Performers' or something else?

In my roms for those systems it was just called "Aladdin' which might be why it wasn't tagged right (i.e. I have do not have info for it beyond the rom, title, and the system.) That info can be entered manually with caution into your list or you can rename the rom and re-scrape.

7
Never heard of it until you said something. I will look into it myself thank you!

How ever it still looks like it is based on 0.084 at least some of the code is. Tekken 3 runs like crap and it runs like that in standard version of mame 0.084 as well. But all that matters is that it worked for YOU. It's your cabinet!

Glad you got it all sorted!  :)

If you want to continue talking about this version of mame then lets move it over to the emulators section..as I think we have hijacked this thread enough!  ;)

8
The only thing I can suggest..if you REEELLLAAAAYYYY want to..and i mean want...

Try an older linux based distro. Make sure you find all the software you need FIRST before attempting this! 

I say this only because I have a I3 dual core I picked up for 99 and honestly it is a pos (though I know you are working with older hardware) it was "made for windows 7" and i can't even fit a graphics card that will fit in it..it will not run any 3-D based games. It was made to be cheap and for office work.

Funny thing is I try to run ANY emulators on it (running WIN10) and none work. Run it in liunx and I can run almost up to dreamcast..but still no 3-D PC games.

But again I say only IF you are willing to go through the hell of doing that with an older machine like that...you said a "P4 1.7Ghz machine"? Maybe try a 32-bit version of ubuntu (14.04 maybe?)...but again that is up to you. It might be a real pain in the tail...but it might pay off.

Good luck!

P.S. I do have to ask in your mame.ini...is it set to 3d3 or software...though i think we covered this...?

9
I've already played with display_expand settings, thats doesnt do anything?!
and display_resizeeffect is set to auto, doesnt slow down anything,,,

That is strange on the display expand setting  ???

as for the resize_effect My point is if you set it to 1 (or the lowest resolution you might be able to get games to 100%

if you are still having trouble with some running full speed. However know that some will NEVER run full speed not because of settings or your computer..just based on the emulators code itself. Tekken 3 runs slow in Advance mame even though the speed counter says 100% but then again Tetris plus runs slowly on standard mame and all err..branches of mame. No matter what machine I run it on (i.e. a pentium II 400Mhz single core all the way up to a I-9 ten core CPU) However once code is "fixed" or improved (a latter version of mame) then it will work just fine (thus tetris plus from mame 0.000 to 0.160 it runs slow...from mame 0.174 to current version it works just fine) it seems like you got it working though...

Just so you know mame plus stopped at 0.195 see if that can help with some of your slowdown problems a newer version might have the fixes you need. I really did like that branch and I wish they would come out with an updated version of it.

10
Stretching is easy
Code: [Select]
display_expand 1.25
change to 2.0 (2.0 is max)

I did forget to mention advance mame will "upscale"..thus  making the games slower. Look for the after you have loaded a game...Video  -> Magnify or mode put the scale all the way down to 1 THEN see if your games work. Your PC might be able to run the games fine...just not at the scaled video options. It take more CPU/GPU/RAM to process the effects along with the game.

To lock it to a scale mode on launch use

Code: [Select]
display_resizeeffect

Default it is set to auto. You mat use Auto, 1, 2,3, or 4 as valid values.  everything else is in the manual. (The huge scary manual...there's so many options my head spins manual  :o )  But that should help get you started :)

The effects (shaders) scanlines ect will take more resources as well. Your results will vary from machine to machine. Even on the pi. That is something you have to experiment with on your own as not all setups are not the same...unless it's a pi ..



11
Emulators / Re: ENVIRONMENT VARIABLES NOT WORKING
« on: June 24, 2021, 09:02:03 PM »
Out of curiosity can you open the folder to the config file you want to use..and then copy the path give in the path bar?


12
I'm messing around with AdvanceMAME now because I want metal slug 5 to work, so I'm testing out all the versions of the emulators that I like.

Umm..huh that's strange.  Advance mame should work well on that machine...that's weird..
Note that advance mame works better then the plain mame 0.106. CPSIII games (not sure when they working in what later version of mame and Toplan games work correctly with samples and the original 0.106 did not not until 2015?...I think... OH! and with CPSIII game in advance mame you don't need to have the chd to run them as you do in mame...but Advance mame will not run Killer Instinct 1 or 2 that driver has been broken for awhile now.

If metal slug 5 can run no lagg no frame skipping on a dos based system thats a P3 400Mhz with some old version that I dont know of AdvanceMAME?!?!, becuase I had a 200IN1 machine like that recently...
Okay now you are talking my launguage! I had an EXACT sysytem like that when I started with mame. I could not run anything up to neogeo games. (I could not run them or anything above them.) But I did find a version of mame that was made just for the problem. In fact I still use it..it very old but it worked for me. It is called 'fast mame'. It is mame...just well optimized i guess? Try it and see if it helps.
https://www.emulation64.com/files/info/41/fastmame.html/ (I am not responsible for any software YOU install and if/when anything gets messed up..just so you know :P )
but you can expect laggg on emulators that goes above a certain version number, I dunno if they changed the code or changed sometime bigtime... but everything just lagggs on new emulators using P4 systems, but downgrade your emulator and the lagg with be gone... I dont get!!!

The newer versions of mame are "more accurate" so therefore they take more resources to run even older games. i.e. you need more power to run them. So on ans older machine it is best to stick with older versions of mame. Among other reasons.... So yes with older machines you just have to use MANY emulators and versions of mame. Also if you want neogeo to run you can try final burn neo for neogeo (and CPSIII) games. That is what I do. I even run dice and Daphne so I can play pong and Dragon's lair.
Sadly part of running a "full cabinet" is about how many different emulators you need and how to make them work. That is how it goes...that is the way it has always been...

13
Wait a minute *facepaw*


wrong path!


put this in as your rom [path] instead

Code: [Select]
rompath           "M:\Emulators\Colecovision\Colecovision rom\"
(that was my fault for not paying attention sorry!)  :-X

14
try changing
Code: [Select]
rompath      roms
 to

Code: [Select]
rompath     M:\Emulators\mameplus\   

in your mame .ini and see if that makes a difference..it did for me anyway.


15
Well I am not sure what the problem is. However as I said...

If you will use the gamesbd as an info source (i.e. info_source thegamesdb.net not info_source  listxml) when you build the list the list should contain long names even if you use mame roms for coleco vision on mame.

But that does not explain why you attract mode config is not working...  :-\

Could you post your mame.ini file please? specifically just these parts so that i can see your path setup please

# CORE SEARCH PATH OPTIONS
#
homepath                  .
rompath     M:\Emulators\mameplus\   <-make sure you have this
hashpath     
samplepath   
artpath     
ctrlrpath     
inipath     
fontpath                 


I tired with my mame after changing my rom path and AM will not work... Put the right path in in the correct place and it works fine

if you need to make an ini file go to your mame directory and type
Code: [Select]
mame -cc

Pages: [1] 2 3 ... 64