Author Topic: atrract mode keeps crashing after I installed NVIDIA driver?!!?!?!?  (Read 1787 times)

JayLie

  • Full Member
  • ***
  • Posts: 31
    • View Profile
Hi, Im building 2 xp machines, running WinXP-attract-v2.6.1-win32, everything works fine, until I installed my drivers for my Nvidia GeForce2, I think... it did the same thing when I installed DirectX v9.0c .....  when I installed the ATI Radeon 9200 there was no issues :o

mame runs like rubbish on onboard gfx on old pc's!!! 

akafox

  • Hero Member
  • *****
  • Posts: 964
    • View Profile
Re: atrract mode keeps crashing after I installed NVIDIA driver?!!?!?!?
« Reply #1 on: June 09, 2021, 01:40:02 PM »
Are there any type of errors reported in the command line when ran from there?

mame runs like rubbish on onboard gfx on old pc's!!!

Well actually I do not think MAME will even use your graphics card....What version of mame are you trying to run? about as high as i could go was 0.130

If older arcade games are what you are wanting to run you can try final burn neo...or even final burn alpha maybe

I have an actual XP machine with onboard graphics works well enough..although I may be using MAMEWah! not Attract Mode.
 I'll dust it off tonight and let you know. It's so pld ot has a floppy drive and a 56K modem in it! I forgot about that...  :o  ???  ::)


Later: So I did just that. And it turns out it is an ATI onboard sooo sorry guess I am not much help.
« Last Edit: June 09, 2021, 08:27:12 PM by akafox »
People want life easy..then complain about it

JayLie

  • Full Member
  • ***
  • Posts: 31
    • View Profile
Re: atrract mode keeps crashing after I installed NVIDIA driver?!!?!?!?
« Reply #2 on: June 10, 2021, 12:09:15 AM »
i dont know anymore, I've downgraded my 2 mame pc's to P4 1.7Ghz for my cabinets for little kids that I'm building ysterday and removed the gfx cards, but the thing I dont understand at all!!!! is new mame versions laggg like hell on old systems, where  mame32 plus 74u1 or even MAME32 plus 0.83 works PERFECT on that axact same system without a gfx card and without lagg that result in audio stuttering ofcourse  :o :o :o ... drawback.. the games on the list that you can play is to old, I want metal slug 5 aswell, and ofcourse some roms will error out aswell when it loads on my old emulator

on the matter of a gfx card, adding a geforce2 seem to take the frameskip to 0 for metal slug, but still other games didnt fall for this trick on that old emulator

on my i7, using arcade 0.202 and tested ROM's and noticed, it used 30% usage of my Nvidia GTX780 using opengl or directx, not sure, i think it was set to opengl and ofcourse it was very hungry on my CPU, usage was monitored using OCCT

On my P4 system....For example, metal slug 3, 0 frames skipping required, even on after burner 2, no lagg on that old emulator, but try it with arcade32 0.202 or any other emulator thats newer then mame32 plus 0.83, youll get lagg and auto frame skip like crazy 11 frames skipped, and that will mess around with your audio aswell :-\

So did someone mess the code up between the old and new versions of mame source in general?
« Last Edit: June 10, 2021, 12:26:29 AM by JayLie »

JayLie

  • Full Member
  • ***
  • Posts: 31
    • View Profile
Re: atrract mode keeps crashing after I installed NVIDIA driver?!!?!?!?
« Reply #3 on: June 10, 2021, 12:20:19 AM »
The same goes for my 200IN1 systems that I first started on repairing but the stuff was to broken and kept on error error, so I decided to build 2 machines using P4 parts and strip the jamma to pc controllers out of the 200IN1 machines, but those 200IN1 specs was P3 motherboards running CPU's like 400Mhz up to 600~700Mhz and it ran games flawless using an very old version of AdvanceMAME, but when I copied the new version of AdvanceMAME on that system, the laggg was sooo bad!!!!!

And those systems have some type of encryption or protection that you cant really touch anything or else it will be wrecked!! and you cant swap the drive out for new drive.. boooom stupid error on screen in orange thats flashing, its also heavy dos based
« Last Edit: June 10, 2021, 12:22:26 AM by JayLie »

akafox

  • Hero Member
  • *****
  • Posts: 964
    • View Profile
Re: atrract mode keeps crashing after I installed NVIDIA driver?!!?!?!?
« Reply #4 on: June 11, 2021, 09:07:21 AM »
Have a look at your mame.ini file what is your video set to? try software ...then try d3d but remember that card has to be able to handle Diretx9 at least! Like I said I use just the integrated graphics and it works fine for most games. (mame.ini set to d3d)

 I use plain vanilla mame  version 0.130 32-bit version with the "scanline" artwork overlay (the machine is a old 32 bit cpu) and it works fine. At least up to cpnz games (i.e street fighter EX..and I have to use and old emulator for that mame will not run them) any systems beyond that will NOT work of a  machine like that (a 1.7ghz). You can also try a lower version of mame as newer versions are more intensive on the cpu so your machine may not have the needed resources for that

 I also assume that you installed windows XP 32 bit on these machines?

Also check the resolution of your monitor turn it down to 800x600 and then try again. You would be surprised how much that will help performance. And most of theses games are not even 800X600 most of them are lower even! you could try 640X480 because of that.

Again you can try Final Burn Neo for games that mame has trouble running. Even then it is hit and miss.

As for AM itself it still crashes upon start? You could try and older version..I think that might be what I did...I will have to look. And I have a very minimal theme to use with it.

Please report back your findings I will continue trying to help you.
« Last Edit: June 11, 2021, 09:10:38 AM by akafox »
People want life easy..then complain about it

JayLie

  • Full Member
  • ***
  • Posts: 31
    • View Profile
Re: atrract mode keeps crashing after I installed NVIDIA driver?!!?!?!?
« Reply #5 on: June 21, 2021, 04:05:22 AM »
I pulled the card out, not using it anymore... it crashes in any pc with AM and NVIDIA... might be a global issue with old NVIDIA drivers and AM, however old ATI drivers and AM have no issues with another...

but I'm playing with onboard....
« Last Edit: June 21, 2021, 04:23:04 AM by JayLie »

JayLie

  • Full Member
  • ***
  • Posts: 31
    • View Profile
Re: atrract mode keeps crashing after I installed NVIDIA driver?!!?!?!?
« Reply #6 on: June 21, 2021, 04:09:12 AM »
Have a look at your mame.ini file what is your video set to? try software ...then try d3d but remember that card has to be able to handle Diretx9 at least! Like I said I use just the integrated graphics and it works fine for most games. (mame.ini set to d3d)

 I use plain vanilla mame  version 0.130 32-bit version with the "scanline" artwork overlay (the machine is a old 32 bit cpu) and it works fine. At least up to cpnz games (i.e street fighter EX..and I have to use and old emulator for that mame will not run them) any systems beyond that will NOT work of a  machine like that (a 1.7ghz). You can also try a lower version of mame as newer versions are more intensive on the cpu so your machine may not have the needed resources for that

 I also assume that you installed windows XP 32 bit on these machines?

Also check the resolution of your monitor turn it down to 800x600 and then try again. You would be surprised how much that will help performance. And most of theses games are not even 800X600 most of them are lower even! you could try 640X480 because of that.

Again you can try Final Burn Neo for games that mame has trouble running. Even then it is hit and miss.

As for AM itself it still crashes upon start? You could try and older version..I think that might be what I did...I will have to look. And I have a very minimal theme to use with it.

Please report back your findings I will continue trying to help you.

I set my screen to 640x480 with crt_emudriver_6.5_1.2b_xp_32 and use onboard with SIS chipset on my 2 machines, and use winVGATV to get my 15Hz display up for my CRT screen in arcade cabinets

I'm using Mame32 Plus! 0.88u2 that can play lagg freee, newer versions of mame = lagggggggggggg, dunno why....

I'm messing around with AdvanceMAME now because I want metal slug 5 to work, so I'm testing out all the versions of the emulators that I like.

If metal slug 5 can run no lagg no frame skipping on a dos based system thats a P3 400Mhz with some old version that I dont know of AdvanceMAME?!?!, becuase I had a 200IN1 machine like that recently...

but you can expect laggg on emulators that goes above a certain version number, I dunno if they changed the code or changed sometime bigtime... but everything just lagggs on new emulators using P4 systems, but downgrade your emulator and the lagg with be gone... I dont get!!!
« Last Edit: June 21, 2021, 04:24:44 AM by JayLie »

akafox

  • Hero Member
  • *****
  • Posts: 964
    • View Profile
Re: atrract mode keeps crashing after I installed NVIDIA driver?!!?!?!?
« Reply #7 on: June 21, 2021, 01:36:51 PM »
I'm messing around with AdvanceMAME now because I want metal slug 5 to work, so I'm testing out all the versions of the emulators that I like.

Umm..huh that's strange.  Advance mame should work well on that machine...that's weird..
Note that advance mame works better then the plain mame 0.106. CPSIII games (not sure when they working in what later version of mame and Toplan games work correctly with samples and the original 0.106 did not not until 2015?...I think... OH! and with CPSIII game in advance mame you don't need to have the chd to run them as you do in mame...but Advance mame will not run Killer Instinct 1 or 2 that driver has been broken for awhile now.

If metal slug 5 can run no lagg no frame skipping on a dos based system thats a P3 400Mhz with some old version that I dont know of AdvanceMAME?!?!, becuase I had a 200IN1 machine like that recently...
Okay now you are talking my launguage! I had an EXACT sysytem like that when I started with mame. I could not run anything up to neogeo games. (I could not run them or anything above them.) But I did find a version of mame that was made just for the problem. In fact I still use it..it very old but it worked for me. It is called 'fast mame'. It is mame...just well optimized i guess? Try it and see if it helps.
https://www.emulation64.com/files/info/41/fastmame.html/ (I am not responsible for any software YOU install and if/when anything gets messed up..just so you know :P )
but you can expect laggg on emulators that goes above a certain version number, I dunno if they changed the code or changed sometime bigtime... but everything just lagggs on new emulators using P4 systems, but downgrade your emulator and the lagg with be gone... I dont get!!!

The newer versions of mame are "more accurate" so therefore they take more resources to run even older games. i.e. you need more power to run them. So on ans older machine it is best to stick with older versions of mame. Among other reasons.... So yes with older machines you just have to use MANY emulators and versions of mame. Also if you want neogeo to run you can try final burn neo for neogeo (and CPSIII) games. That is what I do. I even run dice and Daphne so I can play pong and Dragon's lair.
Sadly part of running a "full cabinet" is about how many different emulators you need and how to make them work. That is how it goes...that is the way it has always been...
People want life easy..then complain about it

JayLie

  • Full Member
  • ***
  • Posts: 31
    • View Profile
Re: atrract mode keeps crashing after I installed NVIDIA driver?!!?!?!?
« Reply #8 on: June 25, 2021, 07:24:45 AM »
My findings on AdvanceMAME

I've been playing around with "AdvanceMAME 0.106 and up" ... it doesnt show stupid nag screens when enabled!! it normalizes sound, everything is perfect, can play about any rom!!!! but.......
BIGGEST CON: it seem to have an issue with going complete full screen, some games it only stretches the vertical or horizontal and that a deal breaker!
ANOTHER CON.. it doesnt have a loading screen or progress bar!??! and this plugin in AM, thats supposed to be a loading screen is pointless.. it only displays for 1 sec and then the emulator loads with a black screen for a couple of seconds depending on game.
ANOTHER CON: AdvanceMAME doesnt show smooth gfx like all the other mame emulators... but thats not a deal breaker for me...

PROs: AdvanceMAME works very well with AM....

I'm running this in my advmame.rc file:
misc_quiet yes
misc_safequit no
device_video_output fullscreen

Im using AdvanceMAME 0.106 om my P4 1.7Ghz machine with no laggg, only games with higher resolution laggs, and midway games laggs a little bit, but too much to leave on machine..
by no lagg, I mean like metal slug 5 runs 100% fine. neogeo and capcom no problem, but when the game res is to high... lagg, and thats understandable
« Last Edit: June 25, 2021, 07:33:58 AM by JayLie »

akafox

  • Hero Member
  • *****
  • Posts: 964
    • View Profile
Re: atrract mode keeps crashing after I installed NVIDIA driver?!!?!?!?
« Reply #9 on: June 26, 2021, 08:07:21 AM »
Stretching is easy
Code: [Select]
display_expand 1.25
change to 2.0 (2.0 is max)

I did forget to mention advance mame will "upscale"..thus  making the games slower. Look for the after you have loaded a game...Video  -> Magnify or mode put the scale all the way down to 1 THEN see if your games work. Your PC might be able to run the games fine...just not at the scaled video options. It take more CPU/GPU/RAM to process the effects along with the game.

To lock it to a scale mode on launch use

Code: [Select]
display_resizeeffect

Default it is set to auto. You mat use Auto, 1, 2,3, or 4 as valid values.  everything else is in the manual. (The huge scary manual...there's so many options my head spins manual  :o )  But that should help get you started :)

The effects (shaders) scanlines ect will take more resources as well. Your results will vary from machine to machine. Even on the pi. That is something you have to experiment with on your own as not all setups are not the same...unless it's a pi ..


People want life easy..then complain about it

JayLie

  • Full Member
  • ***
  • Posts: 31
    • View Profile
Re: atrract mode keeps crashing after I installed NVIDIA driver?!!?!?!?
« Reply #10 on: June 26, 2021, 10:57:33 AM »
Yea that manual from advanceMAME makes my head spin aswell

almost most of the games are perfectly stretched on screen but the majority of it is games that I wont even want to keep on the system..

I've already played with display_expand settings, thats doesnt do anything?!
and display_resizeeffect is set to auto, doesnt slow down anything,,,

I just get super annoyed with the rubbish stretching from advanceMAME but.... this emulator is cool

I'm using "mame32 plus! 0.88u2" that stretches perfect like all the other mame emulators, and that mame32 plus also supports auto volume adjust thats awesome..... but it only goes up to metal slug 3 so im going to try a later version of mame32 plus!, its just hell to find software that you cant find anymore besides on Chinese or other painfull methods and on http://web.archive.org but its just a bunch of dead links mostly...

but this nag screens in general that you cant turn off is soo annoying (advanceMAME have none!)... and a no-nag version of mame something, then the loading bar is gone, and thats just as worst
« Last Edit: June 26, 2021, 12:37:05 PM by JayLie »

akafox

  • Hero Member
  • *****
  • Posts: 964
    • View Profile
Re: atrract mode keeps crashing after I installed NVIDIA driver?!!?!?!?
« Reply #11 on: June 27, 2021, 12:54:37 PM »
I've already played with display_expand settings, thats doesnt do anything?!
and display_resizeeffect is set to auto, doesnt slow down anything,,,

That is strange on the display expand setting  ???

as for the resize_effect My point is if you set it to 1 (or the lowest resolution you might be able to get games to 100%

if you are still having trouble with some running full speed. However know that some will NEVER run full speed not because of settings or your computer..just based on the emulators code itself. Tekken 3 runs slow in Advance mame even though the speed counter says 100% but then again Tetris plus runs slowly on standard mame and all err..branches of mame. No matter what machine I run it on (i.e. a pentium II 400Mhz single core all the way up to a I-9 ten core CPU) However once code is "fixed" or improved (a latter version of mame) then it will work just fine (thus tetris plus from mame 0.000 to 0.160 it runs slow...from mame 0.174 to current version it works just fine) it seems like you got it working though...

Just so you know mame plus stopped at 0.195 see if that can help with some of your slowdown problems a newer version might have the fixes you need. I really did like that branch and I wish they would come out with an updated version of it.
« Last Edit: June 27, 2021, 12:57:04 PM by akafox »
People want life easy..then complain about it

JayLie

  • Full Member
  • ***
  • Posts: 31
    • View Profile
Re: atrract mode keeps crashing after I installed NVIDIA driver?!!?!?!?
« Reply #12 on: June 28, 2021, 02:22:09 AM »
Yea ive tried all the mame32 plus! versions almost, I'm aware of that 0.195 end vibe

I use After burner2 and out run also as lagg bench not sure if thats a good bench reference even to use?!? only if metal slug doesnt lag, they even lagg on new versions, after a certain mame version , and on the newest versions of mame, everything laggg like in auto skip to full blast!

So mame32 plus! 0.88u2 (my fav) nothing lagg! but it doesnt supports the newer games :'(
on advanceMAME 0.106, after burner2 and stuff also lag time, metal slug 5... no issues...

In advanceMAME 0.106... there is no resize_effect... only magnify in the tap menu and auto and runs on 1 but I understand what you mean..

My test results on mame32 plus
MAME32 Plus! 0.74u1 lag free
MAME32 plus 0.83 lag free
MAME32 plus! 0.88u2 - lagg free
mameplus_bin_gcc-0.120 ....work with up to metal slug 4 without lag,,, lagg on other lagg free games from previous versions
Mame32_Plus_0.104 ..hell no
mameplus-0.101u3-bin -hell no
mameplus_bin_gcc-0.106-20060517 metal slug roms all works the rest lagg

MAME32 just have issues..
MAME32 More! 0.84.201 support alot of games, program is just weird and didnt do it for me

also fastmame.. nope!!!! and I dont going to mess around with dll files in my windows folder to make it work..

mame itself... naaah

no-nag versions, i want my loading progress bar

its just a big mess everything...

thats the pain of using old hardware, but hey.. what can I do with a $20 budget, i use the stuff thats there already...  :P ...im doing a massive free favor for a bud who really needs my help
« Last Edit: June 28, 2021, 02:24:52 AM by JayLie »

akafox

  • Hero Member
  • *****
  • Posts: 964
    • View Profile
Re: atrract mode keeps crashing after I installed NVIDIA driver?!!?!?!?
« Reply #13 on: June 28, 2021, 09:06:57 PM »
The only thing I can suggest..if you REEELLLAAAAYYYY want to..and i mean want...

Try an older linux based distro. Make sure you find all the software you need FIRST before attempting this! 

I say this only because I have a I3 dual core I picked up for 99 and honestly it is a pos (though I know you are working with older hardware) it was "made for windows 7" and i can't even fit a graphics card that will fit in it..it will not run any 3-D based games. It was made to be cheap and for office work.

Funny thing is I try to run ANY emulators on it (running WIN10) and none work. Run it in liunx and I can run almost up to dreamcast..but still no 3-D PC games.

But again I say only IF you are willing to go through the hell of doing that with an older machine like that...you said a "P4 1.7Ghz machine"? Maybe try a 32-bit version of ubuntu (14.04 maybe?)...but again that is up to you. It might be a real pain in the tail...but it might pay off.

Good luck!

P.S. I do have to ask in your mame.ini...is it set to 3d3 or software...though i think we covered this...?
People want life easy..then complain about it

JayLie

  • Full Member
  • ***
  • Posts: 31
    • View Profile
Re: atrract mode keeps crashing after I installed NVIDIA driver?!!?!?!?
« Reply #14 on: June 29, 2021, 12:51:50 AM »
lol, they will soon have to rename this thread to emulators and hardware stuff the way we going... :D

oh no.. im not going to start mess around with linux again, Ubuntu is awesome tho and my fav distro, I used it in my AAA radius servers when I used to be a WISP that offered prepaid wifi using prepaid vouchers using credit cards or printed out vouchers, back in the days...before wifi for free everywhere...

that was hell to setup and config....

Code: [Select]
### Windows Direct3D 2D video options ###
d3dtexmanage            1
d3dfilter               1
d3deffectrotate         1
d3deffect               none
d3dprescale             auto
d3dfeedback             0
d3dscan                 100

I run this on my 2 machines with mame32 plus! 0.88u2 ... no laggg, runs fine in my 1.7Ghz celeron and the 1.7Ghz pentuim and it doesnt look so pixelated, thx to that bilinear filter running (doesnt effect performance that I can notice) ....... I'm still stuck on it, if can run on a p3 400Mhz machine up to metal slug 5 without any lagg or frame skip, then it WILL run on my old but faster hardware... but they used DOS on that 200IN1 machine with advancemame.. cant figure out the version... they even packed/compressed it with UPX, and probably any cloning stuff hardcoded in?!?! before I gave up on that project, I copied the latest version of advancemame v3 on that box, and omw.... it was laggging like helll

so I gave up on that boxes, Im just re-using the jamma controllers now...

Have you heard of "MAME32 More! 0.84.233" its a up to date version kinda (Aug 7 2020), looks like mam32 plus! just better, and the controls is mapped all mesedup.. none standard for jamma, and I cant figure out where it saved the stuff once you changed it?!?! I just want to overwrite the remapped keys somehow with standard mame keys.. but it supports stuff like skip any type of error or warning that can be changed in the GUI itself... In earlier version(s) seems to have a bug where the "Mame32m" processes hangs under task manager and it piles up later :o ..i havent yet test this emulator on my 1.7Ghz machines, because im about done with this project but still, but if I find something better, I will update it...

however I would still prefer advancemame aswell, but the screen stretching is messedup and I've found others aswell on threads with the same issue but its super old threads, even on this forum (forum.attractmode.org)..., where all the other mame flavors doesnt have this issue :(

lol and I'm not going to downgrade to DOS
« Last Edit: June 29, 2021, 12:53:42 AM by JayLie »